app-vim/gentoo-syntax: Bump to 20180820
authorMichał Górny <mgorny@gentoo.org>
Mon, 20 Aug 2018 20:50:21 +0000 (22:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 20 Aug 2018 21:06:43 +0000 (23:06 +0200)
Closes: https://bugs.gentoo.org/637104
Closes: https://bugs.gentoo.org/637100
Closes: https://bugs.gentoo.org/605078

app-vim/gentoo-syntax/Manifest
app-vim/gentoo-syntax/gentoo-syntax-20180820.ebuild [new file with mode: 0644]

index 56b96c9e98f1e05d699ad5f31f2052cca252c5f4..e47c36acb7fe222206ed59b7061857b405ce0911 100644 (file)
@@ -1,3 +1,4 @@
 DIST gentoo-syntax-20160530.tar.gz 18950 BLAKE2B 0e769cb4d67ebf1b4299a1aa0dc1bc1ce942a9e6b4f3528b5499ff83ffe9d165697576901c5ba9cca52de6e26abd0298f1f7a5383cdc0c8ca1dff0de2945080c SHA512 38881c5f16499eb053eb7a5514f6324b2a161f1392a044db0bbaf0cb71a0f17e1edebd4a685ff856a78525fbcb8c6267daa2503cfbc6f94d841cf3f6a25045bd
 DIST gentoo-syntax-20170225.tar.gz 18939 BLAKE2B 7586b45791e74e69ad6e0607bc0a4d52eba4747a6c4d9933d43db1196ceb57ac6317279c9e86f77c71bdb7379828dd96fe6d63a2933a3660f1639faf1b6df5d5 SHA512 2c01577910eccd413b85c094dbd12bf8445e2f560be1fffc4a4c3130b32587f9c298d8442b5cf12bd7d2950ab8c9e5b95a72f2f41c42c6dc939ffa2c26fd71d5
 DIST gentoo-syntax-20180814.tar.bz2 18337 BLAKE2B e2808ff4bab17378ac9a15270f32edb67c0a8f4a7e17757d9c128e186fe31add967c169aa9e62fd5fc95dfbadeab72e37c34a14a5452b80c0a1ceafd8bdec85a SHA512 a524a324e3bb1656b2dba9333e03bd130d3700791782d98fed57ea6065f398e4ad29f7980ad823940a44cd1f9f58244b8a908ef4aa3c82c0f7c46882005f358e
+DIST gentoo-syntax-20180820.tar.bz2 18470 BLAKE2B dc536724cd8cf8547b54c7ecc1fc12364ee4542903627e7a3518b9583157d18645e62be519a5d0d0c50f36fe05dfdd19d6999ad049722519f4d6d5707274da44 SHA512 b07fd9b93796a775da0f0fedacbd09cdd30dc414abd05636e96cc0658d1bc12dc5b88cbe4475544f3c79b1a28dacab234cf3c463ddb90bd4e62bec8de4024a57
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20180820.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20180820.ebuild
new file mode 100644 (file)
index 0000000..badfc29
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+       default
+       if use ignore-glep31 ; then
+               for f in ftplugin/*.vim ; do
+                       ebegin "Removing UTF-8 rules from ${f} ..."
+                       sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+                               || die "waah! bad sed voodoo. need more goats."
+                       eend $?
+               done
+       fi
+}
+
+pkg_postinst() {
+       vim-plugin_pkg_postinst
+
+       if [[ -z ${REPLACING_VERSIONS} ]] ; then
+               if use ignore-glep31 1>/dev/null ; then
+                       ewarn "You have chosen to disable the rules which ensure GLEP 31"
+                       ewarn "compliance. When editing ebuilds, please make sure you get"
+                       ewarn "the character set correct."
+               fi
+       fi
+}