xfce-extra/xfswitch-plugin: Add in lxdm support
authorJason Zaman <perfinion@gentoo.org>
Mon, 14 Sep 2015 04:15:55 +0000 (12:15 +0800)
committerJason Zaman <perfinion@gentoo.org>
Mon, 14 Sep 2015 04:16:27 +0000 (12:16 +0800)
Gentoo-Bug: https://bugs.gentoo.org/526598

Package-Manager: portage-2.2.20.1

xfce-extra/xfswitch-plugin/metadata.xml
xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r2.ebuild [new file with mode: 0644]

index f6d547ab548842af1a27a054ba8ec562c656ef01..bd3bfafbabf745babcf48fd38046ff0831b7b11a 100644 (file)
@@ -6,6 +6,8 @@
     <name>XFCE Team</name>
   </maintainer>
   <use>
-    <flag name='gdm'>Use gdmflexiserver from <pkg>gnome-base/gdm</pkg> instead of <pkg>x11-misc/lightdm</pkg></flag>
+    <flag name='gdm'>Compatibility with <pkg>gnome-base/gdm</pkg> only</flag>
+    <flag name='lightdm'>Compatibility with <pkg>x11-misc/lightdm</pkg> only</flag>
+    <flag name='lxdm'>Compatibility with <pkg>lxde-base/lxdm</pkg> only</flag>
   </use>
 </pkgmetadata>
diff --git a/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r2.ebuild b/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r2.ebuild
new file mode 100644 (file)
index 0000000..74b05a4
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A panel plug-in for user switching (using lightdm or gdm or ldm)"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfswitch-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gdm lightdm lxdm"
+
+REQUIRED_USE="
+       gdm? (
+               !lightdm
+               !lxdm
+       )
+
+       lightdm? (
+               !gdm
+               !lxdm
+       )
+       lxdm? (
+               !gdm
+               !lightdm
+       )
+"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
+       >=xfce-base/libxfce4util-4.8
+       >=xfce-base/libxfcegui4-4.8
+       >=xfce-base/xfce4-panel-4.8"
+RDEPEND="${COMMON_DEPEND}
+       gdm? ( gnome-base/gdm )
+       lightdm? ( x11-misc/lightdm )
+       lxdm? ( lxde-base/lxdm )"
+DEPEND="${COMMON_DEPEND}
+       dev-util/intltool
+       virtual/pkgconfig
+       sys-devel/gettext"
+
+pkg_setup() {
+       XFCONF=(
+               --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+               )
+
+       DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+src_prepare() {
+       if use lightdm; then #411921, 526598
+               sed -i \
+                       -e '/command/s:gdmflexiserver --new:/usr/bin/dm-tool switch-to-greeter:' \
+                       panel-plugin/main.c || die
+       elif use lxdm; then
+               sed -i \
+                       -e '/command/s:gdmflexiserver --new:/usr/sbin/lxdm -c USER_SWITCH:' \
+                       panel-plugin/main.c || die
+       fi
+
+       xfconf_src_prepare
+}