media-gfx/openscad: fix automagic deps
authorBernd Waibel <waebbl@gmail.com>
Wed, 22 May 2019 05:52:48 +0000 (07:52 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 19:18:02 +0000 (21:18 +0200)
Fixes issues with automagic dependencies in upstream build system,
where it links against dev-libs/libspnav and dev-libs/hidapi if
they are present on the build host.

Thanks to Phil Stracchino (Unix Ronin) for bringing this up.

Closes: https://bugs.gentoo.org/686354
Reported-by: Phil Stracchino (Unix Ronin) <phils@caerllewys.net>
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Bernd Waibel <waebbl@gmail.com>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-gfx/openscad/openscad-2019.05-r1.ebuild [new file with mode: 0644]

diff --git a/media-gfx/openscad/openscad-2019.05-r1.ebuild b/media-gfx/openscad/openscad-2019.05-r1.ebuild
new file mode 100644 (file)
index 0000000..8991b25
--- /dev/null
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp-common qmake-utils xdg
+
+SITEFILE="50${PN}-gentoo.el"
+
+DESCRIPTION="The Programmers Solid 3D CAD Modeller"
+HOMEPAGE="https://www.openscad.org/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+# FIXME: add optional lib3mf
+RDEPEND="
+       dev-cpp/eigen:3
+       dev-libs/boost:=
+       dev-libs/double-conversion:=
+       dev-libs/glib:2
+       dev-libs/gmp:0=
+       dev-libs/hidapi
+       dev-libs/libspnav
+       dev-libs/libzip:=
+       dev-libs/mpfr:0=
+       dev-qt/qtconcurrent:5
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5[-gles2]
+       dev-qt/qtmultimedia:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtopengl:5
+       dev-qt/qtwidgets:5
+       media-gfx/opencsg
+       media-libs/fontconfig
+       media-libs/freetype
+       >=media-libs/glew-2.0.0:0=
+       media-libs/harfbuzz:=
+       sci-mathematics/cgal:=
+       >=x11-libs/qscintilla-2.10.3:=
+       emacs? ( virtual/emacs )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       sys-devel/bison
+       sys-devel/flex
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       default
+
+       # fix path prefix
+       sed -i "s/\/usr\/local/\/usr/g" ${PN}.pro || die
+}
+
+src_configure() {
+       eqmake5 "${PN}.pro"
+}
+
+src_compile() {
+       default
+
+       if use emacs ; then
+               elisp-compile contrib/*.el
+       fi
+}
+
+src_install() {
+       emake install INSTALL_ROOT="${D}"
+
+       if use emacs; then
+               elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+               elisp-install ${PN} contrib/*.el contrib/*.elc
+       fi
+
+       einstalldocs
+}