app-crypt/gpgme: drop obsolete hacks for Darwin, shorten socketpath length
authorFabian Groffen <grobian@gentoo.org>
Tue, 19 Dec 2017 17:49:09 +0000 (18:49 +0100)
committerFabian Groffen <grobian@gentoo.org>
Tue, 19 Dec 2017 17:49:43 +0000 (18:49 +0100)
Package-Manager: Portage-2.3.13, Repoman-2.3.3

app-crypt/gpgme/gpgme-1.10.0.ebuild

index 513d108c174722043795f775aa8e5678dba720de..d10d5c4e145df4907329a02e62112137ade6a1df 100644 (file)
@@ -48,6 +48,15 @@ pkg_setup() {
        addpredict /run/user/$(id -u)/gnupg
 }
 
+src_prepare() {
+       default
+
+       # Fix too long socket path for gpg-agent, this is mainly a problem
+       # for Prefix, where the builddir is deeper in the FS tree.
+       sed -i -e '/GNUPGHOME/s:$(abs_builddir):'"${T}"':' \
+               tests/gpg/Makefile.{am,in} || die
+}
+
 src_configure() {
        local languages=()
        use common-lisp && languages+=( "cl" )
@@ -59,21 +68,6 @@ src_configure() {
                export MOC="$(qt5_get_bindir)/moc"
        fi
 
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               # FIXME: I don't know how to select on C++11 (libc++) here, but
-               # I do know all Darwin users are using C++11.  This should also
-               # apply to GCC 4.7+ with libc++, and basically anyone targetting
-               # it.
-
-               # The C-standard doesn't define strdup, and C++11 drops it
-               # resulting in an implicit declaration of strdup error.  Since
-               # it is in POSIX raise the feature set to that.
-               append-cxxflags -D_POSIX_C_SOURCE=200112L
-
-               # Work around bug 601834
-               use python && append-cflags -D_DARWIN_C_SOURCE
-       fi
-
        econf \
                --enable-languages="${languages[*]}" \
                $(use_enable static-libs static)