Revert "dev-python/networkx: Add python3 support for pygraphviz"
authorJustin Lecher <jlec@gentoo.org>
Mon, 7 Sep 2015 13:28:48 +0000 (15:28 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 7 Sep 2015 13:33:54 +0000 (15:33 +0200)
This reverts commit 346ac11877ac71834311d6c7d1bdba4e18cce89d.

Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/networkx/networkx-1.10.ebuild

index 23f88cc5a38530526d94947b1ce1034469a1447c..95ff6a288d1d2930314c678c4f3c588bc984d5eb 100644 (file)
@@ -17,8 +17,7 @@ SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
 IUSE="doc examples test"
 
-COMMON_DEPEND="
-       dev-python/matplotlib[${PYTHON_USEDEP}]
+COMMON_DEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
                sci-libs/scipy[${PYTHON_USEDEP}]"
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
@@ -37,7 +36,7 @@ RDEPEND="
        >=dev-python/decorator-3.4.0[${PYTHON_USEDEP}]
        examples? (
                ${COMMON_DEPEND}
-               dev-python/pygraphviz[${PYTHON_USEDEP}]
+               $(python_gen_cond_dep 'dev-python/pygraphviz[${PYTHON_USEDEP}]' python2_7)
                dev-python/pyparsing[${PYTHON_USEDEP}]
                dev-python/pyyaml[${PYTHON_USEDEP}]
        )"