Patch a deadlock observed when both methods of selecting a decoder are disabled.
authorTony Vroon <chainsaw@gentoo.org>
Sat, 6 Jan 2007 14:30:25 +0000 (14:30 +0000)
committerTony Vroon <chainsaw@gentoo.org>
Sat, 6 Jan 2007 14:30:25 +0000 (14:30 +0000)
Package-Manager: portage-2.1.2_rc4-r6

media-sound/audacious/ChangeLog
media-sound/audacious/audacious-1.3.0_alpha1-r1.ebuild [new file with mode: 0644]
media-sound/audacious/files/1.3.0_alpha1-avoid-decoder-selection-deadlock.patch [new file with mode: 0644]
media-sound/audacious/files/digest-audacious-1.3.0_alpha1-r1 [new file with mode: 0644]

index fad559e7a5898cd29e7880cf29a106fc91078bf2..baf98cb4c9913f0c9f446cd6b1bd9e0ba93bdd3d 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for media-sound/audacious
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.97 2007/01/05 10:30:18 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.98 2007/01/06 14:30:25 chainsaw Exp $
+
+*audacious-1.3.0_alpha1-r1 (06 Jan 2007)
+
+  06 Jan 2007; Tony Vroon <chainsaw@gentoo.org>
+  +files/1.3.0_alpha1-avoid-decoder-selection-deadlock.patch,
+  -audacious-1.3.0_alpha1.ebuild, +audacious-1.3.0_alpha1-r1.ebuild:
+  Patch a deadlock observed when both methods of selecting a decoder are
+  disabled.
 
 *audacious-1.3.0_alpha1 (05 Jan 2007)
 
diff --git a/media-sound/audacious/audacious-1.3.0_alpha1-r1.ebuild b/media-sound/audacious/audacious-1.3.0_alpha1-r1.ebuild
new file mode 100644 (file)
index 0000000..3042aa2
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-1.3.0_alpha1-r1.ebuild,v 1.1 2007/01/06 14:30:25 chainsaw Exp $
+
+inherit eutils flag-o-matic
+
+MY_P=${P/_/-}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://audacious-media-player.org/release/${MY_P}.tgz
+        mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="chardet nls gnome"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+       >=gnome-base/libglade-2.3.1
+       dev-libs/libxml2
+       gnome? ( >=gnome-base/gconf-2.6.0 )"
+
+DEPEND="${RDEPEND}
+       nls? ( dev-util/intltool )
+       >=dev-util/pkgconfig-0.9.0"
+
+PDEPEND=">=media-plugins/audacious-plugins-1.3.0_alpha1"
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+       epatch ${FILESDIR}/${PV}-avoid-decoder-selection-deadlock.patch
+}
+
+src_compile() {
+       # Bug #42893
+       replace-flags "-Os" "-O2"
+       # Bug #86689
+       is-flag "-O*" || append-flags -O
+
+       econf \
+               $(use_enable chardet) \
+               $(use_enable nls) \
+               $(use_enable gnome gconf) \
+               || die
+
+       emake || die "make failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die
+       dodoc AUTHORS NEWS README
+
+       # Gentoo_ice skin installation; bug #109772
+       insinto /usr/share/audacious/Skins/gentoo_ice
+       doins "${WORKDIR}"/gentoo_ice/*
+       docinto gentoo_ice
+       dodoc "${WORKDIR}"/README
+}
diff --git a/media-sound/audacious/files/1.3.0_alpha1-avoid-decoder-selection-deadlock.patch b/media-sound/audacious/files/1.3.0_alpha1-avoid-decoder-selection-deadlock.patch
new file mode 100644 (file)
index 0000000..5f689e5
--- /dev/null
@@ -0,0 +1,46 @@
+Index: audacious/playlist.c
+===================================================================
+--- audacious/playlist.c       (revision 3572)
++++ audacious/playlist.c       (working copy)
+@@ -2456,6 +2456,13 @@
+             playlist_get_info_scan_active = FALSE;
+             g_mutex_unlock(mutex_scan);
+         }
++        else /* not on_demand and not on_load...
++                NOTE: this shouldn't happen anymore, sanity check in bmp_config_load now */
++        {
++            g_mutex_lock(mutex_scan);
++            playlist_get_info_scan_active = FALSE;
++            g_mutex_unlock(mutex_scan);
++        }
+         if (update_playlistwin) {
+             playlistwin_update_list(playlist);
+Index: audacious/ui_main.c
+===================================================================
+--- audacious/ui_main.c        (revision 3572)
++++ audacious/ui_main.c        (working copy)
+@@ -3867,7 +3867,7 @@
+ void
+ action_play_file( void )
+ {
+-  util_run_filebrowser(NO_PLAY_BUTTON);
++  util_run_filebrowser(PLAY_BUTTON);
+ }
+ void
+Index: audacious/main.c
+===================================================================
+--- audacious/main.c   (revision 3572)
++++ audacious/main.c   (working copy)
+@@ -604,6 +604,10 @@
+     if (!cfg.session_uri_base)
+         cfg.session_uri_base = g_strdup("");
++
++    /* at least one of these should be true */
++    if ((!cfg.get_info_on_demand) && (!cfg.get_info_on_load))
++        cfg.get_info_on_demand = TRUE;
+ }
diff --git a/media-sound/audacious/files/digest-audacious-1.3.0_alpha1-r1 b/media-sound/audacious/files/digest-audacious-1.3.0_alpha1-r1
new file mode 100644 (file)
index 0000000..285723a
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 037ddc1b36d104af4979b599ba01c32c audacious-1.3.0-alpha1.tgz 1791152
+RMD160 1f12cc2c4def13148b3f5cc233b4663ae2eacc26 audacious-1.3.0-alpha1.tgz 1791152
+SHA256 1dbabe4a6c676194fb3235930e13c5a6e34eb50baf6dff99416a3f9bdf5afdd8 audacious-1.3.0-alpha1.tgz 1791152
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839
+RMD160 11439cbebf8c6dc5745c8593a79e88303d094544 gentoo_ice-xmms-0.2.tar.bz2 51839
+SHA256 d1be63368b76f4a8b1d5b0e955cd7a77177f56a7f0b828c6603d8fd2836422b1 gentoo_ice-xmms-0.2.tar.bz2 51839