media-sound/xnoise: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 16:02:41 +0000 (17:02 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 12 Dec 2019 16:02:41 +0000 (17:02 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/xnoise/files/xnoise-0.2.21-QA-fix-desktop-file.patch [new file with mode: 0644]
media-sound/xnoise/xnoise-0.2.21.ebuild

diff --git a/media-sound/xnoise/files/xnoise-0.2.21-QA-fix-desktop-file.patch b/media-sound/xnoise/files/xnoise-0.2.21-QA-fix-desktop-file.patch
new file mode 100644 (file)
index 0000000..d57cb4b
--- /dev/null
@@ -0,0 +1,54 @@
+--- a/data/misc/xnoise.desktop.in
++++ b/data/misc/xnoise.desktop.in
+@@ -16,24 +16,19 @@
+ [Desktop Action Play]
+ _Name=Play/Pause
+ Exec=xnoise --play-pause
+-OnlyShowIn=Unity;
+ [Desktop Action Stop]
+ _Name=Stop
+ Exec=xnoise --stop
+-OnlyShowIn=Unity;
+ [Desktop Action Next]
+ _Name=Goto next track
+ Exec=xnoise --next
+-OnlyShowIn=Unity;
+ [Desktop Action Previous]
+ _Name=Goto previous track
+ Exec=xnoise --previous
+-OnlyShowIn=Unity;
+ [Desktop Action Quit]
+ _Name=Quit application
+ Exec=xnoise --quit
+-OnlyShowIn=Unity;
+--- a/data/misc/xnoise.desktop.in.in
++++ b/data/misc/xnoise.desktop.in.in
+@@ -16,24 +16,19 @@
+ [Desktop Action Play]
+ _Name=Play/Pause
+ Exec=xnoise --play-pause
+-OnlyShowIn=Unity;
+ [Desktop Action Stop]
+ _Name=Stop
+ Exec=xnoise --stop
+-OnlyShowIn=Unity;
+ [Desktop Action Next]
+ _Name=Goto next track
+ Exec=xnoise --next
+-OnlyShowIn=Unity;
+ [Desktop Action Previous]
+ _Name=Goto previous track
+ Exec=xnoise --previous
+-OnlyShowIn=Unity;
+ [Desktop Action Quit]
+ _Name=Quit application
+ Exec=xnoise --quit
+-OnlyShowIn=Unity;
index d5590f18edb4f3c264d9fe2fde4f8590ddbd353f..facda46f48f55ebc38fbd6e6d680b1d8c9e43e8a 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-inherit xdg-utils gnome2-utils
+EAPI=7
 
-DESCRIPTION="A media player for Gtk+ with a slick GUI, great speed and lots of
-features"
+inherit xdg
+
+DESCRIPTION="A media player for Gtk+ with a slick GUI, great speed and lots of features"
 HOMEPAGE="http://www.xnoise-media-player.com/"
 SRC_URI="https://www.bitbucket.org/shuerhaaken/${PN}/downloads/${P}.tar.gz"
 
@@ -14,60 +14,48 @@ SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE="ayatana +lastfm +lyrics"
 
-RDEPEND="x11-libs/gtk+:3
-       >=dev-libs/glib-2.34:2
+RDEPEND="
+       dev-db/sqlite:3=
+       dev-libs/glib:2
        gnome-base/librsvg:2
-       media-libs/gstreamer:1.0
-       media-libs/gst-plugins-base:1.0
+       media-libs/gstreamer:1.0=
+       media-libs/gst-plugins-base:1.0=
+       media-libs/libtaginfo:=
        media-plugins/gst-plugins-meta:1.0
-       dev-db/sqlite:3
-       >=media-libs/libtaginfo-0.2.0
-       x11-libs/cairo
+       x11-libs/cairo:=
+       x11-libs/gtk+:3
        x11-libs/libX11
-       ayatana? ( dev-libs/libappindicator:3 )
-       lastfm? ( net-libs/libsoup:2.4 )
-       lyrics? ( net-libs/libsoup:2.4
-               dev-libs/libxml2:2 )"
-DEPEND="${RDEPEND}
+       ayatana? ( dev-libs/libappindicator:3= )
+       lastfm? ( net-libs/libsoup:2.4= )
+       lyrics? (
+               net-libs/libsoup:2.4=
+               dev-libs/libxml2:2=
+       )"
+DEPEND="${RDEPEND}"
+BDEPEND="
        dev-util/intltool
-       virtual/pkgconfig
-       sys-devel/gettext"
-
-DOCS=( AUTHORS README )
+       sys-devel/gettext
+       virtual/pkgconfig"
 
-src_prepare() {
-       sed -i -e "/OnlyShowIn/d" data/misc/xnoise.desktop.* || die
-}
+PATCHES=( "${FILESDIR}"/${PN}-0.2.21-QA-fix-desktop-file.patch )
 
 src_configure() {
        econf \
-               $(use_enable ayatana appindicator) \
-               $(use_enable lyrics lyricwiki) \
-               $(use_enable lastfm) \
+               --enable-magnatune \
+               --enable-mediakeys \
                --enable-mpris \
                --enable-soundmenu2 \
-               --enable-mediakeys \
+               $(use_enable ayatana appindicator) \
+               $(use_enable lastfm) \
+               $(use_enable lyrics lyricwiki) \
                $(use_enable lyrics chartlyrics) \
-               $(use_enable lyrics azlyrics) \
-               --enable-magnatune
+               $(use_enable lyrics azlyrics)
 }
 
 src_install() {
        default
-       find "${ED}" -type f -name "*.la" -delete || die
        rm -rf "${ED}"/usr/share/${PN}/license || die
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       xdg_desktop_database_update
-       gnome2_icon_cache_update
-}
 
-pkg_postrm() {
-       xdg_desktop_database_update
-       gnome2_icon_cache_update
+       # no static archives
+       find "${D}" -name '*.la' -delete || die
 }