use new tc-is-softfloat from toolchain-funcs.eclass
authorMike Frysinger <vapier@gentoo.org>
Mon, 12 Feb 2007 05:07:03 +0000 (05:07 +0000)
committerMike Frysinger <vapier@gentoo.org>
Mon, 12 Feb 2007 05:07:03 +0000 (05:07 +0000)
Package-Manager: portage-2.1.2-r9

sys-libs/newlib/newlib-1.14.0.ebuild
sys-libs/newlib/newlib-1.15.0.ebuild
sys-libs/newlib/newlib-20061203.ebuild
sys-libs/uclibc/uclibc-0.9.27-r1.ebuild
sys-libs/uclibc/uclibc-0.9.28-r1.ebuild
sys-libs/uclibc/uclibc-0.9.28-r2.ebuild
sys-libs/uclibc/uclibc-0.9.28.1.ebuild
sys-libs/uclibc/uclibc-0.9.28.ebuild

index 13f66009aa2dab3091f96a5b75fa3743b4696c36..5f6cfbfc7fabda785f36a6939e41865d13d42d17 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.14.0.ebuild,v 1.3 2006/11/06 00:37:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.14.0.ebuild,v 1.4 2007/02/12 05:05:23 vapier Exp $
 
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
 
 export CBUILD=${CBUILD:-${CHOST}}
 export CTARGET=${CTARGET:-${CHOST}}
@@ -48,7 +48,7 @@ src_compile() {
 
        local myconf=""
        # hardwired to avoid breakages
-       [[ ${CTARGET} == *-softfloat-* ]] \
+       [[ $(tc-is-softfloat) == "no" ]] \
                && myconf="--disable-newlib-hw-fp" \
                || myconf="--enable-newlib-hw-fp"
        [[ ${CTARGET} == "spu" ]] \
index a8052369d89f1a7186d9c7dc733e467a5df1e39b..3c2d6b612097812d3eee35893b2b9431188d59ea 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.15.0.ebuild,v 1.2 2007/02/05 14:51:50 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.15.0.ebuild,v 1.3 2007/02/12 05:05:23 vapier Exp $
 
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
 
 export CBUILD=${CBUILD:-${CHOST}}
 export CTARGET=${CTARGET:-${CHOST}}
@@ -46,7 +46,7 @@ src_compile() {
 
        local myconf=""
        # hardwired to avoid breakages
-       [[ ${CTARGET//_/-} == *-softfloat-* ]] \
+       [[ $(tc-is-softfloat) == "no" ]] \
                && myconf="--disable-newlib-hw-fp" \
                || myconf="--enable-newlib-hw-fp"
        [[ ${CTARGET} == "spu" ]] \
index 1fe00a3f7532d72433b5972e186b2e9074b3e5ae..46725a20e42857de8d1288ca0788d508ebfd8007 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-20061203.ebuild,v 1.2 2006/12/10 00:46:54 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-20061203.ebuild,v 1.3 2007/02/12 05:05:23 vapier Exp $
 
-inherit eutils flag-o-matic
+inherit eutils flag-o-matic toolchain-funcs
 
 export CBUILD=${CBUILD:-${CHOST}}
 export CTARGET=${CTARGET:-${CHOST}}
@@ -47,7 +47,7 @@ src_compile() {
 
        local myconf=""
        # hardwired to avoid breakages
-       [[ ${CTARGET} == *-softfloat-* ]] \
+       [[ $(tc-is-softfloat) == "no" ]] \
                && myconf="--disable-newlib-hw-fp" \
                || myconf="--enable-newlib-hw-fp"
        [[ ${CTARGET} == "spu" ]] \
index d211080944846ded39e7128d1ce28af5f8d24e60..3f94da3910022eb68aecf41f9f618ce4b5f98670 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.23 2007/01/28 06:54:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.27-r1.ebuild,v 1.24 2007/02/12 05:07:03 vapier Exp $
 
 inherit eutils flag-o-matic toolchain-funcs
 
@@ -184,7 +184,7 @@ src_unpack() {
        sed -i -e '/ARCH_.*_ENDIAN/d' .config
        echo "ARCH_$(uclibc_endian | tr [a-z] [A-Z])_ENDIAN=y" >> .config
 
-       if [[ ${CTARGET//_/-} == *-softfloat-* ]] ; then
+       if [[ $(tc-is-softfloat) != "yes" ]] ; then
                sed -i -e '/^HAS_FPU=y$/d' .config
                echo 'HAS_FPU=n' >> .config
        fi
index 9447113de7fe0a369609b32673806ce7cb3c6bcd..87bde5626e22aff882b3333013f5646fd7faa07e 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild,v 1.8 2007/01/28 06:54:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r1.ebuild,v 1.9 2007/02/12 05:07:03 vapier Exp $
 
 #ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
 #inherit subversion
@@ -204,7 +204,7 @@ src_unpack() {
        sed -i -e '/ARCH_.*_ENDIAN/d' .config
        echo "ARCH_$(uclibc_endian | tr [a-z] [A-Z])_ENDIAN=y" >> .config
 
-       if [[ ${CTARGET//_/-} == *-softfloat-* ]] ; then
+       if [[ $(tc-is-softfloat) != "yes" ]] ; then
                sed -i -e '/^HAS_FPU=y$/d' .config
                echo 'HAS_FPU=n' >> .config
        fi
index 6d3024fd50ddfedad7c12b0a739e7ddd3ad71b56..df5236fc598fe5efda22bae9ce370aa09c17b951 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild,v 1.3 2007/01/28 06:54:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28-r2.ebuild,v 1.4 2007/02/12 05:07:03 vapier Exp $
 
 #ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
 #inherit subversion
@@ -204,7 +204,7 @@ src_unpack() {
        sed -i -e '/ARCH_.*_ENDIAN/d' .config
        echo "ARCH_$(uclibc_endian | tr [a-z] [A-Z])_ENDIAN=y" >> .config
 
-       if [[ ${CTARGET//_/-} == *-softfloat-* ]] ; then
+       if [[ $(tc-is-softfloat) != "yes" ]] ; then
                sed -i -e '/^HAS_FPU=y$/d' .config
                echo 'HAS_FPU=n' >> .config
        fi
index f4bdc0a5bec24add78a884e6d1903b7181d6c5fc..632e227b547745bc21135457996afec1ebe80c10 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.1.ebuild,v 1.1 2007/01/28 08:16:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.1.ebuild,v 1.2 2007/02/12 05:07:03 vapier Exp $
 
 #ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
 #inherit subversion
@@ -205,7 +205,7 @@ src_unpack() {
        sed -i -e '/ARCH_.*_ENDIAN/d' .config
        echo "ARCH_$(uclibc_endian | tr [a-z] [A-Z])_ENDIAN=y" >> .config
 
-       if [[ ${CTARGET//_/-} == *-softfloat-* ]] ; then
+       if [[ $(tc-is-softfloat) != "yes" ]] ; then
                sed -i -e '/^HAS_FPU=y$/d' .config
                echo 'HAS_FPU=n' >> .config
        fi
index 27674ba2688992d8797c3e054f94d828044f0d25..70a6c5fde8e0280e08618d26d69a3e2bcf183212 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.28 2007/01/28 06:54:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.29 2007/02/12 05:07:03 vapier Exp $
 
 #ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
 #inherit subversion
@@ -204,7 +204,7 @@ src_unpack() {
        sed -i -e '/ARCH_.*_ENDIAN/d' .config
        echo "ARCH_$(uclibc_endian | tr [a-z] [A-Z])_ENDIAN=y" >> .config
 
-       if [[ ${CTARGET//_/-} == *-softfloat-* ]] ; then
+       if [[ $(tc-is-softfloat) != "yes" ]] ; then
                sed -i -e '/^HAS_FPU=y$/d' .config
                echo 'HAS_FPU=n' >> .config
        fi