www-client/dooble: Bump to 1.56c
authorRichard Yao <ryao@gentoo.org>
Wed, 22 Feb 2017 04:38:38 +0000 (23:38 -0500)
committerRichard Yao <ryao@gentoo.org>
Wed, 22 Feb 2017 04:49:21 +0000 (23:49 -0500)
This introduces optional Qt5 support. It is enabled when USE=-qt4 is
set.

Package-Manager: Portage-2.3.3

Signed-off-by: Richard Yao <ryao@gentoo.org>
www-client/dooble/Manifest
www-client/dooble/dooble-1.56c.ebuild [new file with mode: 0644]
www-client/dooble/metadata.xml

index 56022b38614e46fba48b5615e910d946f7855956..8ee2de4232698fa88f8a798be24898f527364c5f 100644 (file)
@@ -1 +1,2 @@
 DIST dooble-1.55.tar.gz 11663614 SHA256 024003e7c397a925d48e41cba10a2a35b89dd1745120caf4fd2010c1e254c5e5 SHA512 413727f74ab7fba89f7b617a774a0dceaa8a03b826f12950e31ca3fedda7e607539759b946eacccd57087429e6a37acd967a2c376b0b195b560c8c9beaf4e3d6 WHIRLPOOL ebe0b69a3dde0c0977c6295c6c67811195ca6d4e66dd95d09b51eae7da32170f737e62275e17020213c640e10a368f3792c8d34b495f15ee004e7a644a914700
+DIST dooble-1.56c.tar.gz 12218062 SHA256 03b5bb0460aa8f4f731a47b70c571942a186fb0e7c4b74f546cef356be0afe6a SHA512 6a42eed4320437b0e43020d661963ff385fd08dd225f96337d778bca13aec85df3a49eb6cb0f7bd9ae26a8822df62dd580b407ed27c6df58bd0720a50867aa42 WHIRLPOOL bca7982447ed0d64c2f19c7d208869cc740866683bb056b6fb635c0585e1b5aed63a2c421027bf2e8fb8daca68604c23c525bca487c82b5c59b9fc72103ef622
diff --git a/www-client/dooble/dooble-1.56c.ebuild b/www-client/dooble/dooble-1.56c.ebuild
new file mode 100644 (file)
index 0000000..dff50cb
--- /dev/null
@@ -0,0 +1,89 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils qmake-utils fdo-mime
+DESCRIPTION="A Secure and Open Source Web Browser"
+HOMEPAGE="http://dooble.sourceforge.net/"
+
+SRC_URI="mirror://sourceforge/${PN}/Version%20${PV}/Dooble.d.tar.gz ->
+${P}.tar.gz"
+
+# icon sets are GPL-3 LGPL-2.1 while the code is BSD
+LICENSE="BSD GPL-3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="qt4"
+DEPEND="dev-db/sqlite:3
+       dev-libs/libgcrypt:0
+       dev-libs/libgpg-error
+       qt4? (
+               dev-qt/qtcore:4
+               dev-qt/qtgui:4
+               dev-qt/qtsql:4
+               dev-qt/qtwebkit:4
+       )
+       !qt4? (
+               dev-qt/linguist-tools:5
+               dev-qt/qtconcurrent:5
+               dev-qt/qtcore:5
+               dev-qt/qtdeclarative:5
+               dev-qt/qtgui:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtsql:5
+               dev-qt/qtwebkit:5
+               dev-qt/qtxml:5
+       )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/dooble.d/Version 1.x/"
+
+src_prepare() {
+       # Adjust paths from FreeBSD locations to Gentoo locations
+       # XXX: Fix the build system to be more flexible and upstream fix
+       sed -i -e 's/\(dooble.path[[:space:]]*= \)\(.*\)$/\1\/usr\/bin/' \
+               -e 's/\(dooble_sh.path[[:space:]]*= \)\(.*\)$/\1\/usr\/share\/dooble/' \
+               -e 's/\(icons.path[[:space:]]*= \)\(.*\)$/\1\/usr\/share\/dooble/' \
+               -e 's/\(images.path[[:space:]]*= \)\(.*\)$/\1\/usr\/share\/dooble/' \
+               -e 's/\(spoton_install.path[[:space:]]*= \)\(.*\)$/\1\/usr\/lib/' \
+               -e 's/\(pluginsdir.path[[:space:]]*= \)\(.*\)$/\1\/usr\/lib\/nsbrowser\/plugins/' \
+               -e 's/\(plugspec.path[[:space:]]*= \)\(.*\)$/\1\/usr\/include\/dooble\/plugin-spec/' \
+               -e 's/\(postinstall.path[[:space:]]*= \)\(.*\)$/\1\/usr\/share\/dooble/' \
+               -e 's/\(tab.path[[:space:]]*= \)\(.*\)$/\1\/usr\/share\/dooble/' \
+               dooble.pro dooble.qt5.pro
+
+       sed -i -e "s:\"Icons:\"${EROOT}usr/share/dooble/Icons:" \
+               ./Source/dsettings.cc
+       sed -i -e '/export/d' -e "s:/usr/local/dooble/Dooble:${EROOT}usr/bin/Dooble:g" \
+               -e "s:cd /usr/local/dooble:cd /usr/share/dooble:" \
+               -e "s:exec ./Dooble:exec ${EROOT}usr/bin/Dooble:" ./dooble.sh
+       sed -i -e "s:/usr/local:${EROOT}/usr/share:" -e 's:/text/xml:text/xml:' \
+               ./dooble.desktop
+}
+
+src_configure() {
+       use qt4 && eqmake4 dooble.pro || eqmake5 dooble.qt5.pro
+}
+
+src_install() {
+       dohtml Documentation/RELEASE-NOTES.html
+       dodoc Documentation/{THEMES,TO-DO}
+       dosym ../share/dooble/dooble.sh /usr/bin/dooble
+       dosym ../../lib/nsbrowser/plugins /usr/share/dooble/Plugins
+       dolib.so libSpotOn/libspoton.so
+       emake INSTALL_ROOT="${ED}" install
+
+       # XXX: The build system installs the build path into INSTALL_ROOT.
+       # It should be fixed not to do this.
+       rm -r "${ED}/var" || die "Failed to remove build path from ${ED}"
+}
+
+pkg_postinst() {
+       fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+       fdo-mime_desktop_database_update
+}
index 3a62b649ccd331dc46b07a718fa2771fd143b6d2..c7cdf0d005931e7893e7b6241ca4f81e8f6e4f5e 100644 (file)
@@ -5,6 +5,9 @@
                <email>ryao@gentoo.org</email>
                <name>Richard Yao</name>
        </maintainer>
+       <use>
+               <flag name="qt4">Build using qt4 instead of qt5</flag>
+       </use>
        <upstream>
                <remote-id type="sourceforge">dooble</remote-id>
        </upstream>