dev-python/sphinxcontrib-htmlhelp: Add missing test-dep on html5lib
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 08:57:33 +0000 (10:57 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 09:03:19 +0000 (11:03 +0200)
Closes: https://bugs.gentoo.org/720826
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/sphinxcontrib-htmlhelp/sphinxcontrib-htmlhelp-1.0.3.ebuild

index ef105cf43f4166e5b902ed8b484ea850578aec05..8feabb3f71a24a846d22d9ccef60ee9cd1e54a8a 100644 (file)
@@ -18,9 +18,11 @@ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sp
 RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
 PDEPEND="
        >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( ${PDEPEND} )"
+BDEPEND="
+       test? (
+               ${PDEPEND}
+               dev-python/html5lib[${PYTHON_USEDEP}]
+       )"
 
 distutils_enable_tests pytest