sys-boot/gnu-efi: drop old
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 1 Apr 2020 21:01:48 +0000 (22:01 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 1 Apr 2020 21:14:10 +0000 (22:14 +0100)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-boot/gnu-efi/Manifest
sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild [deleted file]
sys-boot/gnu-efi/gnu-efi-3.0.6-r2.ebuild [deleted file]
sys-boot/gnu-efi/gnu-efi-3.0.9.ebuild [deleted file]

index 2aba1143677f3c5e7d25180746c07dc3bd9f63f3..0e4ed33baf6455a5b65b7ee823f67794f4fe1b46 100644 (file)
@@ -1,4 +1 @@
 DIST gnu-efi-3.0.11.tar.bz2 154456 BLAKE2B dd8d5100ee65e2f94d6b67f0d2236674c7c2b6f553ac0b2d8fdc83e49c69bec0dce1e2e8730705f70b3b7b0a61e4f065773667945ffc92a6f40eba381fcf6723 SHA512 1a6b06b69eb95e03c00fb1c476bf346ab2cb0ecca9a44e163f52f2aa4b9837d3dd2d3ed8b4ce77aaf32a66e49f826ea5b43a97c8c7c56aaa030bc20b3415122a
-DIST gnu-efi-3.0.3.tar.bz2 142229 BLAKE2B 5230e99358fc2c1a85fd56840a9ddbd4d1cb42d15a8c37dd44e87037e45a1033f1014c953b5a4d2bb565c4be5aa67a3982ca64e575aaae9c1ae64ce27659b642 SHA512 0b0582e22344ea8a544aba540b56dc36364febfeb5bb655e87277e638fd4e549214a0cd2079a852d15ee376cd51c33794f65a7efb23be9a7a929e889cd616c8c
-DIST gnu-efi-3.0.6.tar.bz2 152088 BLAKE2B 2cb1d72f6972a86e913fba28a86e95a1b0baf15251d8fa3d4c335a13e5fd929b61f8f421330acbddbc640efd63594713180b7fc3e623fda2397947538a25b795 SHA512 f1b17766d8ae000c0177ea2126d87883f254ab01ac020e4bfaa9ad2d3d60a66d07b6237d9842e5989c4da3fd23152b5c592ef863fdc9806901f43c43582a2258
-DIST gnu-efi-3.0.9.tar.bz2 154445 BLAKE2B 099af13ff8944d6d362fd4f1dfaf7eff477e7105298651295a63493eb54799459649a977b3b0600e9884b48f8119ecf1faa38d35e0b01086076de40beefbcbcc SHA512 1a775476fcbe354e57c9db258b1c6ad4346b84d1794178ab5d5195b3ffba250066ca4c42a553d5b2866fa1b4e03019d61df0197f269188c73297042990adf316
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.3.ebuild
deleted file mode 100644 (file)
index cb25553..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Library for build EFI Applications"
-HOMEPAGE="http://gnu-efi.sourceforge.net/"
-SRC_URI="mirror://sourceforge/gnu-efi/${P}.tar.bz2"
-
-# inc/, lib/ dirs (README.efilib)
-# - BSD-2
-# gnuefi dir:
-# - BSD (3-cluase): crt0-efi-ia32.S
-# - GPL-2+ : setjmp_ia32.S
-LICENSE="GPL-2+ BSD BSD-2"
-SLOT="0"
-# IA64 build is broken in setjmp code:
-# https://sourceforge.net/p/gnu-efi/bugs/9/
-KEYWORDS="-* amd64 ~arm ~arm64 -ia64 x86"
-IUSE="abi_x86_32 abi_x86_64"
-
-DEPEND="sys-apps/pciutils"
-RDEPEND=""
-
-# These objects get run early boot (i.e. not inside of Linux),
-# so doing these QA checks on them doesn't make sense.
-QA_EXECSTACK="usr/*/lib*efi.a:* usr/*/crt*.o"
-RESTRICT="strip"
-
-efimake() {
-       local arch=
-       case ${CHOST} in
-               arm*) arch=arm ;;
-               aarch64*) arch=aarch64 ;;
-               ia64*) arch=ia64 ;;
-               i?86*) arch=ia32 ;;
-               x86_64*) arch=x86_64 ;;
-               *) die "Unknown CHOST" ;;
-       esac
-
-       local args=(
-               ARCH="${arch}"
-               HOSTCC="${BUILD_CC}"
-               CC="${CC}"
-               AS="${AS}"
-               LD="${LD}"
-               AR="${AR}"
-               PREFIX="${EPREFIX}/usr"
-               LIBDIR='$(PREFIX)'/$(get_libdir)
-       )
-       emake -j1 "${args[@]}" "$@"
-}
-
-src_compile() {
-       tc-export BUILD_CC AR AS CC LD
-
-       # https://bugs.gentoo.org/607992
-       filter-mfpmath sse
-
-       if [[ ${CHOST} == x86_64* ]]; then
-               use abi_x86_32 && CHOST=i686 ABI=x86 efimake
-               use abi_x86_64 && efimake
-       else
-               efimake
-       fi
-}
-
-src_install() {
-       if [[ ${CHOST} == x86_64* ]]; then
-               use abi_x86_32 && CHOST=i686 ABI=x86 efimake INSTALLROOT="${D}" install
-               use abi_x86_64 && efimake INSTALLROOT="${D}" install
-       else
-               efimake INSTALLROOT="${D}" install
-       fi
-       dodoc README* ChangeLog
-}
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.6-r2.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.6-r2.ebuild
deleted file mode 100644 (file)
index 03f00a2..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Library for build EFI Applications"
-HOMEPAGE="http://gnu-efi.sourceforge.net/"
-SRC_URI="mirror://sourceforge/gnu-efi/${P}.tar.bz2"
-
-# inc/, lib/ dirs (README.efilib)
-# - BSD-2
-# gnuefi dir:
-# - BSD (3-cluase): crt0-efi-ia32.S
-# - GPL-2+ : setjmp_ia32.S
-LICENSE="GPL-2+ BSD BSD-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~arm ~arm64 ia64 ~x86"
-IUSE="abi_x86_32 abi_x86_64 -custom-cflags"
-
-DEPEND="sys-apps/pciutils"
-RDEPEND=""
-
-# These objects get run early boot (i.e. not inside of Linux),
-# so doing these QA checks on them doesn't make sense.
-QA_EXECSTACK="usr/*/lib*efi.a:* usr/*/crt*.o"
-RESTRICT="strip"
-
-PATCHES=(
-       "${FILESDIR}"/${P}-ia64-gnu-hash.patch
-       "${FILESDIR}"/${P}-ia64-setjmp.patch
-)
-
-src_prepare() {
-       sed -i -e "s/-Werror//" Make.defaults || die
-       default
-}
-
-efimake() {
-       local arch=
-       case ${CHOST} in
-               arm*) arch=arm ;;
-               aarch64*) arch=aarch64 ;;
-               ia64*) arch=ia64 ;;
-               i?86*) arch=ia32 ;;
-               x86_64*) arch=x86_64 ;;
-               *) die "Unknown CHOST" ;;
-       esac
-
-       local args=(
-               ARCH="${arch}"
-               HOSTCC="${BUILD_CC}"
-               CC="${CC}"
-               AS="${AS}"
-               LD="${LD}"
-               AR="${AR}"
-               PREFIX="${EPREFIX}/usr"
-               LIBDIR='$(PREFIX)'/$(get_libdir)
-       )
-       emake -j1 "${args[@]}" "$@"
-}
-
-src_compile() {
-       tc-export BUILD_CC AR AS CC LD
-
-       if use custom-cflags; then
-               # https://bugs.gentoo.org/607992
-               filter-mfpmath sse
-
-               # https://bugs.gentoo.org/619628
-               append-flags $(test-flags-CC -mno-avx)
-       else
-               unset CFLAGS CPPFLAGS LDFLAGS
-       fi
-
-       if [[ ${CHOST} == x86_64* ]]; then
-               use abi_x86_32 && CHOST=i686 ABI=x86 efimake
-               use abi_x86_64 && efimake
-       else
-               efimake
-       fi
-}
-
-src_install() {
-       if [[ ${CHOST} == x86_64* ]]; then
-               use abi_x86_32 && CHOST=i686 ABI=x86 efimake INSTALLROOT="${D}" install
-               use abi_x86_64 && efimake INSTALLROOT="${D}" install
-       else
-               efimake INSTALLROOT="${D}" install
-       fi
-       einstalldocs
-}
diff --git a/sys-boot/gnu-efi/gnu-efi-3.0.9.ebuild b/sys-boot/gnu-efi/gnu-efi-3.0.9.ebuild
deleted file mode 100644 (file)
index 57a9ed6..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 2004-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Library for build EFI Applications"
-HOMEPAGE="http://gnu-efi.sourceforge.net/"
-SRC_URI="mirror://sourceforge/gnu-efi/${P}.tar.bz2"
-
-# inc/, lib/ dirs (README.efilib)
-# - BSD-2
-# gnuefi dir:
-# - BSD (3-cluase): crt0-efi-ia32.S
-# - GPL-2+ : setjmp_ia32.S
-LICENSE="GPL-2+ BSD BSD-2"
-SLOT="0"
-KEYWORDS="-* ~amd64 ~arm ~arm64 ~ia64 ~x86"
-IUSE="abi_x86_32 abi_x86_64 custom-cflags"
-
-# These objects get run early boot (i.e. not inside of Linux),
-# so doing these QA checks on them doesn't make sense.
-QA_EXECSTACK="usr/*/lib*efi.a:* usr/*/crt*.o"
-RESTRICT="strip"
-
-PATCHES=( "${FILESDIR}"/${PN}-3.0.9-fix-clang-build.patch )
-
-src_prepare() {
-       default
-       sed -i -e "s/-Werror//" Make.defaults || die
-}
-
-efimake() {
-       local arch=
-       case ${CHOST} in
-               arm*) arch=arm ;;
-               aarch64*) arch=aarch64 ;;
-               ia64*) arch=ia64 ;;
-               i?86*) arch=ia32 ;;
-               x86_64*) arch=x86_64 ;;
-               *) die "Unknown CHOST" ;;
-       esac
-
-       local args=(
-               ARCH="${arch}"
-               HOSTCC="${BUILD_CC}"
-               CC="${CC}"
-               AS="${AS}"
-               LD="${LD}"
-               AR="${AR}"
-               PREFIX="${EPREFIX}/usr"
-               LIBDIR='$(PREFIX)'/$(get_libdir)
-       )
-       emake -j1 "${args[@]}" "$@"
-}
-
-src_compile() {
-       tc-export BUILD_CC AR AS CC LD
-
-       if use custom-cflags; then
-               # https://bugs.gentoo.org/607992
-               filter-mfpmath sse
-
-               # https://bugs.gentoo.org/619628
-               append-flags $(test-flags-CC -mno-avx)
-       else
-               unset CFLAGS CPPFLAGS LDFLAGS
-       fi
-
-       if [[ ${CHOST} == x86_64* ]]; then
-               use abi_x86_32 && CHOST=i686 ABI=x86 efimake
-               use abi_x86_64 && efimake
-       else
-               efimake
-       fi
-}
-
-src_install() {
-       if [[ ${CHOST} == x86_64* ]]; then
-               use abi_x86_32 && CHOST=i686 ABI=x86 efimake INSTALLROOT="${D}" install
-               use abi_x86_64 && efimake INSTALLROOT="${D}" install
-       else
-               efimake INSTALLROOT="${D}" install
-       fi
-       einstalldocs
-}