dev-python/PyPDF2: Unrestrict test phase in response to reply from upstream
authorIan Delaney <idella4@gentoo.org>
Fri, 21 Aug 2015 01:02:59 +0000 (09:02 +0800)
committerIan Delaney <idella4@gentoo.org>
Fri, 21 Aug 2015 01:02:59 +0000 (09:02 +0800)
Package-Manager: portage-2.2.20

dev-python/PyPDF2/PyPDF2-1.25.1.ebuild

index 4409d3770783c1a20362644914a5b5f8d758457b..63f5b8ad6f40e3cc2f40f26f13087c55707dd0f5 100644 (file)
@@ -16,11 +16,13 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="examples"
 
-# https://github.com/mstamy2/PyPDF2/issues/216
-RESTRICT="test"
-
 python_test() {
-        "${PYTHON}" -m unittest Tests.tests
+       # https://github.com/mstamy2/PyPDF2/issues/216
+       einfo ""; einfo "According to the author, this 1 failed test is an"
+       einfo "expected failure meaning the installation of PyPDF2 is working"
+       einfo "He plans to update the causative file to see it pass"; einfo ""
+
+        "${PYTHON}" -m unittest Tests.tests || die "Tests failed under ${EPYTHON}"
 }
 
 python_install_all() {