x11-wm/mutter: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sat, 3 Oct 2015 09:05:23 +0000 (11:05 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 3 Oct 2015 09:05:23 +0000 (11:05 +0200)
Package-Manager: portage-2.2.22

x11-wm/mutter/Manifest
x11-wm/mutter/files/mutter-3.16.2-size-unredirected.patch [deleted file]
x11-wm/mutter/mutter-3.16.2-r1.ebuild [deleted file]
x11-wm/mutter/mutter-3.16.2.ebuild [deleted file]
x11-wm/mutter/mutter-3.16.3-r1.ebuild

index 3633659d5a24cf6c780bff8a8f792d9e6ff1fa16..43311d2ab86032edc007ccce51d6cc3c8b5b1313 100644 (file)
@@ -1,3 +1,2 @@
 DIST mutter-3.14.4.tar.xz 1608836 SHA256 b4fbcc0664484d6215fc1f2101e9b636303de63544b786f2f87ebf2f6a616a8b SHA512 5b6e2d969e9a328e23bedb9fd0409da1af0d2ae8ded6a940992d4cff18a8cbfe2aa6582a56a2c8bd549a560a84d8cbffe953f151bcadf235315b8ec8bc7d1267 WHIRLPOOL 45c0329832999f14a5eaa77df3a6c7bbc72556b779fc55b3db9505594efec40252996bf8d96083da47fdb67b6bf5a9402f526d8bbb1e5436e5de16a8520e4acf
-DIST mutter-3.16.2.tar.xz 1549760 SHA256 4a2b752f0b3aa59f50563190222623324f5154acbb6bf174213f5849e77d0763 SHA512 f2cd350f8dbd03bc8e58f6c3f1b48cd51b38ae56e020d4e02100ef02f003d797a20095acf6a8874563fde42cfde49c4a28c418af151ee49f24ed391d5ae3caba WHIRLPOOL a88badf1f59c8c6ba8dcde4af207a2e66e66abbd6fd6c436289591bbb6eb3b017f50a7122282b69fd7d55127029e7623b7cbca3467d2d25d95c8ff6077dc371b
 DIST mutter-3.16.3.tar.xz 1550004 SHA256 ee0098487d1bfb8f28e3927fbb9df227d846555142d352f8693f56a08441c755 SHA512 31b6319c605d2576bf179e01534fe886a997677c63f19fa5d4a2d71e616a02de89d3edb069a444fb84c6fdf5a471afa2bda1d835c07e5d6dce712b2485e5937d WHIRLPOOL 23cc5161edb108137c9c983551b57659fc02c179bc7e08abebd5b26b98dcc1a17e00579a6b1e9f6fc544a92a877282fa1202a6390a14ef92ca6374dae1750112
diff --git a/x11-wm/mutter/files/mutter-3.16.2-size-unredirected.patch b/x11-wm/mutter/files/mutter-3.16.2-size-unredirected.patch
deleted file mode 100644 (file)
index 0999ebd..0000000
+++ /dev/null
@@ -1,151 +0,0 @@
-From 351f444f9d16a90636feb217b15f0f376bf96d85 Mon Sep 17 00:00:00 2001
-From: "Jasper St. Pierre" <jstpierre@mecheye.net>
-Date: Tue, 23 Jun 2015 16:23:45 -0700
-Subject: surface-actor-x11: Make sure to set a size when unredirected
-
-When we're unredirected, we don't have a pixmap, and thus our allocation
-becomes 0x0. So when events come in, they pass right through our actor,
-going to the one underneath in the stack.
-
-Fix this by having a fallback size on the shaped texture actor when
-we're unredirected, causing it to always have a valid allocation.
-
-This fixes clicking on stuff in sloppy / mouse mode focus.
-
-diff --git a/src/compositor/meta-shaped-texture-private.h b/src/compositor/meta-shaped-texture-private.h
-index 4ee8027..21c6335 100644
---- a/src/compositor/meta-shaped-texture-private.h
-+++ b/src/compositor/meta-shaped-texture-private.h
-@@ -32,6 +32,9 @@
- ClutterActor *meta_shaped_texture_new (void);
- void meta_shaped_texture_set_texture (MetaShapedTexture *stex,
-                                       CoglTexture       *texture);
-+void meta_shaped_texture_set_fallback_size (MetaShapedTexture *stex,
-+                                            guint              fallback_width,
-+                                            guint              fallback_height);
- gboolean meta_shaped_texture_is_obscured (MetaShapedTexture *self);
- #endif
-diff --git a/src/compositor/meta-shaped-texture.c b/src/compositor/meta-shaped-texture.c
-index 163c5e6..8701d1b 100644
---- a/src/compositor/meta-shaped-texture.c
-+++ b/src/compositor/meta-shaped-texture.c
-@@ -86,6 +86,7 @@ struct _MetaShapedTexturePrivate
-   cairo_region_t *unobscured_region;
-   guint tex_width, tex_height;
-+  guint fallback_width, fallback_height;
-   guint create_mipmaps : 1;
- };
-@@ -136,7 +137,20 @@ set_unobscured_region (MetaShapedTexture *self,
-   g_clear_pointer (&priv->unobscured_region, (GDestroyNotify) cairo_region_destroy);
-   if (unobscured_region)
-     {
--      cairo_rectangle_int_t bounds = { 0, 0, priv->tex_width, priv->tex_height };
-+      guint width, height;
-+
-+      if (priv->texture)
-+        {
-+          width = priv->tex_width;
-+          height = priv->tex_height;
-+        }
-+      else
-+        {
-+          width = priv->fallback_width;
-+          height = priv->fallback_height;
-+        }
-+
-+      cairo_rectangle_int_t bounds = { 0, 0, width, height };
-       priv->unobscured_region = cairo_region_copy (unobscured_region);
-       cairo_region_intersect_rectangle (priv->unobscured_region, &bounds);
-     }
-@@ -499,16 +513,21 @@ meta_shaped_texture_get_preferred_width (ClutterActor *self,
-                                          gfloat       *natural_width_p)
- {
-   MetaShapedTexturePrivate *priv;
-+  guint width;
-   g_return_if_fail (META_IS_SHAPED_TEXTURE (self));
-   priv = META_SHAPED_TEXTURE (self)->priv;
--  if (min_width_p)
--    *min_width_p = priv->tex_width;
-+  if (priv->texture)
-+    width = priv->tex_width;
-+  else
-+    width = priv->fallback_width;
-+  if (min_width_p)
-+    *min_width_p = width;
-   if (natural_width_p)
--    *natural_width_p = priv->tex_width;
-+    *natural_width_p = width;
- }
- static void
-@@ -518,16 +537,21 @@ meta_shaped_texture_get_preferred_height (ClutterActor *self,
-                                           gfloat       *natural_height_p)
- {
-   MetaShapedTexturePrivate *priv;
-+  guint height;
-   g_return_if_fail (META_IS_SHAPED_TEXTURE (self));
-   priv = META_SHAPED_TEXTURE (self)->priv;
--  if (min_height_p)
--    *min_height_p = priv->tex_height;
-+  if (priv->texture)
-+    height = priv->tex_height;
-+  else
-+    height = priv->fallback_height;
-+  if (min_height_p)
-+    *min_height_p = height;
-   if (natural_height_p)
--    *natural_height_p = priv->tex_height;
-+    *natural_height_p = height;
- }
- static cairo_region_t *
-@@ -860,6 +884,17 @@ meta_shaped_texture_get_image (MetaShapedTexture     *stex,
-   return surface;
- }
-+void
-+meta_shaped_texture_set_fallback_size (MetaShapedTexture *self,
-+                                       guint              fallback_width,
-+                                       guint              fallback_height)
-+{
-+  MetaShapedTexturePrivate *priv = self->priv;
-+
-+  priv->fallback_width = fallback_width;
-+  priv->fallback_height = fallback_height;
-+}
-+
- static void
- meta_shaped_texture_cull_out (MetaCullable   *cullable,
-                               cairo_region_t *unobscured_region,
-diff --git a/src/compositor/meta-surface-actor-x11.c b/src/compositor/meta-surface-actor-x11.c
-index 4aa7ecd..b50b8f2 100644
---- a/src/compositor/meta-surface-actor-x11.c
-+++ b/src/compositor/meta-surface-actor-x11.c
-@@ -416,6 +416,7 @@ meta_surface_actor_x11_set_size (MetaSurfaceActorX11 *self,
-                                  int width, int height)
- {
-   MetaSurfaceActorX11Private *priv = meta_surface_actor_x11_get_instance_private (self);
-+  MetaShapedTexture *stex = meta_surface_actor_get_texture (META_SURFACE_ACTOR (self));
-   if (priv->last_width == width &&
-       priv->last_height == height)
-@@ -424,4 +425,5 @@ meta_surface_actor_x11_set_size (MetaSurfaceActorX11 *self,
-   priv->size_changed = TRUE;
-   priv->last_width = width;
-   priv->last_height = height;
-+  meta_shaped_texture_set_fallback_size (stex, width, height);
- }
--- 
-cgit v0.10.2
-
diff --git a/x11-wm/mutter/mutter-3.16.2-r1.ebuild b/x11-wm/mutter/mutter-3.16.2-r1.ebuild
deleted file mode 100644 (file)
index 19d40dc..0000000
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
-HOMEPAGE="https://git.gnome.org/browse/mutter/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="+introspection +kms test wayland"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-# libXi-1.7.4 or newer needed per:
-# https://bugzilla.gnome.org/show_bug.cgi?id=738944
-COMMON_DEPEND="
-       >=x11-libs/pango-1.2[X,introspection?]
-       >=x11-libs/cairo-1.10[X]
-       >=x11-libs/gtk+-3.9.11:3[X,introspection?]
-       >=dev-libs/glib-2.36.0:2[dbus]
-       >=media-libs/clutter-1.21.3:1.0[introspection?]
-       >=media-libs/cogl-1.17.1:1.0=[introspection?]
-       >=media-libs/libcanberra-0.26[gtk3]
-       >=x11-libs/startup-notification-0.7
-       >=x11-libs/libXcomposite-0.2
-       >=gnome-base/gsettings-desktop-schemas-3.15.92[introspection?]
-       gnome-base/gnome-desktop:3=
-       >sys-power/upower-0.99:=
-
-       x11-libs/libICE
-       x11-libs/libSM
-       x11-libs/libX11
-       >=x11-libs/libXcomposite-0.2
-       x11-libs/libXcursor
-       x11-libs/libXdamage
-       x11-libs/libXext
-       x11-libs/libXfixes
-       >=x11-libs/libXi-1.7.4
-       x11-libs/libXinerama
-       x11-libs/libXrandr
-       x11-libs/libXrender
-       x11-libs/libxcb
-       x11-libs/libxkbfile
-       >=x11-libs/libxkbcommon-0.4.3[X]
-       x11-misc/xkeyboard-config
-
-       gnome-extra/zenity
-
-       introspection? ( >=dev-libs/gobject-introspection-1.42:= )
-       kms? (
-               dev-libs/libinput
-               >=media-libs/clutter-1.20[egl]
-               media-libs/cogl:1.0=[kms]
-               >=media-libs/mesa-10.3[gbm]
-               sys-apps/systemd
-               virtual/libgudev
-               x11-libs/libdrm:= )
-       wayland? (
-               >=dev-libs/wayland-1.6.90
-               >=media-libs/clutter-1.20[wayland]
-               x11-base/xorg-server[wayland] )
-"
-DEPEND="${COMMON_DEPEND}
-       >=dev-util/gtk-doc-am-1.15
-       >=dev-util/intltool-0.41
-       sys-devel/gettext
-       virtual/pkgconfig
-       x11-proto/xextproto
-       x11-proto/xineramaproto
-       x11-proto/xproto
-       test? ( app-text/docbook-xml-dtd:4.5 )
-"
-RDEPEND="${COMMON_DEPEND}
-       !x11-misc/expocity
-"
-
-src_prepare() {
-       # surface-actor-x11: Make sure to set a size when unredirected (from 3.16 branch)
-       epatch "${FILESDIR}"/${P}-size-unredirected.patch
-       gnome2_src_prepare
-}
-
-src_configure() {
-       gnome2_src_configure \
-               --disable-static \
-               --enable-sm \
-               --enable-startup-notification \
-               --enable-verbose-mode \
-               --with-libcanberra \
-               $(use_enable introspection) \
-               $(use_enable kms native-backend) \
-               $(use_enable wayland)
-}
diff --git a/x11-wm/mutter/mutter-3.16.2.ebuild b/x11-wm/mutter/mutter-3.16.2.ebuild
deleted file mode 100644 (file)
index c464ffd..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-
-inherit eutils gnome2
-
-DESCRIPTION="GNOME 3 compositing window manager based on Clutter"
-HOMEPAGE="https://git.gnome.org/browse/mutter/"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE="+introspection +kms test wayland"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-# libXi-1.7.4 or newer needed per:
-# https://bugzilla.gnome.org/show_bug.cgi?id=738944
-COMMON_DEPEND="
-       >=x11-libs/pango-1.2[X,introspection?]
-       >=x11-libs/cairo-1.10[X]
-       >=x11-libs/gtk+-3.9.11:3[X,introspection?]
-       >=dev-libs/glib-2.36.0:2[dbus]
-       >=media-libs/clutter-1.21.3:1.0[introspection?]
-       >=media-libs/cogl-1.17.1:1.0=[introspection?]
-       >=media-libs/libcanberra-0.26[gtk3]
-       >=x11-libs/startup-notification-0.7
-       >=x11-libs/libXcomposite-0.2
-       >=gnome-base/gsettings-desktop-schemas-3.15.92[introspection?]
-       gnome-base/gnome-desktop:3=
-       >sys-power/upower-0.99:=
-
-       x11-libs/libICE
-       x11-libs/libSM
-       x11-libs/libX11
-       >=x11-libs/libXcomposite-0.2
-       x11-libs/libXcursor
-       x11-libs/libXdamage
-       x11-libs/libXext
-       x11-libs/libXfixes
-       >=x11-libs/libXi-1.7.4
-       x11-libs/libXinerama
-       x11-libs/libXrandr
-       x11-libs/libXrender
-       x11-libs/libxcb
-       x11-libs/libxkbfile
-       >=x11-libs/libxkbcommon-0.4.3[X]
-       x11-misc/xkeyboard-config
-
-       gnome-extra/zenity
-
-       introspection? ( >=dev-libs/gobject-introspection-1.42:= )
-       kms? (
-               dev-libs/libinput
-               >=media-libs/clutter-1.20[egl]
-               media-libs/cogl:1.0=[kms]
-               >=media-libs/mesa-10.3[gbm]
-               sys-apps/systemd
-               virtual/libgudev
-               x11-libs/libdrm:= )
-       wayland? (
-               >=dev-libs/wayland-1.6.90
-               >=media-libs/clutter-1.20[wayland]
-               x11-base/xorg-server[wayland] )
-"
-DEPEND="${COMMON_DEPEND}
-       >=dev-util/gtk-doc-am-1.15
-       >=dev-util/intltool-0.41
-       sys-devel/gettext
-       virtual/pkgconfig
-       x11-proto/xextproto
-       x11-proto/xineramaproto
-       x11-proto/xproto
-       test? ( app-text/docbook-xml-dtd:4.5 )
-"
-RDEPEND="${COMMON_DEPEND}
-       !x11-misc/expocity
-"
-
-src_configure() {
-       gnome2_src_configure \
-               --disable-static \
-               --enable-sm \
-               --enable-startup-notification \
-               --enable-verbose-mode \
-               --with-libcanberra \
-               $(use_enable introspection) \
-               $(use_enable kms native-backend) \
-               $(use_enable wayland)
-}
index 98cc39c2a7d00a5684e336f0768e9c8c5600f1d3..76f8ab6019b18dde5fd65e755a7ab9e712cd2591 100644 (file)
@@ -81,19 +81,19 @@ RDEPEND="${COMMON_DEPEND}
 src_prepare() {
        # Fallback to a default keymap if getting it from X fails (from 'master')
        epatch "${FILESDIR}"/${PN}-3.16.3-fallback-keymap.patch
-       
+
        # frames: handle META_FRAME_CONTROL_NONE on left click (from '3.16')
        epatch "${FILESDIR}"/${P}-crash-border.patch
-       
+
        # compositor: Add support for GL_EXT_x11_sync_object (from '3.16')
        epatch "${FILESDIR}"/${P}-GL_EXT_x11_sync_object.patch
-       
+
        # compositor: Fix GL_EXT_x11_sync_object race condition (from '3.16')
        epatch "${FILESDIR}"/${P}-fix-race.patch
-       
+
        # build: Fix return value in meta-sync-ring.c (from '3.16')
        epatch "${FILESDIR}"/${P}-fix-return.patch
-       
+
        # compositor: Handle fences in the frontend X connection (from '3.16')
        epatch "${FILESDIR}"/${P}-flickering.patch