dev-libs/libarcus: version bump to 4.3.0
authorMichael Perlov <perlovka@gmail.com>
Sat, 28 Sep 2019 10:25:39 +0000 (13:25 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Wed, 16 Oct 2019 05:21:57 +0000 (08:21 +0300)
Closes: https://bugs.gentoo.org/693300
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Michael Perlov <perlovka@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/libarcus/Manifest
dev-libs/libarcus/libarcus-4.3.0.ebuild [new file with mode: 0644]

index 6664c0b811b5e3ac991306115c1eefb8981a3162..11f0e74fb17f58f13486c0c8d585f50b237e0929 100644 (file)
@@ -1,3 +1,4 @@
 DIST libarcus-3.4.1.tar.gz 29699 BLAKE2B 73f132ff9d908468f1d67c54b7430ac84c0aebb5dd12282dc894b877a91da3f9822e4db8bf16cb53f313396598d3890be9e06e50737b0a50edfc84543285f251 SHA512 63ed8d8da389641b91ed955624c04ca5488f98d3ef409c4a94ad1962155d6aedd8d61ca0231543cfe4e92ae10beb00001f957eb48f74b0c21447a1bd9b66d85d
 DIST libarcus-3.6.0.tar.gz 29469 BLAKE2B c032dd51631b10c04e69dac4425c8a5d180cf8c983b896330b2dcd5d479467d6a2e94827ef8accad25399167457e5ae9e96f1a363c986be33de8255c3e80b1fb SHA512 1bc50a08cbec61edefd78f3c347cca08f6bc40a308472bf6788c2c8962b03ea81b32357be18a3c34847c121eb52ee6836da22cea65b1a8f64b7c924bda290430
 DIST libarcus-4.2.0.tar.gz 30582 BLAKE2B cb2390d7fc8942cbdd880385313f4bd8886a1ea4eaa5246c76b0b3243e8a099953ecf51d09486e005c8c14783ec67435b33068efae2ea6075edf91b90b9fa9b2 SHA512 f9a38d095a2ba2ab29a382466ce16d1c0f5cdb34b60a2b930529edac94de177d7bed37ee26bf615833c94ccd0e3b7c71d502f5f815d92eeffdf3bc1f15b49ba5
+DIST libarcus-4.3.0.tar.gz 30540 BLAKE2B 58937764d9eec4a235bcc26aa85ab1f1418ae2c576c24759fee5155c7690a3a5feee1946cbae8e7836fd4eccdb0f673167aeda46c3dae124101cfb03510697e8 SHA512 b3893e3c422de85a6968443a6f26149e9dee9f15038c11c219693b9aa8d5174d908421e33c8e3ce4e4ecab8c5077da217b44a9ec6bb4b351ff67b7f2d42cc890
diff --git a/dev-libs/libarcus/libarcus-4.3.0.ebuild b/dev-libs/libarcus/libarcus-4.3.0.ebuild
new file mode 100644 (file)
index 0000000..d053a69
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit cmake-utils python-single-r1
+
+MY_PN="libArcus"
+
+DESCRIPTION="This library facilitates communication between Cura and its backend"
+HOMEPAGE="https://github.com/Ultimaker/libArcus"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0/3"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples python static-libs"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="${PYTHON_DEPS}
+       dev-python/sip[${PYTHON_USEDEP}]
+       dev-libs/protobuf
+       python? ( dev-python/protobuf-python[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # Find SIP for current python version, not the latest installed
+       sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" CMakeLists.txt || die
+       sed -i "s/find_package(Python3 3.4 REQUIRED/find_package(Python3 ${EPYTHON##python} EXACT REQUIRED/g" cmake/FindSIP.cmake || die
+
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_EXAMPLES=$(usex examples ON OFF)
+               -DBUILD_PYTHON=$(usex python ON OFF)
+               -DBUILD_STATIC=$(usex static-libs ON OFF)
+       )
+
+       cmake-utils_src_configure
+}