media-libs/libyami: Bump to 1.1.0
authorAlexis Ballier <aballier@gentoo.org>
Sun, 22 Jan 2017 06:54:33 +0000 (07:54 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 22 Jan 2017 08:44:01 +0000 (09:44 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

media-libs/libyami/Manifest
media-libs/libyami/libyami-1.1.0.ebuild [new file with mode: 0644]
media-libs/libyami/libyami-9999.ebuild
media-libs/libyami/metadata.xml

index dbb9bb97251bf39aaed5dc4d8177709190d08260..76a3a4120acd19bfe370820c9c2a56cb6ae77378 100644 (file)
@@ -1 +1,2 @@
 DIST libyami-1.0.1.tar.gz 480656 SHA256 1051d3e3366a933c4fbfb883b3900e81a8c0e4e1cd4d5a08b9c7d4e1bf7cec34 SHA512 01c0716011682ff8b5e6d2c58479aa574bc2cfb5ffe932952e430302aff090d56e0efa4f784f9cdd36d94800c8454802e4500096b3bea162d04ee6253a134c81 WHIRLPOOL 93ca1ca5a2cea7160398e4df24a829ecd09847f2d65a3fe1d30c608490f671c15c936b359dfa92b3560c9b3652bb3b547ed0e4b2120bea902e1e48e3f6c1fb33
+DIST libyami-1.1.0.tar.gz 491537 SHA256 08acb7857a1a85c1d3341862d6b523c0eb1603adee454469cda765b6bf04f614 SHA512 04ef34a994d23f8f5182c17975d6a28048a311c8090393d8cd54dd1fc74ec8b76af4028e1d5506568fb698e15f14833a01d4eaeb4ccd2484801f806a05cc86fa WHIRLPOOL 1565f0916c90ce906828de4b68cf30e83335a67da645b5b8e6d9930b93c84b72b46a1f23eba417e783937f067ff3121ff2a6c9b537604b6fc6346c00d4457da1
diff --git a/media-libs/libyami/libyami-1.1.0.ebuild b/media-libs/libyami/libyami-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..8be8a01
--- /dev/null
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+       SCM=git-r3
+       EGIT_REPO_URI="https://github.com/01org/libyami"
+fi
+
+inherit ${SCM} autotools multilib-minimal flag-o-matic
+
+DESCRIPTION="Yet Another Media Infrastructure: Media codec with hardware acceleration"
+HOMEPAGE="https://github.com/01org/libyami"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+       KEYWORDS=""
+       SRC_URI=""
+else
+       KEYWORDS="~amd64"
+       SRC_URI="https://github.com/01org/libyami/archive/${P}.tar.gz"
+       S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="debug egl dmabuf doc md5 v4l X test wayland"
+
+RDEPEND="
+       >=x11-libs/libva-1.7.2[drm,X?,wayland?,${MULTILIB_USEDEP}]
+       v4l? (
+               >=virtual/opengl-7[${MULTILIB_USEDEP}]
+               >=media-libs/libv4l-1.6.2[${MULTILIB_USEDEP}]
+               >=media-libs/mesa-10[egl,gles2,${MULTILIB_USEDEP}]
+       )
+       X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )
+       md5? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
+       dmabuf? ( x11-libs/libdrm[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )
+       test? ( >=dev-cpp/gtest-1.7 )
+"
+
+src_prepare() {
+       eautoreconf
+}
+
+multilib_src_configure() {
+       append-cppflags -I"${S}/"
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable debug) \
+               $(use_enable egl) \
+               $(use_enable v4l v4l2) \
+               $(use_enable v4l v4l2-ops) \
+               $(use_enable X x11) \
+               $(use_enable dmabuf) \
+               $(use_enable md5) \
+               $(use_enable wayland) \
+               $(use_enable test gtest) \
+               $(multilib_native_use_enable doc docs) \
+               --enable-h265dec \
+               --enable-vc1dec \
+               --enable-h264dec \
+               --enable-jpegdec \
+               --enable-mpeg2dec \
+               --enable-vp8dec \
+               --enable-vp9dec \
+               --enable-h265enc \
+               --enable-h264enc \
+               --enable-jpegenc \
+               --enable-vp8enc \
+               --enable-vp9enc
+}
+
+multilib_src_compile() {
+       emake
+       multilib_is_native_abi && use doc && emake -C doc
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" install
+       multilib_is_native_abi && use doc && dohtml -r doc/html/*
+}
+
+src_install() {
+       multilib-minimal_src_install
+       find "${ED}" -name '*.la' -delete
+}
index 10af6ad3b5cd18014d68b9a3182b905aa941b1ba..8be8a0110dc86493c887cb00b70de2afd9842a8a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -26,7 +26,7 @@ fi
 
 LICENSE="Apache-2.0"
 SLOT="0"
-IUSE="debug dmabuf doc md5 v4l X test wayland"
+IUSE="debug egl dmabuf doc md5 v4l X test wayland"
 
 RDEPEND="
        >=x11-libs/libva-1.7.2[drm,X?,wayland?,${MULTILIB_USEDEP}]
@@ -53,6 +53,7 @@ multilib_src_configure() {
        append-cppflags -I"${S}/"
        ECONF_SOURCE="${S}" econf \
                $(use_enable debug) \
+               $(use_enable egl) \
                $(use_enable v4l v4l2) \
                $(use_enable v4l v4l2-ops) \
                $(use_enable X x11) \
index 75d5444f08f910ddff2277bb570597f5a3fce180..77b1337f051dd400cf3bd862fdd871730ea7062b 100644 (file)
@@ -5,6 +5,7 @@
     <email>media-video@gentoo.org</email>
   </maintainer>
   <use>
+       <flag name="egl">Enable EGL support.</flag>
     <flag name="v4l">Add support for V4L2 hardware codecs.</flag>
     <flag name="md5">Add support for generating md5 sums for each frame.</flag>
     <flag name="dmabuf">Enable dma_buf buffer sharing.</flag>