dev-perl/DBI: Workaround test failures with -jx w/ x > 70 bug #675164
authorKent Fredric <kentnl@gentoo.org>
Fri, 11 Jan 2019 10:00:22 +0000 (23:00 +1300)
committerKent Fredric <kentnl@gentoo.org>
Fri, 11 Jan 2019 10:03:03 +0000 (23:03 +1300)
Bug: https://bugs.gentoo.org/675164
Package-Manager: Portage-2.3.55, Repoman-2.3.12
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/DBI/DBI-1.637.0.ebuild

index 70e87656bceaf56a2194037d552cca4bf9945811..1676a747a16d79119627e36ba38f56cea437a44f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -27,6 +27,10 @@ DEPEND="${RDEPEND}
        )
 "
 src_test() {
+       if [[ $(makeopts_jobs) -gt 70 ]]; then
+               einfo "Reducing jobs to 70. Bug: https://bugs.gentoo.org/675164"
+               MAKEOPTS="${MAKEOPTS} -j70";
+       fi
        perl_rm_files t/pod-coverage.t t/pod.t
        perl-module_src_test
 }