www-servers/monkeyd: don't install into /run
authorAnthony G. Basile <blueness@gentoo.org>
Fri, 14 Aug 2015 00:48:28 +0000 (20:48 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Fri, 14 Aug 2015 01:03:08 +0000 (21:03 -0400)
Package-Manager: portage-2.2.20.1

www-servers/monkeyd/files/monkeyd.initd-r1
www-servers/monkeyd/monkeyd-1.6.0-r1.ebuild

index d1fb73038baf121377beec3b5f6674d4518c1730..e3ca111eb90709567ee5b53439de46d01f1ebcc6 100644 (file)
@@ -12,6 +12,8 @@ depend() {
 
 start() {
        ebegin "Starting monkeyd"
+       local PIDFILE=$(awk '/^ *PidFile/ { print $2 }' "${CONFFILE}")
+       mkdir -p $(dirname ${PIDFILE})
        start-stop-daemon --start --exec "${DAEMON}" -- "-D" "${MONKEY_ARGS}" >/dev/null
        eend $?
 }
index d07b3b808783e5cc250bd53307435c120d7ed722..59f80a4f519e4f964e242e9565e90a0faa730917 100644 (file)
@@ -118,7 +118,7 @@ src_install() {
        newinitd "${FILESDIR}"/monkeyd.initd-r1 monkeyd
        newconfd "${FILESDIR}"/monkeyd.confd monkeyd
 
-       #move htdocs to docdir, bug #429632
+       # Move htdocs to docdir, bug #429632
        docompress -x /usr/share/doc/"${PF}"/htdocs.dist
        mv "${D}"${WEBROOT}/htdocs \
                "${D}"/usr/share/doc/"${PF}"/htdocs.dist
@@ -127,4 +127,7 @@ src_install() {
        keepdir \
                /var/log/monkeyd \
                ${WEBROOT}/htdocs
+
+       # This needs to be created at runtime
+       rm -rf "${D}"/run
 }