Added helium-1.6.
authorAndres Loeh <kosmikus@gentoo.org>
Fri, 6 Apr 2007 01:10:06 +0000 (01:10 +0000)
committerAndres Loeh <kosmikus@gentoo.org>
Fri, 6 Apr 2007 01:10:06 +0000 (01:10 +0000)
Package-Manager: portage-2.1.1

dev-lang/helium/ChangeLog
dev-lang/helium/files/digest-helium-1.6 [new file with mode: 0644]
dev-lang/helium/files/helium-wrapper-1.6 [new file with mode: 0644]
dev-lang/helium/helium-1.6.ebuild [new file with mode: 0644]

index e770f1d438f5bbede3f2a92121dcada372c6f086..0a2a860bb9056be4ab94c89932af0860d75f98a0 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-lang/helium
 # Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/ChangeLog,v 1.17 2007/01/06 18:21:43 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/ChangeLog,v 1.18 2007/04/06 01:10:06 kosmikus Exp $
+
+*helium-1.6 (06 Apr 2007)
+
+  06 Apr 2007; Andres Loeh <kosmikus@gentoo.org> +files/helium-wrapper-1.6,
+  +helium-1.6.ebuild:
+  Added new version 1.6, which is going to replace the broken older ebuilds.
 
   06 Jan 2007; Andres Loeh <kosmikus@gentoo.org> helium-1.1.ebuild:
   Fixed elog / einfo usage.
diff --git a/dev-lang/helium/files/digest-helium-1.6 b/dev-lang/helium/files/digest-helium-1.6
new file mode 100644 (file)
index 0000000..2bd284f
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 9e661e40c97771c87ccda129269faddc helium-1.6-ghc.patch.bz2 34579
+RMD160 7754353e882d233533011f7e7be0bc92c01b83d0 helium-1.6-ghc.patch.bz2 34579
+SHA256 da463fe2a27689ec702eaf7c687446272f983845228cbb45d0fa91e1542cd7ab helium-1.6-ghc.patch.bz2 34579
+MD5 55476704142a92cbf1dbc69cee6f81b5 helium-1.6-src.tar.gz 960254
+RMD160 9700dde4b77adb73825965c00cdc02d3e1f6fab6 helium-1.6-src.tar.gz 960254
+SHA256 a93632d031a16c0ea516f4fa7ce63acd0950543c74265e22abd0993856a0a053 helium-1.6-src.tar.gz 960254
diff --git a/dev-lang/helium/files/helium-wrapper-1.6 b/dev-lang/helium/files/helium-wrapper-1.6
new file mode 100644 (file)
index 0000000..926e18c
--- /dev/null
@@ -0,0 +1,31 @@
+#! /bin/sh
+
+BINNAME_LONG="$(basename $0)"
+BINNAME="${BINNAME_LONG%-tc}"
+
+if [ -n "${HELIUM_TEMP}" ]; then
+       TEMP="${HELIUM_TEMP}";
+else
+       TEMP="/tmp/helium-${USER}"      
+       if ! [ -d "${TEMP}" ]; then
+               mkdir ${TEMP};
+       fi;
+fi
+
+# if [ "${BINNAME_LONG}" = "${BINNAME}" ]; then
+#      HELIUM_LIBS="/usr/lib/helium/lib/simple";
+# else
+HELIUM_LIBS="/usr/lib/helium/lib";
+# fi
+
+if [ -z "${LVMPATH}" ]; then
+       LVMPATH=".:${HELIUM_LIBS}";
+else
+       LVMPATH="${LVMPATH}:${HELIUM_LIBS}";
+fi
+export LVMPATH
+export TEMP
+
+PROGCALL="/usr/lib/helium/bin/${BINNAME}"
+
+${PROGCALL} $*
diff --git a/dev-lang/helium/helium-1.6.ebuild b/dev-lang/helium/helium-1.6.ebuild
new file mode 100644 (file)
index 0000000..2ba01ba
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/helium/helium-1.6.ebuild,v 1.1 2007/04/06 01:10:06 kosmikus Exp $
+
+inherit eutils
+
+DESCRIPTION="Helium (for learning Haskell)"
+HOMEPAGE="http://www.cs.uu.nl/helium"
+SRC_URI="http://www.cs.uu.nl/helium/distr/${P}-src.tar.gz
+       mirror://gentoo/${P}-ghc.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+# compilation breaks on amd64, suspect lvm doesn't work properly
+KEYWORDS="-amd64 ~ppc -sparc ~x86"
+IUSE="readline"
+
+DEPEND=">=virtual/ghc-6.4.2
+       readline? ( sys-libs/readline )"
+RDEPEND="dev-libs/gmp
+       readline? ( sys-libs/readline )"
+
+src_unpack() {
+       unpack ${A}
+       epatch "${P}-ghc.patch"
+}
+
+src_compile() {
+       # helium consists of two components that have to be set up separately,
+       # lvm and the main compiler. both build systems are slightly strange.
+       # lvm uses a completely non-standard build system:
+       # the ./configure of lvm is not the usual autotools configure
+
+       cd "${S}/lvm/src" && ./configure || die "lvm configure failed"
+       echo "STRIP=echo" >> config/makefile || die "lvm postconfigure failed"
+       myconf="$(use_enable readline) --without-strip --without-upx --without-ag"
+       cd "${S}/helium" && econf --prefix="/usr/lib" ${myconf} || die "econf failed"
+       cd "${S}/helium/src" && make depend || die "make depend failed"
+
+       emake -j1 || die "make failed"
+}
+
+src_install() {
+       cd helium/src || die "cannot cd to helium/src"
+       make install bindir="/usr/lib/helium/bin" DESTDIR="${D}" || die "make install failed"
+
+       # create wrappers
+       newbin "${FILESDIR}/helium-wrapper-${PV}" helium-wrapper
+
+       dosym /usr/bin/helium-wrapper /usr/bin/texthint
+       dosym /usr/bin/helium-wrapper /usr/bin/helium
+       dosym /usr/bin/helium-wrapper /usr/bin/lvmrun
+}