sys-fs/lxcfs: use autotools.eclass instead of custom bootstrap
authorJoonas Niilola <juippis@gentoo.org>
Fri, 15 May 2020 13:39:00 +0000 (16:39 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 15 May 2020 13:39:25 +0000 (16:39 +0300)
Closes: https://bugs.gentoo.org/723236
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-fs/lxcfs/lxcfs-4.0.3.ebuild

index 0a8970439c2dedc758c5dc4fb9144917d8c7ed50..726fa0659d7cf50efb162fe7ef3a64f35704daa3 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit systemd
+inherit autotools systemd
 
 DESCRIPTION="FUSE filesystem for LXC"
 HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
@@ -28,7 +28,7 @@ S="${WORKDIR}/${PN}-${P}"
 
 src_prepare() {
        default
-       ./bootstrap.sh || die "Failed to bootstrap configure files"
+       eautoreconf
 }
 
 src_configure() {