app-portage/repoman: Bump to version 2.3.21
authorZac Medico <zmedico@gentoo.org>
Sun, 15 Mar 2020 02:03:52 +0000 (19:03 -0700)
committerZac Medico <zmedico@gentoo.org>
Sun, 15 Mar 2020 02:08:17 +0000 (19:08 -0700)
 #712106 prevent spurious copyright header updates

Bug: https://bugs.gentoo.org/712106
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-portage/repoman/Manifest
app-portage/repoman/repoman-2.3.21.ebuild [new file with mode: 0644]

index 168da820403e7552b53df4ef3e10870768d7d930..c4dc29daf00ec514e93aeadf03be84ba36329f65 100644 (file)
@@ -1,2 +1,3 @@
 DIST repoman-2.3.16.tar.bz2 86739 BLAKE2B dc3e3b5e72df751cfacc17e6f5c847160438a4d6f5d86b4dd17ab8a3a69cd0502f2965934c456ea7538f228c40364535e861c489ab2a09a0df14183b111e9a38 SHA512 d0e8bee1e3bd6dd8aecb1278fc7877768552612c4638488b61a9b8856ad9cd7333c7d52f0c334925d90170a1d8af20e9ead6533edbc10cae02baec629dece121
 DIST repoman-2.3.20.tar.bz2 87313 BLAKE2B cc0ff9b651e01b12202b32d48979f42ffde6e8a7c72095a3f75228a54892bc11c521f015738443133bec223f9ca0faf5687388680ddfd19e07514f873094b0f9 SHA512 edb5564de920156fd89b4df136d86b73401d4d5cf591abc2fbbf97f0ebb7bb43ed17d076560a76a1f3269d19a64c7c52d48540134a9fb86d9fa952d1702e01e2
+DIST repoman-2.3.21.tar.bz2 87094 BLAKE2B feb972d9585440d2a5ed6800146a1d7027fde4c5e7a70904905837261776b9c09bc9bfc6c4da8248a1420635ad8443b31d7716990e6425db3403c8bb74ddca5d SHA512 537c6f6152134df4cd99321b812a1e02608ef0621e674214789dc79ca6540ff1ddab05d100e2bbc2fd0d85664cd92549fb39f8da3cf6850c1a190a88a95814e5
diff --git a/app-portage/repoman/repoman-2.3.21.ebuild b/app-portage/repoman/repoman-2.3.21.ebuild
new file mode 100644 (file)
index 0000000..c77f2d7
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+PYTHON_REQ_USE='bzip2(+)'
+
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/portage.git"
+       S="${WORKDIR}/${P}/repoman"
+else
+       SRC_URI="https://dev.gentoo.org/~zmedico/portage/archives/${P}.tar.bz2"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Repoman is a Quality Assurance tool for Gentoo ebuilds"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       >=sys-apps/portage-2.3.80[${PYTHON_USEDEP}]
+       >=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
+       dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+python_test() {
+       esetup.py test
+}
+
+python_install() {
+       # Install sbin scripts to bindir for python-exec linking
+       # they will be relocated in pkg_preinst()
+       distutils-r1_python_install \
+               --system-prefix="${EPREFIX}/usr" \
+               --bindir="$(python_get_scriptdir)" \
+               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+               --sbindir="$(python_get_scriptdir)" \
+               --sysconfdir="${EPREFIX}/etc" \
+               "${@}"
+}
+
+pkg_postinst() {
+       if [[ -z {REPLACING_VERSIONS} ]]; then
+               elog ""
+               elog "This release of repoman is from the new portage/repoman split"
+               elog "release code base."
+               elog "This new repoman code base is still being developed.  So its API's"
+               elog "are not to be considered stable and are subject to change."
+               elog "The code released has been tested and considered ready for use."
+               elog "This however does not guarantee it to be completely bug free."
+               elog "Please report any bugs you may encounter."
+               elog ""
+       fi
+}