app-vim/python-mode: Clean up old.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 8 Oct 2015 08:53:03 +0000 (08:53 +0000)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 8 Oct 2015 08:53:47 +0000 (08:53 +0000)
Package-Manager: portage-2.2.20.1
Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
app-vim/python-mode/Manifest
app-vim/python-mode/python-mode-0.6.10.ebuild [deleted file]
app-vim/python-mode/python-mode-0.6.18-r2.ebuild [deleted file]

index a0ced5eb03cc8aba12146080a4f5d20e747dde9e..015780cc231fd1540948fb7725a79c1e21f36537 100644 (file)
@@ -1,2 +1 @@
-DIST python-mode-0.6.10.tar.gz 474266 SHA256 ed97b9c260cafa38e01d1bc988e611df8a4681922e3ba4022e5ccac692b8f583 SHA512 562d91a377e783b2cf2583910f4c6b0e8530be9533b513198f5ac97e7581672f95f69e752d391d2a6ad9ac0621c967bc46c02f79fdc38d25172f14267fe27f7e WHIRLPOOL 404458e298ab3c093c031ac00cf43e66652a8054fecfb4d2c481d73a2efbb6949409545f5269bcb43f519b19a27dd8b68fb75a166dce1e78d49e1899bfe17901
 DIST python-mode-0.6.18.tar.gz 386846 SHA256 d46ff14b7ee639b698d1b0ae0e7ca0dcfa95a315ffb25e523ae720461f399c1d SHA512 0e3159a055304443c8b15590c424ac0f4a4303e343882ff91f01f5b959274931dea83969ab1dcd19ce95894c7da5be60699d51b852dc73165a99a271feec4e64 WHIRLPOOL 1a6114999c1b832335268dd7dd3e9ebfd48ce9e35cdc7058e4a1011d3ac0aeb36df85ab52599460e449c0ee645303aca17a8ecb44533a5d137a9b904c426b1da
diff --git a/app-vim/python-mode/python-mode-0.6.10.ebuild b/app-vim/python-mode/python-mode-0.6.10.ebuild
deleted file mode 100644 (file)
index 9348671..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-VIM_PLUGIN_MESSAGES="filetype"
-VIM_PLUGIN_HELPFILES="PythonModeCommands"
-VIM_PLUGIN_HELPURI="https://github.com/klen/python-mode"
-
-inherit vim-plugin vcs-snapshot
-
-DESCRIPTION="Provide python code looking for bugs, refactoring and other useful things"
-HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3770 https://github.com/klen/python-mode"
-SRC_URI="https://github.com/klen/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=""
-RDEPEND="
-       dev-python/astng
-       dev-python/autopep8
-       dev-python/pyflakes
-       dev-python/pylint
-       dev-python/rope
-       dev-python/ropemode
-       "
-
-src_prepare() {
-       rm -rf pylibs/{logilab,*pep8.py,pyflakes,pylint,rope,ropemode} .gitignore
-       mv pylint.ini "${T}" || die
-       sed -e "s|expand(\"<sfile>:p:h:h\")|\"${EPREFIX}/usr/share/${PN}\"|" \
-               -i plugin/pymode.vim || die # use custom path
-       sed -e "s/pylibs.autopep8/autopep8/g" -i pylibs/pymode/auto.py || die
-       sed -e "s/pylibs.ropemode/ropemode/g" -i pylibs/ropevim.py || die
-}
-
-src_install() {
-       vim-plugin_src_install
-       insinto usr/share/${PN}
-       doins "${T}"/pylint.ini
-}
-
-pkg_postinst() {
-       vim-plugin_pkg_postinst
-       einfo "If you use custom pylintrc make sure you append the contents of"
-       einfo " ${EPREFIX}/usr/share/${PN}/pylint.ini"
-       einfo "to it. Otherwise PyLint command will not work properly."
-}
diff --git a/app-vim/python-mode/python-mode-0.6.18-r2.ebuild b/app-vim/python-mode/python-mode-0.6.18-r2.ebuild
deleted file mode 100644 (file)
index 9f493ee..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-VIM_PLUGIN_MESSAGES="filetype"
-VIM_PLUGIN_HELPFILES="PythonModeCommands"
-VIM_PLUGIN_HELPURI="https://github.com/klen/python-mode"
-
-inherit vim-plugin
-
-DESCRIPTION="Provide python code looking for bugs, refactoring and other useful things"
-HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=3770 https://github.com/klen/python-mode"
-SRC_URI="https://github.com/klen/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
-       dev-python/astng
-       dev-python/autopep8
-       dev-python/pyflakes
-       dev-python/pylint
-       dev-python/rope
-       dev-python/ropemode
-       "
-
-src_prepare() {
-       # debundling fun
-       rm -rf pylibs/pylama/{pep8.py,pyflakes} pylibs/{autopep8.py}
-       #rm -rf pylibs/{rope,ropemode}  #475686
-       sed -e 's/from .pep8/from pep8/g' \
-               -e 's/from .pyflakes/from pyflakes/g' \
-               -i pylibs/pylama/utils.py || die
-       # there's still pylint left, I failed to debundle it :/
-
-       mv pylint.ini "${T}" || die
-       sed -e "s|expand(\"<sfile>:p:h:h\")|\"${EPREFIX}/usr/share/${PN}\"|" \
-               -i autoload/pymode.vim || die # use custom path
-}
-
-src_install() {
-       vim-plugin_src_install
-       insinto usr/share/${PN}
-       doins "${T}"/pylint.ini
-}
-
-pkg_postinst() {
-       vim-plugin_pkg_postinst
-       einfo "If you use custom pylintrc make sure you append the contents of"
-       einfo " ${EPREFIX}/usr/share/${PN}/pylint.ini"
-       einfo "to it. Otherwise PyLint command will not work properly."
-}