app-misc/transfolio: New package
authorConrad Kostecki <conikost@gentoo.org>
Sun, 29 Dec 2019 00:46:39 +0000 (01:46 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Sun, 29 Dec 2019 00:46:39 +0000 (01:46 +0100)
TransFolio is a command line tool for Linux and Windows which,
as did Atari's DOS program FT.COM.
It enables data transfer between the PC and the Atari Portfolio.

Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
app-misc/transfolio/Manifest [new file with mode: 0644]
app-misc/transfolio/metadata.xml [new file with mode: 0644]
app-misc/transfolio/transfolio-1.0.1.ebuild [new file with mode: 0644]

diff --git a/app-misc/transfolio/Manifest b/app-misc/transfolio/Manifest
new file mode 100644 (file)
index 0000000..7d49831
--- /dev/null
@@ -0,0 +1 @@
+DIST transfolio-1.0.1.zip 158362 BLAKE2B 291e80e3576c3d92f00905c49d891c9ff926229cc2d843520b9b69f44660ec16ea274b4b68f4d8f3e353d140a6f8549697f3d2456310a5cd3a0e736ff6e0b61a SHA512 5d8c348cabcc3765c192a200ec011344960704085e815d249db23ac3669760c15ec343b16ecdce3469f49f76872f6f93563d50a96cf305f75ed19235d3a5d665
diff --git a/app-misc/transfolio/metadata.xml b/app-misc/transfolio/metadata.xml
new file mode 100644 (file)
index 0000000..fda9b69
--- /dev/null
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>conikost@gentoo.org</email>
+               <name>Conrad Kostecki</name>
+       </maintainer>
+       <longdescription>
+               TransFolio is a command line tool for Linux and Windows which,
+               as did Atari's DOS program FT.COM.
+               It enables data transfer between the PC and the Atari Portfolio.
+       </longdescription>
+</pkgmetadata>
diff --git a/app-misc/transfolio/transfolio-1.0.1.ebuild b/app-misc/transfolio/transfolio-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..e05ba9d
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Enables data transfer between the PC and the Atari Portfolio"
+HOMEPAGE="http://leute.server.de/peichl/"
+SRC_URI="http://leute.server.de/peichl/transfolio.zip -> ${P}.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="app-arch/unzip"
+
+src_prepare() {
+       default
+
+       # Respect users CC, CFLAGS and disable striping
+       sed -e 's/cc/${CC}/' -e 's/-O2/${CFLAGS}/' -e '/strip/d' -i Makefile || die
+
+       tc-export CC
+}
+
+src_install() {
+       dobin transfolio
+
+       einstalldocs
+}