dev-ruby/hoe: add 3.17.2
authorHans de Graaff <graaff@gentoo.org>
Thu, 14 Mar 2019 05:54:50 +0000 (06:54 +0100)
committerHans de Graaff <graaff@gentoo.org>
Thu, 14 Mar 2019 05:54:50 +0000 (06:54 +0100)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-ruby/hoe/Manifest
dev-ruby/hoe/hoe-3.17.2.ebuild [new file with mode: 0644]

index dc7b7d8dd49a587aa82fa158a07f78e10c78f3dc..9a88d8b9e7e542283fc5ef2f15b473349711d801 100644 (file)
@@ -1,2 +1,3 @@
 DIST hoe-3.16.0.gem 188416 BLAKE2B 48383c46512a359a269ca3475ec701b1443e0ef71b31d1ca1604de391ed4df6b0ad27dd1c5f6ed04751047d211f2c6299245361cf131e2418f224324ac9934c3 SHA512 66cefb5a24906e19bbf0c82c8539d6d101b84d0dc1d3ce1910e4117357639489968271e76e86bd3c432b9ef7e3b24a78294c06210cbef280860f7dac18100606
 DIST hoe-3.17.1.gem 188416 BLAKE2B 0fef6dd9ae4bda93f527d7451d0d591cdc4ba1361aaec531f82e0d7ff03575845c3d5ff85189d76f9ecec17797774fd0ca82f7332a4588d086a494095af99a9d SHA512 5e4b83309ed88da098a5ae8698f9686cea1657f4554fff72446bac46bc567125232a3c5a5b941bd6d5ea18dc53f3cbf5b329f2f0623ef74e81d81586edc63ca3
+DIST hoe-3.17.2.gem 188416 BLAKE2B a6f4f93cc2d724b1c1e855c4e6976b5dbb469c4e10fc9c181b6cafaeb7088f9c19bd4bb5b858a25f011dead1b6e8392d349fe9e86d704a6a4d627cddab8de46a SHA512 d6703cd8913ac7055c33dbfead5610bd197be90ac3aeeaf2e4498ab088447d7e08dbe1ad3fdc602afd26fc7cfda12d73dd43a605b9bf59ecd83b1cfd8845f55b
diff --git a/dev-ruby/hoe/hoe-3.17.2.ebuild b/dev-ruby/hoe/hoe-3.17.2.ebuild
new file mode 100644 (file)
index 0000000..daae06b
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation"
+HOMEPAGE="https://www.zenspider.com/projects/hoe.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.9:5 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 <dev-ruby/rake-13.0"
+
+all_ruby_prepare() {
+       # Skip isolation
+       sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+       # Skip test depending on specifics of gem command name
+       sed -i -e '/test_nosudo/,/^  end/ s:^:#:' test/test_hoe.rb || die
+
+       # Gem.bin_wrapper does not work as expected on Gentoo.
+       sed -i -e 's/#{Gem.bin_wrapper "rdoc"}/-S rdoc/' lib/hoe/rcov.rb lib/hoe/publish.rb test/test_hoe_publish.rb || die
+
+       # Avoid test with random sort order
+       sed -i -e '/test_possibly_better/askip "ordering issues"' test/test_hoe.rb || die
+}
+
+all_ruby_compile() {
+       all_fakegem_compile
+
+       if use doc; then
+               rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+       fi
+}