app-emulation/cri-o: Bump to version 1.15.0
authorZac Medico <zmedico@gentoo.org>
Sun, 21 Jul 2019 05:56:18 +0000 (22:56 -0700)
committerZac Medico <zmedico@gentoo.org>
Sun, 21 Jul 2019 05:58:55 +0000 (22:58 -0700)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Zac Medico <zmedico@gentoo.org>
app-emulation/cri-o/Manifest
app-emulation/cri-o/cri-o-1.15.0.ebuild [new file with mode: 0644]

index c05e993564abdcdc09c8be987216e02a49fc9edb..7bd5610901c3defbbe16a3fad43f30ef5d5fd43b 100644 (file)
@@ -3,3 +3,4 @@ DIST cri-o-1.13.9.tar.gz 6685519 BLAKE2B 5d9e68c7a0ae532e2406e5e47562693cddbc34a
 DIST cri-o-1.14.2.tar.gz 9347347 BLAKE2B 83a0d77245bc841a9f89c55c853b64e69cec124da07b1314cfc27237cc82c55e49becc0f14c579a09d23e8da047c6bbb285b0eb79c4609a23827ab24ae28ce4a SHA512 1499b09a8f5c51b426bd8fba7c254288707524a363bfa97537edd35fdf29ac354d13578f2bf3c09c2d128650082f9a2bfbf69872fa9fce77dbff43913afc8066
 DIST cri-o-1.14.4.tar.gz 9370878 BLAKE2B 50fd9b9c4802d2d89b8bbc83d1faf3084a2978835c579814730b93772f3e04cef8d1b46b2176eff494906e89fc20a53cbcab0cf0cabaed74ddcf56bd9f89b14d SHA512 2a78e7ec3ba5ff80649ec11e42da80b15ab86e5b541ffa626a65042b362ac8445bbf00ec46014c0fdd8baec2e4777e23a2463de318113f9c4c6ddda92b5cf3b7
 DIST cri-o-1.14.9.tar.gz 8357782 BLAKE2B ab4df69f231a0e1998182b086eb92e72211282c3f136e3cb2a4f06a94a4de86616d6a540ee8645cfb8d2189e791181b2b39f0e76f19e1a181e495dd5321eb7e7 SHA512 afa17b8a43e7776b44250bfa4657c6a7d4ddd1438ef012a0cb78a98fb73bdc477e990109355d97a84dd38f4ac13d42785c065eb577f978c124e6f8c95e751f94
+DIST cri-o-1.15.0.tar.gz 12153225 BLAKE2B c2db397cb2660af62c53bb5b166854d43cab665f53979ea45e6352929f0070ce7a730d356c7e71edb376d89baa0f616d84fe71017a6d6ca4d6b1270196cc1804 SHA512 4d5460f1e476085523cd82136d80ef32de645a8e6dd2da3ba7b1575cfee9e8ed44de7c144a8338aeb379a6ba506350e10cfc6feb3317b34429d41cb5fe6e20c4
diff --git a/app-emulation/cri-o/cri-o-1.15.0.ebuild b/app-emulation/cri-o/cri-o-1.15.0.ebuild
new file mode 100644 (file)
index 0000000..32d09b5
--- /dev/null
@@ -0,0 +1,104 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_COMMIT="0af20c51a25a04ef77f7e038ff4f24a5a87cd1df"
+EGO_PN="github.com/cri-o/${PN}"
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="OCI-based implementation of Kubernetes Container Runtime Interface"
+HOMEPAGE="https://cri-o.io/"
+SRC_URI="https://github.com/cri-o/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="btrfs +device-mapper selinux systemd"
+
+COMMON_DEPEND="
+       app-crypt/gpgme:=
+       app-emulation/runc
+       dev-libs/glib:=
+       dev-libs/libassuan:=
+       dev-libs/libgpg-error:=
+       net-firewall/conntrack-tools
+       net-firewall/iptables
+       net-misc/cni-plugins
+       net-misc/socat
+       sys-apps/iproute2
+       sys-libs/libseccomp:=
+       btrfs? ( sys-fs/btrfs-progs )
+       device-mapper? ( sys-fs/lvm2:= )
+       selinux? ( sys-libs/libselinux:= )
+       systemd? ( sys-apps/systemd:= )"
+DEPEND="
+       ${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+       !<app-emulation/libpod-1.3.2-r1"
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+src_prepare() {
+       default
+
+       sed -e '/^GIT_.*/d' \
+               -e '/   git diff --exit-code/d' \
+               -e 's/$(GO) build -i/$(GO) build -v -work -x/' \
+               -e 's/\${GIT_COMMIT}/'${EGIT_COMMIT}'/' \
+               -i Makefile || die
+
+       echo ".NOTPARALLEL: binaries docs" >> Makefile || die
+
+       sed -e "s|^COMMIT_NO := .*|COMMIT_NO := ${EGIT_COMMIT}|" \
+               -e "s|^GIT_COMMIT := .*|GIT_COMMIT := ${EGIT_COMMIT}|" \
+               -i Makefile.inc || die
+
+       sed -e 's:/usr/local/bin:/usr/bin:' \
+               -i contrib/systemd/* || die
+
+       if ! use systemd; then
+               sed -e 's| pkg-config --exists libsystemd-journal | false |' \
+                       -e 's| pkg-config --exists libsystemd | false |' \
+                       -i conmon/Makefile || die
+       fi
+}
+
+src_compile() {
+       [[ -f hack/btrfs_installed_tag.sh ]] || die
+       use btrfs || { echo -e "#!/bin/sh\necho exclude_graphdriver_btrfs" > \
+               hack/btrfs_installed_tag.sh || die; }
+
+       [[ -f hack/libdm_installed.sh ]] || die
+       use device-mapper || { echo -e "#!/bin/sh\necho exclude_graphdriver_devicemapper" > \
+               hack/libdm_installed.sh || die; }
+
+       [[ -f hack/selinux_tag.sh ]] || die
+       use selinux || { echo -e "#!/bin/sh\ntrue" > \
+               hack/selinux_tag.sh || die; }
+
+       mkdir -p bin || die
+       GOPATH="${WORKDIR}/${P}" GOBIN="${WORKDIR}/${P}/bin" \
+               emake all
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="${D}${EPREFIX}/usr" install install.config install.systemd
+
+       keepdir /etc/crio
+       mv "${ED}/etc/crio/crio.conf"{,.example} || die
+
+       newinitd "${FILESDIR}/crio.initd" crio
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+
+       # Suppress crio log error messages triggered if these don't exist.
+       keepdir /etc/containers/oci/hooks.d
+       keepdir /usr/share/containers/oci/hooks.d
+
+       # Suppress crio "Missing CNI default network" log message.
+       keepdir /etc/cni/net.d
+       insinto /etc/cni/net.d
+       doins contrib/cni/99-loopback.conf
+}