Add Rubinius back as a ruby target (rbx). Fixes bug 334177, many thanks for Judson...
authorHans de Graaff <graaff@gentoo.org>
Fri, 21 Oct 2011 06:53:40 +0000 (06:53 +0000)
committerHans de Graaff <graaff@gentoo.org>
Fri, 21 Oct 2011 06:53:40 +0000 (06:53 +0000)
Package-Manager: portage-2.1.10.11/cvs/Linux x86_64

dev-lang/rubinius/ChangeLog [new file with mode: 0644]
dev-lang/rubinius/Manifest [new file with mode: 0644]
dev-lang/rubinius/files/auto_gem.rb [new file with mode: 0644]
dev-lang/rubinius/metadata.xml [new file with mode: 0644]
dev-lang/rubinius/rubinius-1.2.4.20110705.ebuild [new file with mode: 0644]

diff --git a/dev-lang/rubinius/ChangeLog b/dev-lang/rubinius/ChangeLog
new file mode 100644 (file)
index 0000000..aec7300
--- /dev/null
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lang/rubinius
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rubinius/ChangeLog,v 1.5 2011/10/21 06:53:40 graaff Exp $
+
+*rubinius-1.2.4.20110705 (21 Oct 2011)
+
+  21 Oct 2011; Hans de Graaff <graaff@gentoo.org>
+  +rubinius-1.2.4.20110705.ebuild, +files/auto_gem.rb, +metadata.xml:
+  Add Rubinius back as a ruby target (rbx). Fixes bug 334177, many thanks for
+  Judson for creating and testing the initial package.
+
diff --git a/dev-lang/rubinius/Manifest b/dev-lang/rubinius/Manifest
new file mode 100644 (file)
index 0000000..f7a1bad
--- /dev/null
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA256
+
+AUX auto_gem.rb 159 RMD160 fbf261e5cf0a8450c51c33a7ad4dafbab21bd518 SHA1 8dde3d73f65998f4c5552924ad49e1441e1b211d SHA256 fe1efe24cd0ba36c55449e9623cd0be394980f37d12468624dad7ffdef72f4dc
+DIST rubinius-1.2.4-20110705.tar.gz 9880126 RMD160 015540347989167a7f953c6c02ca6b6524d21fa2 SHA1 c39c4fb1e62e0fb418453811636177e6ccf6a936 SHA256 d474fb6f50292bff5211aaa80b1cead1fb3ed5c7c49223c51fddb8ffc5c3f23d
+EBUILD rubinius-1.2.4.20110705.ebuild 2002 RMD160 32e4fb62ba35f26c77fdc3ab66dbddad31800eb8 SHA1 85119df3c2c54dbd3c7ca1e9a82d37fd39a75a05 SHA256 da9979aa77eed4f4d4d11669d964fd9a5f4d52b8cbf057d945a4e0106dadb0f5
+MISC ChangeLog 501 RMD160 1b173841eada86ed7430dd27ab7207d21f57fbd6 SHA1 66add754b5151a70abc3607a5302385d5725f35f SHA256 4e81660b2427d7510cf1b64eed9acd8cb09db88914b63050ff4eb6bfb244a8e2
+MISC metadata.xml 1388 RMD160 2e3de2f87f5bade79976069f8a4e89ecff342d10 SHA1 a0ed685628b1f5de88e81e1aacc56c28bb2bb52f SHA256 365a88ae053d47050b6b50d05eb518755a3aeb0c91ca77d2d8eeabfd24a2447f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iF4EAREIAAYFAk6hFvoACgkQiIP6VqMIqNcjDwD+JUfP/pTMoGJyhv5fGxsBmPDc
+9e88vEq4zAQy/7Eao7kA/1FD+p59cOj436HGmnpFcqlCFU7Fikgj9CQoFtMJPmPx
+=8pbE
+-----END PGP SIGNATURE-----
diff --git a/dev-lang/rubinius/files/auto_gem.rb b/dev-lang/rubinius/files/auto_gem.rb
new file mode 100644 (file)
index 0000000..5c4f540
--- /dev/null
@@ -0,0 +1,7 @@
+# This file is installed by Gentoo's rubygems package.
+# It's intended to help automate the loading of rubygems
+
+begin
+require 'rubygems'
+rescue LoadError
+end
diff --git a/dev-lang/rubinius/metadata.xml b/dev-lang/rubinius/metadata.xml
new file mode 100644 (file)
index 0000000..963d76e
--- /dev/null
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <herd>ruby</herd>
+  <use>
+    <flag name='rubytests'>
+      Install ruby tests that can only be run after ruby is installed
+    </flag>
+
+    <flag name='libedit'>
+      Use the <pkg>dev-libs/libedit</pkg> library to provide the
+      readline extension, used for instance by the irb tool. This flag
+      will take precedence over the readline USE flag.
+
+      If neither libedit nor readline USE flags are enabled, the
+      readline extension will not be built (and irb will lose line
+      editing functionality).
+    </flag>
+
+    <flag name='readline'>
+      Use the <pkg>sys-libs/readline</pkg> library to provide the
+      readline extension, used for instance by the irb tool. This flag
+      is meaningful only if the libedit USE flag is disabled.
+
+      If neither libedit nor readline USE flags are enabled, the
+      readline extension will not be built (and irb will lose line
+      editing functionality).
+    </flag>
+
+    <flag name='yaml'>
+      Use the <pkg>dev-libs/libyaml</pkg> library to build the psych
+      extension, available since Ruby 1.9.2_rc2, in alternative to the
+      bundled syck-based parser.
+    </flag>
+
+    <flag name='rdoc'>
+      Install <pkg>dev-ruby/rdoc</pkg> after installing Ruby.
+    </flag>
+  </use>
+</pkgmetadata>
diff --git a/dev-lang/rubinius/rubinius-1.2.4.20110705.ebuild b/dev-lang/rubinius/rubinius-1.2.4.20110705.ebuild
new file mode 100644 (file)
index 0000000..ac111c7
--- /dev/null
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rubinius/rubinius-1.2.4.20110705.ebuild,v 1.1 2011/10/21 06:53:40 graaff Exp $
+
+EAPI=4
+inherit eutils flag-o-matic multilib versionator
+
+DESCRIPTION="A re-implementation of the Ruby VM designed for speed"
+HOMEPAGE="http://rubini.us"
+MY_PV=$(replace_version_separator 3 -)
+SRC_URI="http://asset.rubini.us/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+RDEPEND="sys-libs/readline
+       dev-ruby/rubygems
+       >=sys-devel/llvm-2.8
+       dev-libs/openssl
+       sys-libs/zlib"
+DEPEND="${RDEPEND}
+       sys-devel/bison
+       dev-lang/ruby:1.8
+       dev-ruby/rake"
+
+pkg_setup() {
+       unset RUBYOPT
+}
+
+src_configure() {
+       #Rubinius uses a non-autoconf ./configure script which balks at econf
+       ./configure --skip-prebuilt \
+               --prefix /usr/$(get_libdir) \
+               --mandir /usr/share/man \
+               || die "Configure failed"
+}
+
+src_compile() {
+       rake build || die "Rake failed"
+}
+
+src_test() {
+       if [ $UID != 0 ] ; then
+               rake vm:test || die
+               # These currently cause a weird and uninformative "Hangup".
+#              RBX_RUNTIME="${S}/runtime" RBX_LIB="${S}/lib" bin/mspec ci --background --agent || die
+       else
+               ewarn "Tests will fail if run as root.  Set FEATURES=userpriv if " \
+                       "you want to run tests."
+       fi
+}
+
+src_install() {
+       local minor_version=$(get_version_component_range 1-2)
+       local librbx="usr/$(get_libdir)/rubinius"
+
+       einfo "install:build"
+       rake compiler:load install:build || die "rake install:build failed"
+
+       einfo "install:files"
+       FAKEROOT="${D}" rake install:files || die "rake install:files failed"
+
+       dosym /${librbx}/${minor_version}/bin/rbx /usr/bin/rbx || die "Couldn't make rbx symlink"
+
+       insinto /${librbx}/${minor_version}/site
+       doins "${FILESDIR}/auto_gem.rb" || die "Couldn't install rbx auto_gem.rb"
+       bin/rbx compile "${D}/${librbx}/${minor_version}/site/auto_gem.rb" || die "Couldn't bytecompile auto_gem.rb"
+}