app-misc/spacenavd: Fix USE=-X for 0.7
authorSebastian Pipping <sping@gentoo.org>
Sat, 1 Feb 2020 20:51:49 +0000 (21:51 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sat, 1 Feb 2020 20:51:49 +0000 (21:51 +0100)
Closes: https://bugs.gentoo.org/707732
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.84, Repoman-2.3.20

app-misc/spacenavd/files/spacenavd-0.7-no-x11.patch [new file with mode: 0644]
app-misc/spacenavd/spacenavd-0.7.ebuild

diff --git a/app-misc/spacenavd/files/spacenavd-0.7-no-x11.patch b/app-misc/spacenavd/files/spacenavd-0.7-no-x11.patch
new file mode 100644 (file)
index 0000000..8dbdb7d
--- /dev/null
@@ -0,0 +1,24 @@
+From 3168b1dedf88c9026683ed43ea337814003d6802 Mon Sep 17 00:00:00 2001
+From: John Tsiombikas <nuclear@member.fsf.org>
+Date: Sat, 1 Feb 2020 22:08:43 +0200
+Subject: [PATCH] add a USE_X11 ifdef around the call to drop_xinput in
+ src/dev.c to fix non-X11 build. This should fix github issue #19.
+
+---
+ src/dev.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/src/dev.c b/src/dev.c
+index 8b72932..2074895 100644
+--- a/src/dev.c
++++ b/src/dev.c
+@@ -88,7 +88,9 @@ int init_devices(void)
+               return -1;
+       }
++#ifdef USE_X11
+       drop_xinput();
++#endif
+       return 0;
+ }
index 6a4e1d73addcfc9036c13ea9557a1adacbd3cb15..4c5a57fdbfa39f519af2af8d1ebb2b603ff2ed4b 100644 (file)
@@ -19,6 +19,7 @@ DEPEND="${RDEPEND}"
 
 PATCHES=(
        "${FILESDIR}"/${P}-gcc10.patch
+       "${FILESDIR}"/${P}-no-x11.patch
 )
 
 pkg_setup() {