dev-util/pkgcheck: remove old
authorTim Harder <radhermit@gentoo.org>
Fri, 24 Apr 2020 02:23:28 +0000 (20:23 -0600)
committerTim Harder <radhermit@gentoo.org>
Fri, 24 Apr 2020 02:25:51 +0000 (20:25 -0600)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-util/pkgcheck/metadata.xml
dev-util/pkgcheck/pkgcheck-0.7.6.ebuild [deleted file]

index 823ef4f00a2a45f4f7099185ef03abf16ce7dace..aa0ba050b3e0155927602908bde8273f039f4a3a 100644 (file)
@@ -5,10 +5,6 @@
                <email>mgorny@gentoo.org</email>
                <name>Michał Górny</name>
        </maintainer>
-       <use>
-               <flag name="network">Enable support for network checks using <pkg>dev-python/requests</pkg></flag>
-               <flag name="perl">Enable support for perl checks using <pkg>dev-perl/Gentoo-PerlMod-Version</pkg></flag>
-       </use>
        <upstream>
                <remote-id type="github">pkgcore/pkgcheck</remote-id>
        </upstream>
diff --git a/dev-util/pkgcheck/pkgcheck-0.7.6.ebuild b/dev-util/pkgcheck/pkgcheck-0.7.6.ebuild
deleted file mode 100644 (file)
index eb8f739..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_IN_SOURCE_BUILD=1
-inherit distutils-r1
-
-if [[ ${PV} == *9999 ]] ; then
-       EGIT_REPO_URI="https://github.com/pkgcore/pkgcheck.git"
-       inherit git-r3
-else
-       KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="pkgcore-based QA utility for ebuild repos"
-HOMEPAGE="https://github.com/pkgcore/pkgcheck"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="network perl test"
-RESTRICT="!test? ( test )"
-
-if [[ ${PV} == *9999 ]]; then
-       RDEPEND="
-               ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
-               ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
-else
-       RDEPEND="
-               >=dev-python/snakeoil-0.8.8[${PYTHON_USEDEP}]
-               >=sys-apps/pkgcore-0.10.11[${PYTHON_USEDEP}]"
-fi
-RDEPEND+="
-       dev-python/chardet[${PYTHON_USEDEP}]
-       dev-python/lxml[${PYTHON_USEDEP}]
-       dev-python/pathspec[${PYTHON_USEDEP}]
-       network? ( dev-python/requests[${PYTHON_USEDEP}] )
-       perl? ( dev-perl/Gentoo-PerlMod-Version )
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-python_test() {
-       esetup.py test
-}
-
-python_install_all() {
-       local DOCS=( NEWS.rst )
-       [[ ${PV} == *9999 ]] || doman man/*
-       distutils-r1_python_install_all
-}