dev-ruby/activestorage: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sun, 19 Apr 2020 12:15:08 +0000 (14:15 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 19 Apr 2020 12:18:44 +0000 (14:18 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/activestorage/Manifest
dev-ruby/activestorage/activestorage-5.2.4.1.ebuild [deleted file]

index ea925dae1db5541c2711dbb34338126125b97701..91d18b4ce33f701b57f8690cac759e1a62179f39 100644 (file)
@@ -1,4 +1,3 @@
-DIST rails-5.2.4.1.tgz 8823310 BLAKE2B 33d863a66c0f5e0554c2beaf5fac235cfa3a5ba0c514aa30f53d9d036656d3710f7c486f3cd23e3b2986ee8621a11782a7a630f74131cce4c99a4ff7539e6b58 SHA512 5b59cd0ede76cedf1fdb50090c434c24fdcd30a2cf6ec4abc5437e62bb2aae410607e812d4e14acdd27b81a51365232f6e768156556ca67ae94b9e10d2eb7655
 DIST rails-5.2.4.2.tgz 8823143 BLAKE2B 273bee6ccc2354bcfd8d24b320fe69c24f643c196eba053c727d30b13d4178069068c430a0a4112ae28c3e4b5a5dde0b66a7c46c7c28054f2b7a678427f478af SHA512 21561407a0b606dbd2fb6ad12ef910c0bdf3d5162db7e55f4f41f698280ba73664b0b5594930d4cebcb42a66e2e5e22de3523789818eb424443e8c5b2316b8fc
 DIST rails-6.0.2.1.tgz 18556085 BLAKE2B 178e2d5319fa71ba9f3f7d7a00c207ed9c8d87973487a253c5f819132743f8cdf1428b1668c6e176c91d45986a2201e52f9016efe5ca28ab93301135e5392dd5 SHA512 b33e82ba9e898f7c467df26b7196c69564bcdd24a4732ae6912d06dd361044e769d87fc3e8872533c97fc8d034cab2fad33082925f98cf2096fb1dd4ff6789d7
 DIST rails-6.0.2.2.tgz 18556125 BLAKE2B f4ed5cc6cbbfa84fb687aba5a6c8f2f6ab68febb41147c40ed8dbc6253c128adbac6503e65e89fe672f50270716d197d8c05b4e1e286aafd76581fc167e6c5da SHA512 c1aab2d6c72948c75a047aec9d9f651f0c1bae78bb17e2fa0cb393113ee1e59980dc093e6f3fd3b2f3839c9b3bb4afcd0b0badfd9574b35b932275a9d9800689
diff --git a/dev-ruby/activestorage/activestorage-5.2.4.1.ebuild b/dev-ruby/activestorage/activestorage-5.2.4.1.ebuild
deleted file mode 100644 (file)
index ec98b14..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="activestorage.gemspec"
-
-RUBY_FAKEGEM_EXTRAINSTALL="app config db"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eapi7-ver
-
-DESCRIPTION="Attach cloud and local files in Rails applications"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-DEPEND+=" test? ( app-text/mupdf ) "
-
-ruby_add_rdepend "
-       ~dev-ruby/actionpack-${PV}:*
-       ~dev-ruby/activerecord-${PV}:*
-       >=dev-ruby/marcel-0.3.1 =dev-ruby/marcel-0.3*
-"
-
-ruby_add_bdepend "
-       test? (
-               ~dev-ruby/railties-${PV}
-               dev-ruby/test-unit:2
-               dev-ruby/mini_magick
-               dev-ruby/mocha
-               dev-ruby/rake
-               dev-ruby/sqlite3
-       )"
-
-all_ruby_prepare() {
-          # Remove items from the common Gemfile that we don't need for this
-               # test run. This also requires handling some gemspecs.
-               sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|rubocop\|capybara\|rack-cache\|json\|dalli\|listen\|connection_pool\|puma\|mysql2\)/ s:^:#:" \
-                       -e '/dalli/ s/2.7.7/2.7.9/' \
-                       -e '/:job/,/end/ s:^:#:' \
-                       -e '/:test/,/^end/ s:^:#:' \
-                       -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
-               rm ../Gemfile.lock || die
-}