dev-util/cmake: suppress CPackDEB tests
authorRolf Eike Beer <eike@sf-mail.de>
Wed, 3 Jul 2019 21:44:40 +0000 (23:44 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 4 Jul 2019 19:36:07 +0000 (21:36 +0200)
They would always fail as this is not Debian.

Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Bug: https://bugs.gentoo.org/686482
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-util/cmake/cmake-3.14.3.ebuild
dev-util/cmake/cmake-3.14.5.ebuild
dev-util/cmake/cmake-3.15.0_rc3.ebuild

index 40c7542127452d1c39c4e8ad012b44b55e908b1a..01f4a37c83331d91f72c94c046fecac279f1fc2a 100644 (file)
@@ -119,12 +119,14 @@ cmake_src_test() {
        #    RunCMake.CompilerLauncher: also requires fortran
        #    RunCMake.CPack_RPM: breaks if app-arch/rpm is installed because
        #        debugedit binary is not in the expected location
+       #    RunCMake.CPack_DEB: breaks if app-arch/dpkg is installed because
+       #        it can't find a deb package that owns libc
        #    TestUpload, which requires network access
        "${BUILD_DIR}"/bin/ctest \
                -j "$(makeopts_jobs)" \
                --test-load "$(makeopts_loadavg)" \
                ${ctestargs} \
-               -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.CPack_RPM|TestUpload)" \
+               -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
                || die "Tests failed"
 
        popd > /dev/null
index e3507ad6196d4a2f7c91f5e8ded2db8b77fffd62..b04b6c2e4330204b25a30ac7dfd1e87134ee59d7 100644 (file)
@@ -119,12 +119,14 @@ cmake_src_test() {
        #    RunCMake.CompilerLauncher: also requires fortran
        #    RunCMake.CPack_RPM: breaks if app-arch/rpm is installed because
        #        debugedit binary is not in the expected location
+       #    RunCMake.CPack_DEB: breaks if app-arch/dpkg is installed because
+       #        it can't find a deb package that owns libc
        #    TestUpload, which requires network access
        "${BUILD_DIR}"/bin/ctest \
                -j "$(makeopts_jobs)" \
                --test-load "$(makeopts_loadavg)" \
                ${ctestargs} \
-               -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.CPack_RPM|TestUpload)" \
+               -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
                || die "Tests failed"
 
        popd > /dev/null
index 0fb93b78d73ff9599863c775ec55bb5780514e57..06184a6bfe5fbc937ad3ae89d7bfb11e1a34f7c4 100644 (file)
@@ -119,12 +119,14 @@ cmake_src_test() {
        #    RunCMake.CompilerLauncher: also requires fortran
        #    RunCMake.CPack_RPM: breaks if app-arch/rpm is installed because
        #        debugedit binary is not in the expected location
+       #    RunCMake.CPack_DEB: breaks if app-arch/dpkg is installed because
+       #        it can't find a deb package that owns libc
        #    TestUpload, which requires network access
        "${BUILD_DIR}"/bin/ctest \
                -j "$(makeopts_jobs)" \
                --test-load "$(makeopts_loadavg)" \
                ${ctestargs} \
-               -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.CPack_RPM|TestUpload)" \
+               -E "(BootstrapTest|BundleUtilities|CMakeOnly.AllFindModules|CompileOptions|CTest.UpdateCVS|Fortran|RunCMake.CompilerLauncher|RunCMake.CPack_(DEB|RPM)|TestUpload)" \
                || die "Tests failed"
 
        popd > /dev/null