Fix 'TypeError: not all arguments converted during string formatting'
authorZac Medico <zmedico@gentoo.org>
Mon, 5 Nov 2007 06:49:14 +0000 (06:49 -0000)
committerZac Medico <zmedico@gentoo.org>
Mon, 5 Nov 2007 06:49:14 +0000 (06:49 -0000)
issues with the EbuildNestedDie check.

svn path=/main/trunk/; revision=8429

bin/repoman
pym/repoman/errors.py

index 5a5455bbd6e2daad43a5bcb0c22080ef16981526..472fb3278e9fc1528c77518995ad970c412d6222 100755 (executable)
@@ -1393,7 +1393,8 @@ for x in scanlist:
                errors = check.Run()
                for e in errors:
                        stats[check.repoman_check_name] += 1
-                       fails[check.repoman_check_name].append(x + '/' + y + '.ebuild: %s' % e)
+                       fails[check.repoman_check_name].append(
+                               x + '/' + y + '.ebuild: %s' % e[1] % e[0])
                del check, errors, path, contents, myear
 
                if options.force:
index 3b3b3c179ff368a7a3fdb295826e245743a7f807..d1aad1d8a2ed7850d453f2e4ff0c35d02a414fe6 100644 (file)
@@ -10,5 +10,5 @@ LEADING_SPACES_ERROR = 'Ebuild contains leading spaces on line: %d'
 TRAILING_WHITESPACE_ERROR = 'Trailing whitespace error on line: %d'
 READONLY_ASSIGNMENT_ERROR = 'Ebuild contains assignment to read-only variable on line: %d'
 MISSING_QUOTES_ERROR = 'Unquoted Variable on line: %d'
-NESTED_DIE_ERROR = 'Ebuild calls die in a subshell'
+NESTED_DIE_ERROR = 'Ebuild calls die in a subshell on line: %d'
 REDUNDANT_CD_S_ERROR = 'Ebuild has redundant cd ${S} statement on line: %d'