x11-plugins/wmbinclock: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 1 Mar 2020 15:02:26 +0000 (16:02 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 1 Mar 2020 15:12:42 +0000 (16:12 +0100)
Closes: https://bugs.gentoo.org/707018
Package-Manager: Portage-2.3.90, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmbinclock/files/wmbinclock-0.5-gcc-10.patch [new file with mode: 0644]
x11-plugins/wmbinclock/wmbinclock-0.5-r1.ebuild

diff --git a/x11-plugins/wmbinclock/files/wmbinclock-0.5-gcc-10.patch b/x11-plugins/wmbinclock/files/wmbinclock-0.5-gcc-10.patch
new file mode 100644 (file)
index 0000000..9656e5c
--- /dev/null
@@ -0,0 +1,39 @@
+diff -Naur wmbinclock-0.5.orig/wmBinClock.c wmbinclock-0.5/wmBinClock.c
+--- wmbinclock-0.5.orig/wmBinClock.c   2005-06-21 19:57:58.000000000 +0200
++++ wmbinclock-0.5/wmBinClock.c        2020-03-01 16:01:16.622171968 +0100
+@@ -72,6 +72,13 @@
+ int GotFirstClick3, GotDoubleClick3;
+ int DblClkDelay;
++Display               *display;
++Window          Root;
++Window          iconwin, win;
++int             screen; 
++int             DisplayDepth;
++GC NormalGC;
++
+ void IntToBinary(int x, int *str[]);
+ void PrintHelp(char err[]);
+diff -Naur wmbinclock-0.5.orig/xutils.h wmbinclock-0.5/xutils.h
+--- wmbinclock-0.5.orig/xutils.h       2005-02-04 23:06:34.000000000 +0100
++++ wmbinclock-0.5/xutils.h    2020-03-01 16:01:24.721173796 +0100
+@@ -18,12 +18,12 @@
+ /*
+  *   Global variable
+  */
+-Display               *display;
+-Window          Root;
+-Window          iconwin, win;
+-int             screen; 
+-int             DisplayDepth;
+-GC NormalGC;
++extern Display                *display;
++extern Window          Root;
++extern Window          iconwin, win;
++extern int             screen; 
++extern int             DisplayDepth;
++extern GC NormalGC;
index 77d11a2018b05120a12023c4fe086584104ac6b8..5d9f17b2c38f9035ea8c06868af6eb08f2c32290 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -19,6 +19,8 @@ RDEPEND="x11-libs/libX11
 DEPEND="${RDEPEND}
        x11-base/xorg-proto"
 
+PATCHES=( "${FILESDIR}"/${P}-gcc-10.patch )
+
 src_compile() {
        emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
                INCDIR="-I/usr/include/X11" LIBDIR="" \