dev-python/parver: 0.2.1
authorOz Tiram <oz.tiram@gmail.com>
Mon, 16 Dec 2019 10:30:54 +0000 (11:30 +0100)
committerSebastian Pipping <sping@gentoo.org>
Mon, 16 Dec 2019 13:45:19 +0000 (14:45 +0100)
Closes: https://bugs.gentoo.org/696658
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Oz Tiram <oz.tiram@gmail.com>
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
dev-python/parver/Manifest
dev-python/parver/files/parver-0.2.1-gentoo-versioning.patch [new file with mode: 0644]
dev-python/parver/parver-0.2.1.ebuild [new file with mode: 0644]

index cc5934733980bac7ff3bd18f36b4fa563cd6ed3d..b99d6e0f291da7a9894a74ca53aa1a43deae15d1 100644 (file)
@@ -1 +1,2 @@
 DIST parver-0.1.1.tar.gz 23398 BLAKE2B 2e15ac0c5739ac4d5360cd905d87d0ba1e3831fa975b42c73503f1fdc0952d4a73f36a9eb07cf95a12969637cbfaa902ed46c9a66a85110c17b8ff36c39c87f1 SHA512 d79a4981f3ad77180c5a9c5972410714a1be075308c933bde6af499c25aaa2f82034afb27c0b4c4d7ca269d645285a953a91ea6f945fcac663250ed06ae3accb
+DIST parver-0.2.1.tar.gz 25717 BLAKE2B dd55f44b8bb43ca948fa459537385066b811fca4ff68426365b840d704c30c4a258632f1d2ac2a3967acafcbde44151f1d394ffd96a18d03c6a004ce6b29f1b1 SHA512 674e97d5bef6bb02a659ecf5e1a78fa5d597436b656d0251db20fe330a151ae8de52a3f3f0d3732ccb624ad9093116c07837ba0cbe4ae7ae664b4d47ec3333c3
diff --git a/dev-python/parver/files/parver-0.2.1-gentoo-versioning.patch b/dev-python/parver/files/parver-0.2.1-gentoo-versioning.patch
new file mode 100644 (file)
index 0000000..a2cae61
--- /dev/null
@@ -0,0 +1,29 @@
+diff --git a/setup.py b/setup.py
+index c5c2492..8f5c8c7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -18,9 +18,9 @@ LONG_DESC = open('README.rst', encoding='utf-8').read()
+ extras_require = {
+     'test': [
+-        'pytest ~= 3.5',
+-        'hypothesis ~= 3.56',
+-        'pretend ~= 1.0',
++        'pytest >= 3.5',
++        'hypothesis >= 3.56',
++        'pretend >= 1.0',
+     ],
+     'docstest': [
+         'doc8',
+@@ -49,9 +49,9 @@ setup(
+     packages=find_packages('src'),
+     package_dir={'': 'src'},
+     install_requires=[
+-        'arpeggio ~= 1.7',
++        'arpeggio >= 1.7',
+         'attrs >= 17.4.0',
+-        'six ~= 1.9',
++        'six >= 1.9',
+     ],
+     extras_require=extras_require,
+     python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
diff --git a/dev-python/parver/parver-0.2.1.ebuild b/dev-python/parver/parver-0.2.1.ebuild
new file mode 100644 (file)
index 0000000..4b68ea5
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Parse and manipulate version numbers"
+HOMEPAGE="https://github.com/RazerM/parver https://pypi.org/project/parver/"
+SRC_URI="https://github.com/RazerM/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.2.1-gentoo-versioning.patch
+)
+
+RDEPEND="
+       >=dev-python/arpeggio-1.7[${PYTHON_USEDEP}]
+       dev-python/attrs[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       "
+
+DEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/hypothesis[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/pretend[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       pytest -vv || die "Testing failed"
+}