dev-python/pygit2: Remove redundant version
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Dec 2019 11:17:06 +0000 (12:17 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Dec 2019 11:27:16 +0000 (12:27 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pygit2/Manifest
dev-python/pygit2/pygit2-1.0.0.ebuild [deleted file]

index 30626b83b334143ace5f80576fb151a399189cd2..6e8da0e7e973179d1e3fd8266ad0914e67e5dfd7 100644 (file)
@@ -1,3 +1,2 @@
 DIST pygit2-0.28.2.tar.gz 496469 BLAKE2B 1173401d4555f6f40eaf5a27d9c0e83214b66afa609f15cc4d689e8c58cc0ae3865b4e6ebb31808d354ecef56f3a74cc777fe42314ef348c39f1f61d82655bc9 SHA512 3f742cdcc9d603c9cc9ef2e0a545da8bcfb555a0bdeea1c73c53a284b43d40ad6b28c87a029578ad7b1c8f2bf56ecd2859dac8dd836474bfc66223ff4af9e8f0
-DIST pygit2-1.0.0.tar.gz 501473 BLAKE2B 854f53113bda2ec5c1fd2ba7f2dfc4213d31d3e687fa17d8942b03dd685cd37df28fc8347bd63ede9650de00b980a4cf7aa1196b9feb9a2365e1fc118d187121 SHA512 33296f95aacbfc3cbce275f84c2025767499738495941408de15ac14f822de132995c05c713b815732dbfc3094edf64351d6240e7201e472b3c47035a7532eff
 DIST pygit2-1.0.1.tar.gz 501496 BLAKE2B 6a844a6ecab453f589f407acbd94aba46018a46374ba745ef50e72f4a5eda35103873287af7533ec963a297775eb3703151beec36984dfbcb68d751057c46c78 SHA512 c225204129cdfa41bcc50d76ff219602bfe910cdb77e246c49ecf5265b5a88c5c4803a7d107f4e00c4ec2f0b0d30e1a729d15413bdca8575d6ec23bb9420a90d
diff --git a/dev-python/pygit2/pygit2-1.0.0.ebuild b/dev-python/pygit2/pygit2-1.0.0.ebuild
deleted file mode 100644 (file)
index ade7039..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{5,6,7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       =dev-libs/libgit2-0.28*
-       >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-src_prepare() {
-       distutils-r1_src_prepare
-
-       # unconditionally prevent it from using network
-       sed -i -e '/def no_network/a \
-    return True' test/utils.py || die
-
-       # we need to move them away to prevent pytest from forcing '..'
-       # for imports
-       mkdir hack || die
-       mv test hack/ || die
-       ln -s hack/test test || die
-}
-
-python_test() {
-       pytest -vv hack/test || die
-}