sys-fs/zfs-kmod: bump to 0.8.0_rc5, works with linux-5.1
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 10 May 2019 00:09:09 +0000 (17:09 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 10 May 2019 00:12:42 +0000 (17:12 -0700)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
sys-fs/zfs-kmod/Manifest
sys-fs/zfs-kmod/zfs-kmod-0.8.0_rc5.ebuild [new file with mode: 0644]

index 7d8b4df3603a027710829438f59e5dbc6b82cee4..d461c803f801cb21c253f019f5df55cdf52a81f1 100644 (file)
@@ -2,3 +2,4 @@ DIST zfs-0.6.5.11.tar.gz 2521959 BLAKE2B 95b145a26620995343df1a468367b882bc71ab3
 DIST zfs-0.7.12.tar.gz 6565017 BLAKE2B 493df30ecce1f169e02d6c8262ba71cc9e7b01d5b17ce188004f522f0c93943b858434067cba8173ccb3e08cde24a1d3e8a3996b2e852f8bc35251f8c4ab3809 SHA512 278e411eac5fb2a91108671b64521c2bd5c08024d5829e1679d8f243dfc3c6317363ed9c79dabfddecf425acb6b3003eeaf4e7d991513cbcae4d2644f5d30bf2
 DIST zfs-0.7.13.tar.gz 6614047 BLAKE2B c59c46287715779eb04d69333b0a417fa9865eb0d61c642b043188c4c97d4eed369f76a48327326ed1d4dd608ff95d91d20d26c80ed0b120a8fcd5f83cea638f SHA512 457d8f110b68c9656194cd3738b216d5d807d680e5cfc6ed1f3cf5ebde67860476387c6b862ba3ba7f972d8945075963e6c325543ab84468e3eff5dbce68476e
 DIST zfs-0.8.0-rc4.tar.gz 8874029 BLAKE2B 17dd408bfe5133339548c124529b22312c70f527cca9329a7198c415ee2010e03a967d06d6b56ba25c667c8586476daed97c812ffc26331827aac818eda27282 SHA512 0a1137cf5ed2859dd3876867c4f63b74f117847276a3d9de67736a92cbe5a0c9b2e599bb0e84664f5feb89be36188baacdcc2aa233b498fcfeb6fd946c8b73ea
+DIST zfs-0.8.0-rc5.tar.gz 8994022 BLAKE2B f29b9f6d264bbd04553f6855fbdf039808903eb02989e06082d9db8494723e611736db753fa4d27443527fbac189c1ee282ac89fdf799f6182ae428e178d0d10 SHA512 e54a3f9c7947baf619d737a832a545609bc03774a53f9a65147b8c23d9fb5148400a33d99216205a3e45821f8300108882c4eab9995778611775035441428551
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.8.0_rc5.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.8.0_rc5.ebuild
new file mode 100644 (file)
index 0000000..779b745
--- /dev/null
@@ -0,0 +1,167 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic linux-info linux-mod toolchain-funcs
+
+DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
+HOMEPAGE="https://zfsonlinux.org/"
+
+if [[ ${PV} == "9999" ]]; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/zfsonlinux/zfs.git"
+else
+       MY_PV="${PV/_rc/-rc}"
+       SRC_URI="https://github.com/zfsonlinux/zfs/releases/download/zfs-${MY_PV}/zfs-${MY_PV}.tar.gz"
+       KEYWORDS="~amd64"
+       ZFS_KERNEL_COMPAT="${ZFS_KERNEL_COMPAT_OVERRIDE:-5.1}"
+       S="${WORKDIR}/zfs-${PV%_rc*}"
+fi
+
+LICENSE="CDDL debug? ( GPL-2+ )"
+SLOT="0"
+IUSE="custom-cflags debug +rootfs"
+
+DEPEND=""
+
+RDEPEND="${DEPEND}
+       !sys-fs/zfs-fuse
+       !sys-kernel/spl
+"
+
+BDEPEND="
+       dev-lang/perl
+       virtual/awk
+"
+
+RESTRICT="debug? ( strip ) test"
+
+DOCS=( AUTHORS COPYRIGHT META README.md )
+
+pkg_setup() {
+       linux-info_pkg_setup
+
+       CONFIG_CHECK="
+               !DEBUG_LOCK_ALLOC
+               EFI_PARTITION
+               MODULES
+               !PAX_KERNEXEC_PLUGIN_METHOD_OR
+               !TRIM_UNUSED_KSYMS
+               ZLIB_DEFLATE
+               ZLIB_INFLATE
+       "
+
+       use debug && CONFIG_CHECK="${CONFIG_CHECK}
+               FRAME_POINTER
+               DEBUG_INFO
+               !DEBUG_INFO_REDUCED
+       "
+
+       use rootfs && \
+               CONFIG_CHECK="${CONFIG_CHECK}
+                       BLK_DEV_INITRD
+                       DEVTMPFS
+       "
+
+       kernel_is -lt 5 && CONFIG_CHECK="${CONFIG_CHECK} IOSCHED_NOOP"
+
+       kernel_is -ge 2 6 32 || die "Linux 2.6.32 or newer required"
+
+       if [[ ${PV} != "9999" ]]; then
+               local KV_MAJOR_MAX="${ZFS_KERNEL_COMPAT%%.*}"
+               local KV_MINOR_MAX="${ZFS_KERNEL_COMPAT##*.}"
+               kernel_is -le "${KV_MAJOR_MAX}" "${KV_MINOR_MAX}" || die \
+                       "Linux ${KV_MAJOR_MAX}.${KV_MINOR_MAX} is the latest supported version"
+       fi
+
+       check_extra_config
+}
+
+src_prepare() {
+       default
+
+       if [[ ${PV} == "9999" ]]; then
+               eautoreconf
+       else
+               # Set module revision number
+               sed -i "s/\(Release:\)\(.*\)1/\1\2${PR}-gentoo/" META || die "Could not set Gentoo release"
+       fi
+
+       # Remove GPLv2-licensed ZPIOS unless we are debugging
+       use debug || sed -e 's/^subdir-m += zpios$//' -i module/Makefile.in
+}
+
+src_configure() {
+       set_arch_to_kernel
+
+       use custom-cflags || strip-flags
+
+       filter-ldflags -Wl,*
+
+       local myconf=(
+               --bindir="${EPREFIX}/bin"
+               --sbindir="${EPREFIX}/sbin"
+               --with-config=kernel
+               --with-linux="${KV_DIR}"
+               --with-linux-obj="${KV_OUT_DIR}"
+               $(use_enable debug)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_compile() {
+       set_arch_to_kernel
+
+       default
+}
+
+src_install() {
+       set_arch_to_kernel
+
+       emake \
+               DEPMOD="/bin/true" \
+               DESTDIR="${D}" \
+               INSTALL_MOD_PATH="${INSTALL_MOD_PATH:-$EROOT}" \
+               install
+
+       einstalldocs
+}
+
+pkg_postinst() {
+       linux-mod_pkg_postinst
+
+       # Remove old modules
+       if [[ -d "${EROOT}/lib/modules/${KV_FULL}/addon/zfs" ]]; then
+               ewarn "${PN} now installs modules in ${EROOT}/lib/modules/${KV_FULL}/extra/zfs"
+               ewarn "Old modules were detected in ${EROOT}/lib/modules/${KV_FULL}/addon/zfs"
+               ewarn "Automatically removing old modules to avoid problems."
+               rm -r "${EROOT}/lib/modules/${KV_FULL}/addon/zfs" || die "Cannot remove modules"
+               rmdir --ignore-fail-on-non-empty "${EROOT}/lib/modules/${KV_FULL}/addon"
+       fi
+
+       if use x86 || use arm; then
+               ewarn "32-bit kernels will likely require increasing vmalloc to"
+               ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
+       fi
+
+       ewarn "This version of ZFSOnLinux includes support for new feature flags"
+       ewarn "that are incompatible with previous versions. GRUB2 support for"
+       ewarn "/boot with the new feature flags is not yet available."
+       ewarn "Do *NOT* upgrade root pools to use the new feature flags."
+       ewarn "Any new pools will be created with the new feature flags by default"
+       ewarn "and will not be compatible with older versions of ZFSOnLinux. To"
+       ewarn "create a newpool that is backward compatible wih GRUB2, use "
+       ewarn
+       ewarn "zpool create -d -o feature@async_destroy=enabled "
+       ewarn " -o feature@empty_bpobj=enabled -o feature@lz4_compress=enabled"
+       ewarn " -o feature@spacemap_histogram=enabled"
+       ewarn " -o feature@enabled_txg=enabled "
+       ewarn " -o feature@extensible_dataset=enabled -o feature@bookmarks=enabled"
+       ewarn " ..."
+       ewarn
+       ewarn "GRUB2 support will be updated as soon as either the GRUB2"
+       ewarn "developers do a tag or the Gentoo developers find time to backport"
+       ewarn "support from GRUB2 HEAD."
+}