sci-libs/libsigrok: Install udev rules, bug #671716
authorSven Wegener <swegener@gentoo.org>
Fri, 12 Apr 2019 15:42:24 +0000 (15:42 +0000)
committerSven Wegener <swegener@gentoo.org>
Fri, 12 Apr 2019 15:44:11 +0000 (15:44 +0000)
Closes: https://bugs.gentoo.org/671716
Signed-off-by: Sven Wegener <swegener@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

sci-libs/libsigrok/libsigrok-0.5.1.ebuild
sci-libs/libsigrok/libsigrok-9999.ebuild

index 8ebbf15dc3dedc800f5cf29a168dad6324d4d016..5c92de1d5d3ee58e097705becf12f55c7555523f 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
 
 PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
 
-inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 xdg-utils
+inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 udev xdg-utils
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="git://sigrok.org/${PN}"
@@ -20,7 +20,7 @@ HOMEPAGE="https://sigrok.org/wiki/Libsigrok"
 
 LICENSE="GPL-3"
 SLOT="0/4"
-IUSE="cxx ftdi java parport python serial static-libs test usb"
+IUSE="cxx ftdi java parport python serial static-libs test +udev usb"
 REQUIRED_USE="java? ( cxx ) python? ( cxx ${PYTHON_REQUIRED_USE} )"
 
 # We also support librevisa, but that isn't in the tree ...
@@ -78,6 +78,7 @@ src_test() {
 
 src_install() {
        default
+       use udev && udev_dorules contrib/*.rules
        prune_libtool_files
 }
 
index 694f44c3d6035196d68943bfbd70bc8a3c5600b4..4c9fa1e48079c61da4957473e5d0b212e10a5f55 100644 (file)
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
 
 PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
 
-inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 xdg-utils
+inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 udev xdg-utils
 
 if [[ ${PV} == "9999" ]]; then
        EGIT_REPO_URI="git://sigrok.org/${PN}"
@@ -20,7 +20,7 @@ HOMEPAGE="https://sigrok.org/wiki/Libsigrok"
 
 LICENSE="GPL-3"
 SLOT="0/9999"
-IUSE="cxx ftdi java parport python serial static-libs test usb"
+IUSE="cxx ftdi java parport python serial static-libs test +udev usb"
 REQUIRED_USE="java? ( cxx ) python? ( cxx ${PYTHON_REQUIRED_USE} )"
 
 # We also support librevisa, but that isn't in the tree ...
@@ -78,6 +78,7 @@ src_test() {
 
 src_install() {
        default
+       use udev && udev_dorules contrib/*.rules
        prune_libtool_files
 }