net-mail/cyrus-imapd: bump to 3.0.9
authorEray Aslan <eras@gentoo.org>
Fri, 15 Mar 2019 07:38:16 +0000 (10:38 +0300)
committerEray Aslan <eras@gentoo.org>
Fri, 15 Mar 2019 07:38:16 +0000 (10:38 +0300)
and fix underlinking perl modules
Closes: https://bugs.gentoo.org/678754
Package-Manager: Portage-2.3.62, Repoman-2.3.12
Signed-off-by: Eray Aslan <eras@gentoo.org>
net-mail/cyrus-imapd/Manifest
net-mail/cyrus-imapd/cyrus-imapd-3.0.9.ebuild [new file with mode: 0644]
net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs-r1.patch [new file with mode: 0644]

index 36d2675692e66ce89c424e10401fd3b6f5993e19..6f70f5a78588969eb21e49177263de4d88dd0c0a 100644 (file)
@@ -4,3 +4,4 @@ DIST cyrus-imapd-3.0.4.tar.gz 10819487 BLAKE2B 209e379731c996ee083b0de61d6122b37
 DIST cyrus-imapd-3.0.5.tar.gz 10910080 BLAKE2B a7914ab189a290427ddc0d013c19ff0c36f3a6c4fc016f50013d0f6abb11ae2f7d067b71df99b7f00ba4e8a2170e0f068baa170458b0dc1e94d69d8e4b814873 SHA512 262806729d5ee5d753732603aa7af33c6f96bc5145b7a951b8668ffdee0dcd4a90bd287da0949e85c4596cccb471a688f7f8b6f3e39194e1cff311950d4d4410
 DIST cyrus-imapd-3.0.6.tar.gz 10734548 BLAKE2B d16d1093b17f632fa75e77c1b923deb0c5a76de4c06a657c4c1dd2f9498ac0abd81ecee58c64378118d4b09be872957afc6db5d8deebf72c819623d6ea5aa0a9 SHA512 375e3936465e9ee448996cf738ebe93a35697a58a7784cf6f7a8be25e3e03925fb4f44ff98a0aacbc5b9e3ef39fc8a0e51acb4ea26cbbfbc8e492556fdc03a03
 DIST cyrus-imapd-3.0.8.tar.gz 10735462 BLAKE2B 27fdead9a75048c12fe4c0eed1dcda9ce24319c2183851190068fd3ded32c1f6b4d550e726dd4a483bafe298ac0199aa2b1354c6f0c5ac0083d7d1ad0e69457a SHA512 f4aa9877e62479439bee2ca29f452bd7e9daa091c19bf3567aa7f493f5163c98b44086b749c70981402212ff90e19d9125b508cfcc077088f8c705e533812960
+DIST cyrus-imapd-3.0.9.tar.gz 10771916 BLAKE2B cc483246c83ed55fa7d4e85aa8189852f2e6be23aff5bb478c2d2123e3d928cc8248e580c80c1474b2b3eea9aa1c0f8b3336f779e72e690d8d093e70993cd657 SHA512 d1a65e957ad3bbbd70e4c8c699e226c17911c6f5815839694136b967a7067acaf4261c8aaad223ffb1e41d76ef78e9e7279a2805048de9b05939044ce17cb738
diff --git a/net-mail/cyrus-imapd/cyrus-imapd-3.0.9.ebuild b/net-mail/cyrus-imapd/cyrus-imapd-3.0.9.ebuild
new file mode 100644 (file)
index 0000000..c6ba076
--- /dev/null
@@ -0,0 +1,218 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic pam ssl-cert user
+
+DESCRIPTION="The Cyrus IMAP Server"
+HOMEPAGE="http://www.cyrusimap.org/"
+SRC_URI="https://github.com/cyrusimap/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="BSD-with-attribution"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="afs backup calalarm caps clamav http kerberos ldap lmdb \
+       mysql nntp pam perl postgres replication +server sieve snmp \
+       sphinx sqlite ssl static-libs tcpd test xapian"
+
+# virtual/mysql-5.5 added for the --variable= option below
+CDEPEND="sys-libs/zlib
+       dev-libs/libpcre
+       >=dev-libs/cyrus-sasl-2.1.13
+       dev-libs/jansson
+       dev-libs/icu:=
+       sys-libs/e2fsprogs-libs
+       afs? ( net-fs/openafs )
+       calalarm? ( dev-libs/libical )
+       caps? ( sys-libs/libcap )
+       clamav? ( app-antivirus/clamav )
+       http? ( dev-libs/libxml2 dev-libs/libical )
+       kerberos? ( virtual/krb5 )
+       ldap? ( net-nds/openldap )
+       lmdb? ( dev-db/lmdb )
+       mysql? ( dev-db/mysql-connector-c:0= )
+       nntp? ( !net-nntp/leafnode )
+       pam? (
+                       virtual/pam
+                       >=net-mail/mailbase-1
+               )
+       perl? ( dev-lang/perl:= )
+       postgres? ( dev-db/postgresql:* )
+       snmp? ( >=net-analyzer/net-snmp-5.2.2-r1 )
+       ssl? ( >=dev-libs/openssl-1.0.1e:0[-bindist] )
+       sqlite? ( dev-db/sqlite:3 )
+       tcpd? ( >=sys-apps/tcp-wrappers-7.6 snmp? ( net-analyzer/net-snmp[tcpd=] ) )
+       xapian? ( >=dev-libs/xapian-1.4.0 )"
+
+DEPEND="${CDEPEND}
+       test? ( dev-util/cunit )"
+
+# all blockers really needed?
+# file collision with app-arch/dump - bug 619584
+RDEPEND="${CDEPEND}
+       !mail-mta/courier
+       !net-mail/bincimap
+       !net-mail/courier-imap
+       !net-mail/uw-imap
+       !app-arch/dump"
+
+REQUIRED_USE="afs? ( kerberos )
+       backup? ( sqlite )
+       calalarm? ( http )
+       http? ( sqlite )
+       sphinx? ( mysql )"
+
+# https://bugs.gentoo.org/678754
+# TODO: check underlinking for other libraries
+PATCHES=( "${FILESDIR}/cyrus-imapd-libcap-libs-r1.patch" )
+
+pkg_setup() {
+       enewuser cyrus -1 -1 /usr/cyrus mail
+       # https://bugs.gentoo.org/604466
+       append-ldflags $(no-as-needed)
+}
+
+src_prepare() {
+       default
+       # Fix master(8)->cyrusmaster(8) manpage.
+       for i in `grep -rl -e 'master\.8' -e 'master(8)' "${S}"` ; do
+               sed -i -e 's:master\.8:cyrusmaster.8:g' \
+                       -e 's:master(8):cyrusmaster(8):g' \
+                       "${i}" || die "sed failed" || die "sed failed"
+       done
+       mv man/master.8 man/cyrusmaster.8 || die "mv failed"
+       sed -i -e "s:MASTER:CYRUSMASTER:g" \
+               -e "s:Master:Cyrusmaster:g" \
+               -e "s:master:cyrusmaster:g" \
+               man/cyrusmaster.8 || die "sed failed"
+
+       # lock.h to afs/lock.h
+       sed -i -e '/lock.h/s:lock.h:afs/lock.h:' \
+               ptclient/afskrb.c || die
+
+       eautoreconf
+}
+
+src_configure() {
+       local myconf
+       if use afs ; then
+               myconf+=" --with-afs-libdir=/usr/$(get_libdir)"
+               myconf+=" --with-afs-incdir=/usr/include/afs"
+       fi
+       econf \
+               --enable-unit-tests \
+               --enable-murder \
+               --enable-idled \
+               --enable-event-notification \
+               --enable-autocreate \
+               --enable-pcre \
+               --with-com_err \
+               --with-cyrus-user=cyrus \
+               --with-sasl \
+               --without-krb \
+               --without-krbdes \
+               --enable-squat \
+               --with-zlib \
+               $(use_enable afs) \
+               $(use_enable afs krb5afspts) \
+               $(use_enable backup) \
+               $(use_enable calalarm calalarmd) \
+               $(use_with caps libcap) \
+               $(use_with clamav) \
+               $(use_enable nntp) \
+               $(use_enable http) \
+               $(use_enable replication) \
+               $(use_enable kerberos gssapi) \
+               $(use_with ldap) \
+               $(use_with lmdb) \
+               $(use_with mysql) \
+               $(use_with postgres pgsql) \
+               $(use_with perl) \
+               $(use_with sqlite) \
+               $(use_with ssl openssl) \
+               $(use_enable server) \
+               $(use_enable sieve) \
+               $(use_with snmp) \
+               $(use_enable sphinx) \
+               $(use_enable static-libs static) \
+               $(use_with tcpd libwrap) \
+               $(use_enable xapian) \
+               ${myconf}
+}
+
+src_install() {
+       emake DESTDIR="${D}" INSTALLDIRS=vendor install
+
+       dodoc README*
+       dodoc -r doc
+       cp -r contrib tools "${D}/usr/share/doc/${PF}"
+       rm -f doc/text/Makefile*
+
+       mv "${D}"usr/libexec/{master,cyrusmaster} || die
+
+       insinto /etc
+       newins "${D}usr/share/doc/${PF}/doc/examples/cyrus_conf/normal.conf" cyrus.conf
+       newins "${D}usr/share/doc/${PF}/doc/examples/imapd_conf/normal.conf" imapd.conf
+
+       sed -i -e '/^configdirectory/s|/var/.*|/var/imap|' \
+               -e '/^partition-default/s|/var/.*|/var/spool/imap|' \
+               -e '/^sievedir/s|/var/.*|/var/imap/sieve|' \
+               "${D}"etc/imapd.conf
+
+       sed -i -e 's|/var/imap/socket/lmtp|/run/cyrus/socket/lmtp|' \
+               -e 's|/var/imap/socket/notify|/run/cyrus/socket/notify|' \
+               "${D}"etc/cyrus.conf
+
+       # turn off sieve if not installed
+       if ! use sieve; then
+               sed -i -e "/sieve/s/^/#/" "${D}/etc/cyrus.conf" || die
+       fi
+       # same thing for http(s) as well
+       if ! use http; then
+               sed -i -e "/http/s/^/#/" "${D}/etc/cyrus.conf" || die
+       fi
+
+       newinitd "${FILESDIR}/cyrus.rc8" cyrus
+       newconfd "${FILESDIR}/cyrus.confd" cyrus
+       newpamd "${FILESDIR}/cyrus.pam-include" sieve
+
+       for subdir in imap/{,db,log,msg,proc,socket,sieve} spool/imap/{,stage.} ; do
+               keepdir "/var/${subdir}"
+               fowners cyrus:mail "/var/${subdir}"
+               fperms 0750 "/var/${subdir}"
+       done
+       for subdir in imap/{user,quota,sieve} spool/imap ; do
+               for i in a b c d e f g h i j k l m n o p q r s t v u w x y z ; do
+                       keepdir "/var/${subdir}/${i}"
+                       fowners cyrus:mail "/var/${subdir}/${i}"
+                       fperms 0750 "/var/${subdir}/${i}"
+               done
+       done
+}
+
+pkg_preinst() {
+       if ! has_version ${CATEGORY}/${PN} ; then
+               elog "For correct logging add the following to /etc/syslog.conf:"
+               elog "    local6.*         /var/log/imapd.log"
+               elog "    auth.debug       /var/log/auth.log"
+               echo
+
+               elog "You have to add user cyrus to the sasldb2. Do this with:"
+               elog "    saslpasswd2 cyrus"
+       fi
+}
+
+pkg_postinst() {
+       # do not install server.{key,pem) if they exist
+       if use ssl ; then
+               if [ ! -f "${ROOT}"etc/ssl/cyrus/server.key ]; then
+                       install_cert /etc/ssl/cyrus/server
+                       chown cyrus:mail "${ROOT}"etc/ssl/cyrus/server.{key,pem}
+               fi
+       fi
+
+       echo
+       einfo "Please see http://www.cyrusimap.org/imap/download/upgrade.html"
+       einfo "for upgrade instructions."
+       echo
+}
diff --git a/net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs-r1.patch b/net-mail/cyrus-imapd/files/cyrus-imapd-libcap-libs-r1.patch
new file mode 100644 (file)
index 0000000..4b1a510
--- /dev/null
@@ -0,0 +1,35 @@
+--- a/configure.ac     2017-07-15 07:26:38.375295969 +0200
++++ b/configure.ac     2017-07-15 07:28:33.250194410 +0200
+@@ -1351,7 +1351,9 @@
+                 AC_CHECK_HEADERS([sys/capability.h sys/prctl.h], , have_libcap=no)
+                 if test "$have_libcap" = "yes"; then
+                         AC_DEFINE(HAVE_LIBCAP, [], [Do we have libcap system capabilities handling (Linux systems only)?])
+-                        LIBS="$LIBS -lcap"
++                        LIBCAP="-lcap"
++                        AC_SUBST(LIBCAP)
++                        LIBS="$LIBS $LIBCAP"
+                 fi
+         fi
+         ;;
+--- a/perl/imap/Makefile.PL.in 2019-02-25 15:43:44.370676803 +0100
++++ b/perl/imap/Makefile.PL.in 2019-02-25 15:44:02.595285944 +0100
+@@ -90,7 +90,7 @@
+     'clean'   => {'FILES' => 'libcyrperl.a cyradm'},
+     'OBJECT'    => 'IMAP.o',
+     'MYEXTLIB'  => '@top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+-    'LIBS'    => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@"],
++    'LIBS'    => [ "$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @LIBCAP@"],
+     'DEFINE'  => '-DPERL_POLLUTE',    # e.g., '-DHAVE_SOMETHING' 
+     'INC'     => "-I@top_srcdir@ -I@top_srcdir@/com_err/et @SASLFLAGS@ @SSL_CPPFLAGS@ -I@top_srcdir@/perl/imap", 
+     'EXE_FILES' => [cyradm],
+--- a/perl/sieve/managesieve/Makefile.PL.in    2019-02-25 15:42:40.852554632 +0100
++++ b/perl/sieve/managesieve/Makefile.PL.in    2019-02-25 15:43:05.029362231 +0100
+@@ -69,7 +69,7 @@
+     'ABSTRACT'  => 'Cyrus Sieve management interface',
+     'VERSION_FROM' => "@top_srcdir@/perl/sieve/managesieve/managesieve.pm", # finds $VERSION
+     'MYEXTLIB'  => '../lib/.libs/libisieve.a @top_builddir@/perl/.libs/libcyrus.a @top_builddir@/perl/.libs/libcyrus_min.a',
+-    'LIBS'    => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @SQLITE_LIBADD@ @MYSQL_LIBADD@ @PGSQL_LIBADD@"],
++    'LIBS'    => ["$LIB_SASL @SSL_LIBS@ @LIB_UUID@ @ZLIB@ @SQLITE_LIBADD@ @MYSQL_LIBADD@ @PGSQL_LIBADD@ @LIBCAP@"],
+     'CCFLAGS' => '@GCOV_CFLAGS@',
+     'DEFINE'  => '-DPERL_POLLUTE',     # e.g., '-DHAVE_SOMETHING' 
+     'INC'     => "-I@top_srcdir@/lib -I@top_srcdir@/perl/sieve -I@top_srcdir@/perl/sieve/lib @SASLFLAGS@ @SSL_CPPFLAGS@",