media-libs/lv2-1.16.0: bump
authorMiroslav Šulc <fordfrog@gentoo.org>
Sat, 14 Dec 2019 12:58:29 +0000 (13:58 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Sat, 14 Dec 2019 13:01:40 +0000 (14:01 +0100)
1) removed python2_7, added python3_7
2) reorganized deps, removed obsolete blockers

Closes: https://bugs.gentoo.org/696394
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-libs/lv2/Manifest
media-libs/lv2/lv2-1.16.0.ebuild [new file with mode: 0644]

index 18a19362a84440f9b4d2509187700e842b393d4e..3f3b100127d6091d5c94ad72ce0959cca6399a2a 100644 (file)
@@ -1 +1,2 @@
 DIST lv2-1.14.0.tar.bz2 386438 BLAKE2B e09e6c2b1bbf24d5896e7803b970fd8877a5b6a9ded0fcf294561c365d5f0b2e89503c0306b02dd956f7ac6ebd9df4ca0c0a17564ef3851443d81847dd41b261 SHA512 6991d848ed9f04a48ca3070efc15af83431f680aa8a8559a02b1666f7b8d43af8e089f78c3b14ad3345dac32fd1c8ad0faf3a3f56dddc07c6f0e0aeef4077498
+DIST lv2-1.16.0.tar.bz2 502116 BLAKE2B 00b364311f61b1a9f251d8eb3e27b66d4a59e313006df549dbb80fc6a1106b588bc59c7766910037ee093254d96e508f8538615666833b0c00c8282301bfe0e4 SHA512 ead6d590cded5dd7a548d6ffe0f2f9f8efadfa7bb9e8b4fa0aea6664ccdfbb3ca697514bddebe695a9442fba5b62714b5cd45c1bf7d0aaef12ffe50972c2d88c
diff --git a/media-libs/lv2/lv2-1.16.0.ebuild b/media-libs/lv2/lv2-1.16.0.ebuild
new file mode 100644 (file)
index 0000000..2dc4fcf
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit python-single-r1 waf-utils multilib-build multilib-minimal
+
+DESCRIPTION="A simple but extensible successor of LADSPA"
+HOMEPAGE="http://lv2plug.in/"
+SRC_URI="http://lv2plug.in/spec/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc plugins"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+       plugins? ( virtual/pkgconfig )
+       doc? ( app-doc/doxygen dev-python/rdflib )
+"
+CDEPEND="
+       ${PYTHON_DEPS}
+       plugins? ( x11-libs/gtk+:2 media-libs/libsndfile )
+"
+DEPEND="${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       dev-python/lxml[${PYTHON_USEDEP}]
+       dev-python/pygments[${PYTHON_USEDEP}]
+       dev-python/rdflib[${PYTHON_USEDEP}]
+"
+DOCS=( "README.md" "NEWS" )
+
+src_prepare() {
+       default
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       waf-utils_src_configure \
+               --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+               --lv2dir="${EPREFIX}"/usr/$(get_libdir)/lv2 \
+               $(use plugins || echo " --no-plugins") \
+               $(multilib_native_usex doc --docs "")
+}
+
+multilib_src_install() {
+       waf-utils_src_install
+}
+
+multilib_src_install_all() {
+       python_fix_shebang "${D}"
+}