dev-python/contextlib2: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 19:56:06 +0000 (21:56 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 May 2020 20:14:28 +0000 (22:14 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/contextlib2/contextlib2-0.6.0_p1.ebuild

index 114a17add9f9858fcd5f90acf5024f8568df1a6e..341b0e956fa57d5fed8b99bbf428492a2e2e24cc 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
 
 inherit distutils-r1
 
@@ -18,7 +18,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~
 IUSE="test"
 
 DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( $(python_gen_cond_dep '
                        dev-python/unittest2[${PYTHON_USEDEP}]
                        ' python2_7 pypy3