Fix bug #146580, thanks to Aurélien Francillon for the patch.
authorSandro Bonazzola <sanchan@gentoo.org>
Wed, 6 Sep 2006 19:57:30 +0000 (19:57 +0000)
committerSandro Bonazzola <sanchan@gentoo.org>
Wed, 6 Sep 2006 19:57:30 +0000 (19:57 +0000)
Package-Manager: portage-2.1.1_rc1-r4

dev-tinyos/tos-apps/ChangeLog
dev-tinyos/tos-apps/files/digest-tos-apps-1.1.15-r1 [new file with mode: 0644]
dev-tinyos/tos-apps/files/tos-apps-1.1.15-TOSBase-types-conflict-fix.patch [new file with mode: 0644]
dev-tinyos/tos-apps/tos-apps-1.1.15-r1.ebuild [new file with mode: 0644]

index 649bd50da5f309a540274c47d67d878912ffc9fe..6bb972df2031679ad712e1977a8383a4364d7588 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for dev-tinyos/tos-apps
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/tos-apps/ChangeLog,v 1.2 2006/08/09 19:48:55 sanchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/tos-apps/ChangeLog,v 1.3 2006/09/06 19:57:30 sanchan Exp $
+
+*tos-apps-1.1.15-r1 (06 Sep 2006)
+
+  06 Sep 2006; Sandro Bonazzola <sanchan@gentoo.org>
+  +files/tos-apps-1.1.15-TOSBase-types-conflict-fix.patch,
+  -tos-apps-1.1.15.ebuild, +tos-apps-1.1.15-r1.ebuild:
+  Fix bug #146580, thanks to AurĂ©lien Francillon for the patch.
 
   09 Aug 2006; Sandro Bonazzola <sanchan@gentoo.org> tos-apps-1.1.15.ebuild:
   Moving important info from einfo to elog.
diff --git a/dev-tinyos/tos-apps/files/digest-tos-apps-1.1.15-r1 b/dev-tinyos/tos-apps/files/digest-tos-apps-1.1.15-r1
new file mode 100644 (file)
index 0000000..a4d5cf8
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 4e9535229eab02ee1f198b244c04bcd6 tinyos-1.1.15Dec2005cvs.tar.gz 10273122
+RMD160 cddbcf32e53352d04be2eda49852540650e73088 tinyos-1.1.15Dec2005cvs.tar.gz 10273122
+SHA256 78f985eb83293cf10f23013f771c7f5d130f9a240a4dcda02321e10c3b5a341f tinyos-1.1.15Dec2005cvs.tar.gz 10273122
diff --git a/dev-tinyos/tos-apps/files/tos-apps-1.1.15-TOSBase-types-conflict-fix.patch b/dev-tinyos/tos-apps/files/tos-apps-1.1.15-TOSBase-types-conflict-fix.patch
new file mode 100644 (file)
index 0000000..e8b1ddf
--- /dev/null
@@ -0,0 +1,19 @@
+--- tinyos-1.1.15Dec2005cvs/apps/TOSBase/TOSBaseM.nc.orig      2006-09-06 18:12:43.000000000 +0200
++++ tinyos-1.1.15Dec2005cvs/apps/TOSBase/TOSBaseM.nc   2006-09-06 18:21:02.000000000 +0200
+@@ -70,12 +70,12 @@
+   };
+   TOS_Msg    uartQueueBufs[UART_QUEUE_LEN];
+-  uint8_t    uartIn, uartOut;
+-  bool       uartBusy, uartCount;
++  uint8_t    uartIn, uartOut, uartCount;
++  bool       uartBusy;
+   TOS_Msg    radioQueueBufs[RADIO_QUEUE_LEN];
+-  uint8_t    radioIn, radioOut;
+-  bool       radioBusy, radioCount;
++  uint8_t    radioIn, radioOut, radioCount;
++  bool       radioBusy;
+   task void UARTSendTask();
+   task void RadioSendTask();
diff --git a/dev-tinyos/tos-apps/tos-apps-1.1.15-r1.ebuild b/dev-tinyos/tos-apps/tos-apps-1.1.15-r1.ebuild
new file mode 100644 (file)
index 0000000..77f1cb0
--- /dev/null
@@ -0,0 +1,68 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tinyos/tos-apps/tos-apps-1.1.15-r1.ebuild,v 1.1 2006/09/06 19:57:30 sanchan Exp $
+inherit eutils
+
+CVS_MONTH="Dec"
+CVS_YEAR="2005"
+MY_PN="tinyos"
+MY_P=${MY_PN}-${PV}${CVS_MONTH}${CVS_YEAR}cvs
+
+DESCRIPTION="TinyOS apps: TinyOS bundled applications."
+HOMEPAGE="http://www.tinyos.net/"
+SRC_URI="http://www.tinyos.net/dist-1.1.0/tinyos/source/${MY_P}.tar.gz"
+LICENSE="Intel"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-tinyos/tos-1.1.15"
+RDEPEND=">=dev-tinyos/tos-make-1.1.15"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+       if [ -z "${TOSROOT}" ]
+       then
+               export TOSROOT=/usr/src/tinyos-1.x
+       fi
+
+       if [ ! -d "${TOSROOT}" ]
+       then
+               eerror "In order to emerge tos-apps you have to set the"
+               eerror "\$TOSROOT environment properly."
+               eerror ""
+               eerror "You can achieve this by emerging >=dev-tinyos/tos-1.1.15"
+               eerror "or by exporting TOSDIR=\"path to your tinyos dir\""
+               die "Couldn't find a valid TinyOS home"
+       else
+               einfo "Building tos-apps for ${TOSROOT}"
+       fi
+}
+
+src_unpack(){
+       unpack ${A}
+       cd ${S}
+       for i in `find . -name CVS`; do
+               rm -rf "${i}"
+       done
+       epatch ${FILESDIR}/tos-apps-1.1.15-TOSBase-types-conflict-fix.patch
+}
+
+src_compile() {
+       einfo "Nothing to compile."
+}
+
+src_install() {
+       insinto ${TOSROOT}
+       doins -r apps
+       chown -R root:0 "${D}"
+}
+
+pkg_postinst() {
+       elog "If you want to use TinyOS on real hardware you need a cross compiler."
+       elog "You should emerge sys-devel/crossdev and compile any toolchain you need"
+       elog "Example: for Mica2 and Mica2 Dot: crossdev --target avr"
+       ebeep 5
+       epause 5
+}
+