dev-python/paver: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:35:13 +0000 (12:35 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:36:42 +0000 (12:36 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/paver/Manifest
dev-python/paver/paver-1.2.4.ebuild [deleted file]
dev-python/paver/paver-1.3.4.ebuild [deleted file]

index 7cfbf5365de7c93ad37504070bcb673fa4b4cc6e..de0b9ed71854b0d9b01e1f6bf1db1eea32581585 100644 (file)
@@ -1,2 +1 @@
-DIST Paver-1.2.4.tar.gz 328794 BLAKE2B f81db3fa8fae72b9719b51d0643ba9495734bc351a6b3d5e86ba6f4afd778cf70157c427cc8e7741828c97197d8961c10f49dcd92b6fb22c810c73a2d26a2668 SHA512 ba737f2da0582d4c3364b654a79d9868bb394fcbf1102feea3604821a65075631fbdb7b767ba8977f3231bcb6cf167abd994fb1dd9fd080046ea8bcfde8cdeb7
 DIST Paver-1.3.4.tar.gz 446425 BLAKE2B 6ed6014e45d0d54f5323fba7a2aa713f860b6d8a7e6ed2d409f17e02b245b516196cf298602dea98022efc640cb2a94fddec060a396d02807fb872240a3bff3e SHA512 f29d6a67ebae8100f3dc7f7cea06acf5606c4c3691be49a86cd85ff69aecff4441c28e41ce5e1b79050d32946f9bb55b213e68ee966ffc0ae1e0b0bea4871aa7
diff --git a/dev-python/paver/paver-1.2.4.ebuild b/dev-python/paver/paver-1.2.4.ebuild
deleted file mode 100644 (file)
index 65a9b33..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN=${PN/p/P}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python-based software project scripting tool along the lines of Make"
-HOMEPAGE="http://www.blueskyonmars.com/projects/paver/ https://github.com/paver/paver"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x64-macos ~x86-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       test? ( dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
-       # https://github.com/paver/paver/issues/143#issuecomment-103943327
-       find paver/tests -name '*.pyc' -delete || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/paver/paver-1.3.4.ebuild b/dev-python/paver/paver-1.3.4.ebuild
deleted file mode 100644 (file)
index fc9c4b9..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-MY_PN=${PN/p/P}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python-based software project scripting tool along the lines of Make"
-HOMEPAGE="http://www.blueskyonmars.com/projects/paver/ https://github.com/paver/paver"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-DEPEND="
-       ${RDEPEND}
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
-       # https://github.com/paver/paver/issues/143#issuecomment-103943327
-       find paver/tests -name '*.pyc' -delete || die
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       nosetests || die "Testing failed with ${EPYTHON}"
-}