dev-python/socketpool: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 17:07:53 +0000 (19:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 26 May 2020 18:09:47 +0000 (20:09 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/socketpool/socketpool-0.5.3-r3.ebuild

index f0bfe38bf1050f1b22b56044bd5e1c562120adf5..b96eb34c7eb1ff3099e57be7ed260b562c5366a4 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
 
 inherit distutils-r1
 
@@ -44,6 +44,13 @@ PATCHES=( "${FILESDIR}"/${PN}-0.5.2-locale.patch )
 
 distutils_enable_tests pytest
 
+src_prepare() {
+       # py3.9
+       sed -i -e 's:isAlive:is_alive:' socketpool/backend_thread.py || die
+
+       distutils-r1_src_prepare
+}
+
 python_test() {
        cp -r examples tests "${BUILD_DIR}" || die