sys-apps/pcsc-lite: version bump
authorAlon Bar-Lev <alonbl@gentoo.org>
Tue, 11 Aug 2015 19:59:27 +0000 (22:59 +0300)
committerAlon Bar-Lev <alonbl@gentoo.org>
Tue, 11 Aug 2015 20:08:57 +0000 (23:08 +0300)
Bug: 557258

Package-Manager: portage-2.2.20

sys-apps/pcsc-lite/Manifest
sys-apps/pcsc-lite/pcsc-lite-1.8.14.ebuild [new file with mode: 0644]

index abf623fe2a4708785b5c91b8a383c10d148c6bb9..fd863b0ea2fa0190454880021b81873af06bf96f 100644 (file)
@@ -1,2 +1,3 @@
 DIST pcsc-lite-1.8.12.tar.bz2 580449 SHA256 f2c30a2aba6805f2859ede5f2eca351ca6c495a18d5d36d74c63e7898b353c51 SHA512 b0ed94187052e0ff73030ecf9f5165d4f8dc4a7f1eb05c6c57c0e5552ae6699c53f12cd72e09812de3c55be86a08ab060a92ad08b5db2686dfa1afbaca336d87 WHIRLPOOL c6feed97170a640b6ee86e2188a124995acf73f618cfc5d4f1cf68a7f8da5955330a255b211606ebb5d50d58a4cfad859a7004fddf06c6476838458e3b7162c3
 DIST pcsc-lite-1.8.13.tar.bz2 584083 SHA256 f315047e808d63a3262c4a040f77548af2e04d1fd707e0c2759369b926fbbc3b SHA512 ce45b48fa0da568690e25f80c8b37c201f8a6eb411c7d12a55748af16eda1d8b39984261f562c5af50ff79d7476597e3363097cb5f0b6ca8fa009d9321d02023 WHIRLPOOL 6bf25e06e26583a8a5ac7f2e7c53f85f3aee0942d838c11afa40c2c95ef4dae805a00c813a11e5eb20221f2a2004608da6fea48b00d6edd661cc728e68d1989f
+DIST pcsc-lite-1.8.14.tar.bz2 689197 SHA256 b91f97806042315a41f005e69529cb968621f73f2ddfbd1380111a175b02334e SHA512 a374ee254403b57a9bb24629e1d2d867b4b2046126f06fcc9df5d2e4b1ab9e8e2daddf371082c829e40d0874d2e84a8d657240857cc928242adfbbb1516c3362 WHIRLPOOL 9a045ba14273324661e9d8dddfa4ed0bdc89ecc8bd3a06c28e428b8a84f30ca97d9dd91718c7e83dffd20fad90ddab3d02de886b75cfb080b4eb205fe9b49a78
diff --git a/sys-apps/pcsc-lite/pcsc-lite-1.8.14.ebuild b/sys-apps/pcsc-lite/pcsc-lite-1.8.14.ebuild
new file mode 100644 (file)
index 0000000..f082a9c
--- /dev/null
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 multilib systemd udev user autotools-multilib
+
+DESCRIPTION="PC/SC Architecture smartcard middleware library"
+HOMEPAGE="http://pcsclite.alioth.debian.org/"
+
+STUPID_NUM="4138"
+MY_P="${PN}-${PV/_/-}"
+SRC_URI="http://alioth.debian.org/download.php/file/${STUPID_NUM}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
+
+# GPL-2 is there for the init script; everything else comes from
+# upstream.
+LICENSE="BSD ISC MIT GPL-3+ GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+# This is called libusb so that it doesn't fool people in thinking that
+# it is _required_ for USB support. Otherwise they'll disable udev and
+# that's going to be worse.
+IUSE="libusb policykit selinux +udev"
+
+REQUIRED_USE="^^ ( udev libusb )"
+
+# No dependencies need the MULTILIB_DEPS because the libraries are actually
+# standalone, the deps are only needed for the daemon itself.
+CDEPEND="${PYTHON_DEPS}
+       libusb? ( virtual/libusb:1 )
+       udev? ( virtual/udev )
+       policykit? ( >=sys-auth/polkit-0.111 )"
+DEPEND="${CDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+       !<app-crypt/ccid-1.4.1-r1
+       !<sys-apps/baselayout-2
+       !<sys-apps/openrc-0.11.8
+       selinux? ( sec-policy/selinux-pcscd )
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.8.11-polkit-pcscd.patch
+)
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+
+       enewgroup openct # make sure it exists
+       enewgroup pcscd
+       enewuser pcscd -1 -1 /run/pcscd pcscd,openct
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               --disable-maintainer-mode
+               --docdir="${EPREFIX}/usr/share/doc/${PF}"
+               --enable-usbdropdir="${EPREFIX}/usr/$(get_libdir)/readers/usb"
+               --enable-ipcdir=/run/pcscd
+               $(multilib_native_use_enable udev libudev)
+               $(multilib_native_use_enable libusb)
+               $(multilib_native_use_enable policykit polkit)
+               "$(systemd_with_unitdir)"
+       )
+       autotools-utils_src_configure
+}
+
+DOCS=( AUTHORS DRIVERS HELP README SECURITY ChangeLog )
+
+multilib_src_install_all() {
+       einstalldocs
+
+       newinitd "${FILESDIR}"/pcscd-init.7 pcscd
+
+       if use udev; then
+               insinto "$(get_udevdir)"/rules.d
+               doins "${FILESDIR}"/99-pcscd-hotplug.rules
+       fi
+
+       python_fix_shebang "${ED}/usr/bin"
+}
+
+pkg_postinst() {
+       elog "Starting from version 1.6.5, pcsc-lite will start as user nobody in"
+       elog "the pcscd group, to avoid running as root."
+       elog ""
+       elog "This also means you need the newest drivers available so that the"
+       elog "devices get the proper owner."
+       elog ""
+       elog "Furthermore, a conf.d file is no longer installed by default, as"
+       elog "the default configuration does not require one. If you need to"
+       elog "pass further options to pcscd, create a file and set the"
+       elog "EXTRA_OPTS variable."
+       elog ""
+       if use udev; then
+               elog "Hotplug support is provided by udev rules; you only need to tell"
+               elog "the init system to hotplug it, by setting this variable in"
+               elog "/etc/rc.conf:"
+               elog ""
+               elog "    rc_hotplug=\"pcscd\""
+       fi
+}