net-mail/fetchmail: Version 6.4.0_rc4
authorJeroen Roovers <jer@gentoo.org>
Sat, 14 Sep 2019 10:50:31 +0000 (12:50 +0200)
committerJeroen Roovers <jer@gentoo.org>
Sat, 14 Sep 2019 10:50:56 +0000 (12:50 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-mail/fetchmail/Manifest
net-mail/fetchmail/fetchmail-6.4.0_rc4.ebuild [new file with mode: 0644]

index 142c72d52e4176bd113e3a302818fb650501e308..04e98d92475c437ade231955f74b2676a6669da4 100644 (file)
@@ -1 +1,2 @@
 DIST fetchmail-6.3.26.tar.xz 1283816 BLAKE2B dd98d7470b8cb65de90cb1d798a2ed3e6aa723bc8e47bcd4d79ca489bdc439fd7204ffb11fea671e292c06616e5a0ccfd9f2689a4f21a1bbbd70677b0f04133e SHA512 8e0a2484e60eaf6c0231e2599e10fec6d207fa1c0fa02ec99b3ef9aea00b6d87275434e79470a25f06e358cdd4a293f9c46a82dd128fe733a99c85144e6caa63
+DIST fetchmail-6.4.0.rc4.tar.xz 1254560 BLAKE2B 9f80cd0f1aa4ecc215e370154069f9b5fab04c84b1a6c196e5911a1481732568d7e391e2098437217c893ee00900e8980a7e59328dacd4e3faaadcdd242a71b4 SHA512 1085668464534f39c7939fdbe845397ca7f9c709bb0f816655643cb5a7d4adcb63e32a534f10303c5366d786bd7fd4650fd960c21f0346a10e78860e11bbd6fd
diff --git a/net-mail/fetchmail/fetchmail-6.4.0_rc4.ebuild b/net-mail/fetchmail/fetchmail-6.4.0_rc4.ebuild
new file mode 100644 (file)
index 0000000..c709406
--- /dev/null
@@ -0,0 +1,108 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1 user systemd toolchain-funcs autotools
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P/_/.}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks libressl"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="ssl? (
+               !libressl? ( >=dev-libs/openssl-0.9.6:= )
+               libressl?  ( dev-libs/libressl:= )
+       )
+       kerberos? (
+               virtual/krb5
+               !libressl? ( >=dev-libs/openssl-0.9.6:= )
+               libressl?  ( dev-libs/libressl:= )
+       )
+       nls? ( virtual/libintl )
+       !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+       socks? ( net-proxy/dante )
+       tk? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+       app-arch/xz-utils
+       sys-devel/flex
+       nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+       "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+pkg_setup() {
+       enewgroup ${PN}
+       enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+
+       use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+       # don't compile during src_install
+       use tk && : > "${S}"/py-compile
+       eautoreconf
+}
+
+src_configure() {
+       use tk || export PYTHON=:
+
+       econf \
+               --enable-RPA \
+               --enable-NTLM \
+               --enable-SDPS \
+               $(use_enable nls) \
+               $(use_with ssl ssl "${EPREFIX}/usr") \
+               $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+               $(use_with kerberos gssapi) \
+               $(use_with kerberos kerberos5) \
+               --without-hesiod \
+               $(use_with socks)
+}
+
+src_compile() {
+       emake AR="$(tc-getAR)"
+}
+
+src_install() {
+       # fetchmail's homedir (holds fetchmail's .fetchids)
+       keepdir /var/lib/${PN}
+       fowners ${PN}:${PN} /var/lib/${PN}
+       fperms 700 /var/lib/${PN}
+
+       default
+
+       newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+       newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+       systemd_dounit  "${FILESDIR}"/${PN}.service
+       systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+       systemd_dotmpfilesd "${FILESDIR}"/${PN}.conf
+
+       docinto contrib
+       local f
+       for f in contrib/* ; do
+               [ -f "${f}" ] && dodoc "${f}"
+       done
+
+       use tk && python_optimize
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]]; then
+               elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+               elog "the polling delay used by the fetchmail init script."
+       fi
+}