dev-python/dbusmock: Version bump to 0.18.3
authorMatt Turner <mattst88@gentoo.org>
Sat, 8 Feb 2020 20:14:01 +0000 (12:14 -0800)
committerMatt Turner <mattst88@gentoo.org>
Sat, 8 Feb 2020 20:14:05 +0000 (12:14 -0800)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-python/dbusmock/Manifest
dev-python/dbusmock/dbusmock-0.18.3.ebuild [new file with mode: 0644]

index 5f6a671d2f1e7a0c86c79f20fa62338b7d792726..27146fc4878ffed030e019e14ff587e227c62617 100644 (file)
@@ -1 +1,2 @@
 DIST dbusmock-0.18.2.tar.gz 72031 BLAKE2B 44b46f05e48f1178fe95e44c83899bbef5bc64dcee856be1b332890893a5b901a03c236ad9a8cc6cf2ece83efbf5ec798551320a098736ff95c13951333ffaa3 SHA512 2421cea872e1d84db639cae0d6cc10c4b80ccf64903b7b3f437cb58ad8e3d957c30c871f9666a7a7774808b4b56d6116959ea03fdc8b575ed98023b77b61c8a0
+DIST dbusmock-0.18.3.tar.gz 72049 BLAKE2B b5ed8ebcae51fedec75fc810e07dc9a38223bcde541cbfddd5d3fbf1ad45d1458e6ad39c1fc69ee77165d751f978cb4483929e823eacbc99a7ae414aebf4d0f0 SHA512 6f7b42eae578ce03024b3b5cc85e82f04a467803f4c8b4cb5193454dcd849038f11e6ce5028ca9dd57ea5a9380c1b754d8fc644b4a24b51deee9e87b409115c3
diff --git a/dev-python/dbusmock/dbusmock-0.18.3.ebuild b/dev-python/dbusmock/dbusmock-0.18.3.ebuild
new file mode 100644 (file)
index 0000000..b5aafa0
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="https://github.com/martinpitt/${MY_PN}/releases/download/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/dbus-python[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+       )"
+
+PATCHES=(
+       "${FILESDIR}"/0.18.2-disable-polkitd-tests.patch
+)
+
+python_test() {
+       nosetests --verbose || die "tests fail under ${EPYTHON}"
+}
+
+python_install_all() {
+       local DOCS=( NEWS README.rst )
+
+       distutils-r1_python_install_all
+}