x11-themes/QGnomePlatform: Bump to 0.6.1
authorPacho Ramos <pacho@gentoo.org>
Wed, 20 May 2020 20:16:03 +0000 (22:16 +0200)
committerPacho Ramos <pacho@gentoo.org>
Wed, 20 May 2020 20:16:03 +0000 (22:16 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
x11-themes/QGnomePlatform/Manifest
x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild [new file with mode: 0644]

index 94c9d978f6d607811379ed6ede7171fc886f5e78..0d0b5fcc224476d7f5b25526a12ee22ed8dc785c 100644 (file)
@@ -1 +1,2 @@
 DIST QGnomePlatform-0.6.0.tar.gz 28618 BLAKE2B af4ef5c54a8056a370a8d6299fd80bace2491a97c9bff99ce5a461a1c3ab07c6a5336fa88606805e37102ccc648217722331ec9e572ce3708581b713ee399d0d SHA512 c5aad4518e1c9d06b2561a6f8a6a169bf9a07ec0a63602d3bc5b0f91e1134504f5ca0e5a76bda3183165c72bf8de3e9297b51fe37879d80c1fbe4ca06e242a97
+DIST QGnomePlatform-0.6.1.tar.gz 28996 BLAKE2B 3d0da37fcc8e85bd59263dffb19865666d25dd50d2c1e00b4d6358d745eb7079f415058ffb75a8228c9c7ed956003a656b3e10a3467d9fc9dcd5eee2c14bf7cd SHA512 5e0bab45a8ff4c56e6e34d636ed719ce1a087f116942dd356253403d4be40aac348ccbdbfc917f65f6cc4df8619e1031734f0a46a36d4d9b7bb4838ded61570c
diff --git a/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild b/x11-themes/QGnomePlatform/QGnomePlatform-0.6.1.ebuild
new file mode 100644 (file)
index 0000000..65c5840
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="A Qt Platform Theme aimed to accommodate GNOME settings"
+HOMEPAGE="https://github.com/FedoraQt/QGnomePlatform"
+SRC_URI="https://github.com/FedoraQt/QGnomePlatform/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       >=dev-qt/qtwidgets-5.6:5=
+       dev-qt/qtwayland:5=
+       dev-qt/qtx11extras:5=
+       x11-libs/gtk+:3[X]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+src_configure() {
+       eqmake5
+}
+
+src_install() {
+       INSTALL_ROOT="${D}" default
+}