www-servers/monkeyd: major bump to 1.6.0.
authorAnthony G. Basile <blueness@gentoo.org>
Mon, 10 Aug 2015 19:04:45 +0000 (15:04 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Mon, 10 Aug 2015 19:06:09 +0000 (15:06 -0400)
Package-Manager: portage-2.2.20

www-servers/monkeyd/Manifest
www-servers/monkeyd/metadata.xml
www-servers/monkeyd/monkeyd-1.6.0.ebuild [new file with mode: 0644]

index acca2cbcbcda2d12819f245264609c523ecb95bd..52f20be091ac49e98f7b318285ecbc927807cc99 100644 (file)
@@ -1,3 +1,4 @@
 DIST monkey-1.5.3.tar.gz 892478 SHA256 0ac300e04f052818bc26b7da0183c3c5cd13be8090aaabd3505838587be8c0ec SHA512 6a55ba580bfde3c11329e94055d287e341990e4db4cb5ab12e40b8bab57b4b51fd57cd33fc5aa9d864127f235888f818593be26fe93daa34ca3c40fa8936465f WHIRLPOOL 4038bd2f0b39f6068ab69dc98dec4d5b29feca388c18361f57b653db86c38469d69072ae803ddd565e57350163247072334835216a13d014956a27b91c8a42b6
 DIST monkey-1.5.5.tar.gz 898602 SHA256 5a0554fdb4d8746f5eb665f305bd120c8f2bef3e7fea2a43be6b472461b45b05 SHA512 faf86a36a91c8b1e47f3a2ea7f19aee98eada6f3348ff64f160fc388c268a146d49ad9434043731cf928fca6708db40fa5e1daedc41d4b8cce671f98d590b920 WHIRLPOOL 26b44624f77b72bbd31da6be5855429199a0fc9ab163548f1d0f21a34b84a1f0325241ed7ad5ecbb28c9e9f899458b5d8c15f9f91e27b73a53023c2e3152947d
 DIST monkey-1.5.6.tar.gz 902636 SHA256 7c3d845306aa74ee6effd7ab6169d16ac4e6450e564954d0d0baa2d1e9be1a22 SHA512 4c7c627cb047252252b22da5fba179a21fb5b8dc6280b96307af52757ad049d24b0daaaea51dca4f0429af5e6499c239f6b62a03654cc9e7ad98ae8f5149b64c WHIRLPOOL aba1a928023fc67224f254182eb9707c6594c7092d9ff98ecfa297c91d5c61f79235e7467192b5d46ac114ae67a3cee98e06704721348a40ee825755ab39d9a1
+DIST monkey-1.6.0.tar.gz 1915116 SHA256 bd6d126aba461b16def25eb7d9226c1256063d6c82cd0a2a92f634e9b959fddd SHA512 4cb916d13619a78ad067f0ac47d82d88425dbe0458cba6c580694caf9455a2141c78980af7143f24f82eb41d1d5c842f4765117d9c7b4d657c728c38a1315627 WHIRLPOOL 0681aac08412e15a2279c2cde0446357c35450d4e2fc97b642ae3adbcfa020aafd8f410f7d48603d1004266f5c11ddc5587a186a4718fd9146deb8f7c4f70652
index f81ac37e2e765c570bf5f065fdb6e010f2effa29..05bf7e3f659e82e55045861a39282e5d6b46c86c 100644 (file)
@@ -9,5 +9,6 @@
                <flag name="debug">Enable lots of debugging info</flag>
                <flag name="jemalloc">Use dev-libs/jemalloc for allocations</flag>
                <flag name="minimal">Do not install shared lib and include files</flag>
+               <flag name="static-plugins">Build statically linked plugins</flag>
        </use>
 </pkgmetadata>
diff --git a/www-servers/monkeyd/monkeyd-1.6.0.ebuild b/www-servers/monkeyd/monkeyd-1.6.0.ebuild
new file mode 100644 (file)
index 0000000..3f55619
--- /dev/null
@@ -0,0 +1,119 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit toolchain-funcs depend.php multilib
+
+MY_P="${PN/d}-${PV}"
+DESCRIPTION="A small, fast, and scalable web server"
+HOMEPAGE="http://www.monkey-project.com/"
+SRC_URI="http://monkey-project.com/releases/${PV:0:3}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+
+# Currently monkeyd_plugins_tls is off.  It provides mbed TLS (formerly PolarSSL).
+# jemalloc is also off until we figure out how to work CMakeLists.txt magic.
+#PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
+#IUSE="cgi -debug fastcgi jemalloc php static-plugins ${PLUGINS}"
+
+PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril"
+IUSE="cgi -debug fastcgi php static-plugins ${PLUGINS}"
+
+# uclibc is often compiled without backtrace info so we should
+# force this off.  If someone complains, consider relaxing it.
+REQUIRED_USE="
+       elibc_uclibc? ( !debug )
+       cgi? ( php )"
+
+#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
+DEPEND=""
+RDEPEND="
+       php? ( dev-lang/php )
+       cgi? ( dev-lang/php[cgi] )"
+
+S="${WORKDIR}/${MY_P}"
+
+WEBROOT="/var/www/localhost"
+
+pkg_setup() {
+       if use debug; then
+               ewarn
+               ewarn "\033[1;33m**************************************************\033[00m"
+               ewarn "Do not use debug in production!"
+               ewarn "\033[1;33m**************************************************\033[00m"
+               ewarn
+       fi
+}
+
+src_prepare() {
+       # Unconditionally get rid of the bundled jemalloc and mbedTLS
+       rm -rf "${S}"/deps
+}
+
+src_configure() {
+       local myconf=""
+
+       use elibc_uclibc && myconf+=" --uclib-mode"
+       use elibc_musl && myconf+=" --musl-mode"
+
+       #use jemalloc || myconf+=" --malloc-libc"
+       myconf+=" --malloc-libc"
+
+       if use debug; then
+               myconf+=" --debug --trace"
+       else
+               myconf+=" --no-backtrace"
+       fi
+
+       local enable_plugins=""
+       local disable_plugins=""
+       # We use 'cgi' and 'fastcgi' because they are global flags
+       # instead of the corresponding monkeyd_plugins_*
+       use cgi && enable_plugins+="cgi," || disable_plugins+="cgi,"
+       use fastcgi && enable_plugins+="fastcgi," || disable_plugins+="fastcgi,"
+       # For the rest, we scan the monkeyd_plugins_* and parse out the plugin name.
+       for p in ${PLUGINS}; do
+               pp=${p/+/}
+               cp=${pp/monkeyd_plugins_/}
+               use $pp && enable_plugins+="${cp}," || disable_plugins+="${cp},"
+       done
+       myconf+=" --enable-plugins=${enable_plugins%,} --disable-plugins=${disable_plugins%,}"
+       if use static-plugins; then
+               myconf+=" --static-plugins=${enable_plugins%,}"
+       fi
+
+       # Non-autotools configure
+       ./configure \
+               --pthread-tls \
+               --prefix=/usr \
+               --sbindir=/usr/sbin \
+               --webroot=${WEBROOT}/htdocs \
+               --logdir=/var/log/${PN} \
+               --mandir=/usr/share/man \
+               --libdir=/usr/$(get_libdir) \
+               --pidfile=/run/monkey.pid \
+               --sysconfdir=/etc/${PN} \
+               ${myconf} \
+               || die
+}
+
+src_install() {
+       default
+
+       newinitd "${FILESDIR}"/monkeyd.initd monkeyd
+       newconfd "${FILESDIR}"/monkeyd.confd monkeyd
+
+       #move htdocs to docdir, bug #429632
+       docompress -x /usr/share/doc/"${PF}"/htdocs.dist
+       mv "${D}"${WEBROOT}/htdocs \
+               "${D}"/usr/share/doc/"${PF}"/htdocs.dist
+       mkdir "${D}"${WEBROOT}/htdocs
+
+       keepdir \
+               /var/log/monkeyd \
+               ${WEBROOT}/htdocs
+}