dev-haskell/hashable-time: pew kacgae, a depend of dev-haskell/aeson-1
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 20:41:27 +0000 (20:41 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:56:53 +0000 (21:56 +0000)
Hashable instances for Data.Time

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/hashable-time/Manifest [new file with mode: 0644]
dev-haskell/hashable-time/hashable-time-0.2.ebuild [new file with mode: 0644]
dev-haskell/hashable-time/metadata.xml [new file with mode: 0644]

diff --git a/dev-haskell/hashable-time/Manifest b/dev-haskell/hashable-time/Manifest
new file mode 100644 (file)
index 0000000..77debf1
--- /dev/null
@@ -0,0 +1 @@
+DIST hashable-time-0.2.tar.gz 2111 SHA256 97b722ab467fae0d499de91bfaf3d6e346c7c1cac126796f0031aee5dbfe2b0a SHA512 0a05707019f2cc19c26a4dac955c5f31f334589074b7ecff15ae60654dea1376205b897d674fa4b1369dec62ca4f93a061250baabccf30f877ea984495df1211 WHIRLPOOL cdea6ae8084c465e8d301fd07be2ef1cc9de4db324de9783d7ebc553677cf367a300f75d1b05a734adeddd4c77ffe13bf95cd171f054e40b6cc05bd48921c8de
diff --git a/dev-haskell/hashable-time/hashable-time-0.2.ebuild b/dev-haskell/hashable-time/hashable-time-0.2.ebuild
new file mode 100644 (file)
index 0000000..6efcfe6
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Hashable instances for Data.Time"
+HOMEPAGE="http://hackage.haskell.org/package/hashable-time"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.2.3.3:=[profile?]
+       >=dev-haskell/old-locale-1.0:=[profile?] <dev-haskell/old-locale-1.1:=[profile?]
+       >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.18.1.3
+"
+
+src_prepare() {
+       default
+
+       cabal_chdeps \
+               'base >=4.7 && <4.9' 'base >=4.7' \
+               'hashable >=1.2.3.3 && <=1.3' 'hashable >=1.2.3.3'
+}
diff --git a/dev-haskell/hashable-time/metadata.xml b/dev-haskell/hashable-time/metadata.xml
new file mode 100644 (file)
index 0000000..7d4c050
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>haskell@gentoo.org</email>
+               <name>Gentoo Haskell</name>
+       </maintainer>
+       <longdescription>
+               Hashable instances for types in Data.Time
+       </longdescription>
+</pkgmetadata>