dev-libs/libfmt: 6.2.0 version bump
authorCraig Andrews <candrews@gentoo.org>
Mon, 6 Apr 2020 13:50:41 +0000 (09:50 -0400)
committerCraig Andrews <candrews@gentoo.org>
Mon, 6 Apr 2020 13:55:56 +0000 (09:55 -0400)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-libs/libfmt/Manifest
dev-libs/libfmt/libfmt-6.2.0.ebuild [new file with mode: 0644]

index f3d23b1a402ee4293086cb82eb0a9e4e72110d41..151bd564f699af3236e62117d315ddbebfe9ba82 100644 (file)
@@ -1 +1,2 @@
 DIST libfmt-6.1.2.tar.gz 723160 BLAKE2B 36e7451a8732c62dcbf47e6d287ea582827b6196a468b8648803ea1bc9a37a5f681d87488f748d749183d97783ac7fb47a3f2aeed64fc6a684f9ee85b67ae28d SHA512 8770bf4bd2bb6d938e75e0cf1e665c41930dbd9d2a6825274a5a43cd1d85b9c9ca621bb040ed099429f0e16bddbc3399361c453eb1bf3fc01376e6ad9dd875b7
+DIST libfmt-6.2.0.tar.gz 733403 BLAKE2B c7ff69a56b90ec8df7d1af5c9934592449f2052046192aa498a6440d2aab76f10c17fa2833a41475b777dca2e3a1ae671021530bf0ef8be12443541f0f5212b3 SHA512 0003543f437bae416600a2b982eb133f65588bd36d7506fa7d883ae3133fcaf7ad825904af9b588ea22e5d91e56560aaf4243a6afa11ff6d8aace2e4bb1b0cee
diff --git a/dev-libs/libfmt/libfmt-6.2.0.ebuild b/dev-libs/libfmt/libfmt-6.2.0.ebuild
new file mode 100644 (file)
index 0000000..78c2d74
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+LICENSE="MIT"
+IUSE="test"
+SLOT="0/$(ver_cut 1)"
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+       S="${WORKDIR}/fmt-${PV}"
+fi
+
+DEPEND=""
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+               -DFMT_LIB_DIR="$(get_libdir)"
+               -DFMT_TEST=$(usex test)
+       )
+       cmake_src_configure
+}