net-analyzer/metasploit: bug #653024
authorRick Farina <zerochaos@gentoo.org>
Fri, 7 Dec 2018 17:14:55 +0000 (12:14 -0500)
committerRick Farina <zerochaos@gentoo.org>
Fri, 7 Dec 2018 17:17:39 +0000 (12:17 -0500)
move from /usr/$(get_libdir) to /usr/lib

Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Rick Farina <zerochaos@gentoo.org>
net-analyzer/metasploit/metasploit-4.17.21-r3.ebuild [moved from net-analyzer/metasploit/metasploit-4.17.21-r2.ebuild with 95% similarity]
net-analyzer/metasploit/metasploit-9999.ebuild

similarity index 95%
rename from net-analyzer/metasploit/metasploit-4.17.21-r2.ebuild
rename to net-analyzer/metasploit/metasploit-4.17.21-r3.ebuild
index 73c86666c95415baac577ab23c0385915fda77ff..32cb686d0d8d6af28a660e7557fce438e0125245 100644 (file)
@@ -302,9 +302,9 @@ each_ruby_install() {
 
        #I'm 99% sure that this will only work for as long as we only support one ruby version.  Creativity will be needed if we wish to support multiple.
        # should be as simple as copying everything into the target...
-       dodir /usr/$(get_libdir)/${PN}${SLOT}
-       cp -R * "${ED}"/usr/$(get_libdir)/${PN}${SLOT} || die "Copy files failed"
-       rm -Rf "${ED}"/usr/$(get_libdir)/${PN}${SLOT}/documentation "${ED}"/usr/$(get_libdir)/${PN}${SLOT}/README.md
+       dodir /usr/lib/${PN}${SLOT}
+       cp -R * "${ED}"/usr/lib/${PN}${SLOT} || die "Copy files failed"
+       rm -Rf "${ED}"/usr/lib/${PN}${SLOT}/documentation "${ED}"/usr/lib${PN}${SLOT}/README.md
        fowners -R root:0 /
 
 }
@@ -313,16 +313,16 @@ all_ruby_install() {
        # do not remove LICENSE, bug #238137
        dodir /usr/share/doc/${PF}
        cp -R {documentation,README.md} "${ED}"/usr/share/doc/${PF} || die
-       ln -s "../../share/doc/${PF}/documentation" "${ED}/usr/$(get_libdir)/${PN}${SLOT}/documentation"
+       ln -s "../../share/doc/${PF}/documentation" "${ED}/usr/lib/${PN}${SLOT}/documentation"
 
-       fperms +x /usr/$(get_libdir)/${PN}${SLOT}/msfupdate
+       fperms +x /usr/lib/${PN}${SLOT}/msfupdate
 
        #tell revdep-rebuild to ignore binaries meant for the target
        dodir /etc/revdep-rebuild
        cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-metasploit${SLOT}
                #These dirs contain prebuilt binaries for running on the TARGET not the HOST
-               SEARCH_DIRS_MASK="/usr/lib*/${PN}${SLOT}/data/meterpreter"
-               SEARCH_DIRS_MASK="/usr/lib*/${PN}${SLOT}/data/exploits"
+               SEARCH_DIRS_MASK="/usr/lib/${PN}${SLOT}/data/meterpreter"
+               SEARCH_DIRS_MASK="/usr/lib/${PN}${SLOT}/data/exploits"
        EOF
 }
 
index 73c86666c95415baac577ab23c0385915fda77ff..c4fc0fdabcdb8edad7bc6fa780cdb3f98c928eac 100644 (file)
@@ -302,9 +302,9 @@ each_ruby_install() {
 
        #I'm 99% sure that this will only work for as long as we only support one ruby version.  Creativity will be needed if we wish to support multiple.
        # should be as simple as copying everything into the target...
-       dodir /usr/$(get_libdir)/${PN}${SLOT}
-       cp -R * "${ED}"/usr/$(get_libdir)/${PN}${SLOT} || die "Copy files failed"
-       rm -Rf "${ED}"/usr/$(get_libdir)/${PN}${SLOT}/documentation "${ED}"/usr/$(get_libdir)/${PN}${SLOT}/README.md
+       dodir /usr/lib/${PN}${SLOT}
+       cp -R * "${ED}"/usr/lib/${PN}${SLOT} || die "Copy files failed"
+       rm -Rf "${ED}"/usr/lib/${PN}${SLOT}/documentation "${ED}"/usr/lib/${PN}${SLOT}/README.md
        fowners -R root:0 /
 
 }
@@ -313,16 +313,16 @@ all_ruby_install() {
        # do not remove LICENSE, bug #238137
        dodir /usr/share/doc/${PF}
        cp -R {documentation,README.md} "${ED}"/usr/share/doc/${PF} || die
-       ln -s "../../share/doc/${PF}/documentation" "${ED}/usr/$(get_libdir)/${PN}${SLOT}/documentation"
+       ln -s "../../share/doc/${PF}/documentation" "${ED}/usr/lib/${PN}${SLOT}/documentation"
 
-       fperms +x /usr/$(get_libdir)/${PN}${SLOT}/msfupdate
+       fperms +x /usr/lib/${PN}${SLOT}/msfupdate
 
        #tell revdep-rebuild to ignore binaries meant for the target
        dodir /etc/revdep-rebuild
        cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-metasploit${SLOT}
                #These dirs contain prebuilt binaries for running on the TARGET not the HOST
-               SEARCH_DIRS_MASK="/usr/lib*/${PN}${SLOT}/data/meterpreter"
-               SEARCH_DIRS_MASK="/usr/lib*/${PN}${SLOT}/data/exploits"
+               SEARCH_DIRS_MASK="/usr/lib/${PN}${SLOT}/data/meterpreter"
+               SEARCH_DIRS_MASK="/usr/lib/${PN}${SLOT}/data/exploits"
        EOF
 }