use cleaner method of supporting multilib
authorMike Frysinger <vapier@gentoo.org>
Tue, 20 Jun 2006 19:17:46 +0000 (19:17 +0000)
committerMike Frysinger <vapier@gentoo.org>
Tue, 20 Jun 2006 19:17:46 +0000 (19:17 +0000)
Package-Manager: portage-2.1.1_pre1-r1

games-emulation/nestra/nestra-0.66-r1.ebuild
games-emulation/snes9x/snes9x-1.43-r1.ebuild
games-emulation/zsnes/zsnes-1.42.ebuild

index 903d93c5ea60bdbbbe55c0bf29b1b2b4eb5b57a2..89b679b5b989cb4ac2f98fee2dbee5fafe2c94d8 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.13 2006/02/11 04:44:27 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.14 2006/06/20 19:16:06 vapier Exp $
 
-inherit eutils toolchain-funcs flag-o-matic games
+inherit eutils toolchain-funcs flag-o-matic multilib games
 
 PATCH="${P/-/_}-7.diff"
 DESCRIPTION="NES emulation for Linux/x86"
@@ -21,11 +21,6 @@ DEPEND="${RDEPEND}"
 
 S=${WORKDIR}/${PN}
 
-pkg_setup() {
-       games_pkg_setup
-       use amd64 && export ABI=x86
-}
-
 src_unpack() {
        unpack ${A}
        cd "${S}"
@@ -40,6 +35,11 @@ src_unpack() {
                || die "sed failed"
 }
 
+src_compile() {
+       use amd64 && multilib_toolchain_setup x86
+       games_src_compile
+}
+
 src_install() {
        dogamesbin nestra || die "dogamesbin failed"
        dodoc BUGS CHANGES README
index bfc59a026a172f60341e3aed4cdbdbb2675f6c4f..3e44e18e432632d8470113544b6eb77de4365dae 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.8 2006/04/13 20:33:52 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.43-r1.ebuild,v 1.9 2006/06/20 19:17:46 vapier Exp $
 
 # 3dfx support (glide) is disabled because it requires
 # glide-v2 while we only provide glide-v3 in portage
@@ -36,11 +36,6 @@ DEPEND="${RDEPEND}
 
 S=${WORKDIR}/${P}-src
 
-pkg_setup() {
-       games_pkg_setup
-       use amd64 && [[ -z ${NATIVE_AMD64_BUILD_PLZ} ]] && has_multilib_profile && ABI=x86
-}
-
 src_unpack() {
        unpack ${A}
        cd "${S}"/snes9x
@@ -64,6 +59,8 @@ src_unpack() {
 }
 
 src_compile() {
+       [[ -z ${NATIVE_AMD64_BUILD_PLZ} ]] && use amd64 && multilib_toolchain_setup x86
+
        local vidconf=
        local target=
        local vid=
index 2d7e014663d57eba9519b20f1dfcf56e1481ba24..4e64e501b7b7e23cc81c95d311798640ab411974 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.12 2006/04/13 20:36:47 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.42.ebuild,v 1.13 2006/06/20 19:17:03 vapier Exp $
 
-inherit eutils flag-o-matic games
+inherit eutils flag-o-matic multilib games
 
 DESCRIPTION="SNES (Super Nintendo) emulator that uses x86 assembly"
 HOMEPAGE="http://www.zsnes.com/ http://ipherswipsite.com/zsnes/"
@@ -23,12 +23,7 @@ DEPEND="${RDEPEND}
        sys-devel/automake
        >=sys-devel/autoconf-2.58"
 
-S="${WORKDIR}/${PN}_${PV//./_}"
-
-pkg_setup() {
-       games_pkg_setup
-       use amd64 && export ABI=x86
-}
+S=${WORKDIR}/${PN}_${PV//./_}
 
 src_unpack() {
        unpack ${A}
@@ -40,6 +35,7 @@ src_unpack() {
 }
 
 src_compile() {
+       use amd64 && multilib_toolchain_setup x86
        cd src
        egamesconf \
                $(use_enable png libpng) \